The MU forums have moved to WordPress.org

Links broken after restoring 2.3.1 installation following failed upgrade (4 posts)

  1. librlart
    Member
    Posted 13 years ago #

    First I'm trying to recover my WordPress MU installation so it's fully functional.

    Second I'm trying to upgrade to the current version. I'm assuming I will have to do multiple incremental upgrades to get this to work, is this right?

    I'm running WordPress MU version=2.3.1
    The path to the installation is http://destinymanifestation.com/wordpressmu/

    I tried to upgrade to 2.7 using the Automatic Upgrade button in the manage section. I backed up the database before I did this. It completed the script and its own backups, but then created a new blog and I was unable to access any of my old blogs. The new upgraded version worked but I lost all the old content.

    I didn't backup the htaccess file; it took me a while to figure out where it was supposed to be, but there doesn't seem to be one present. Media Temple says they should be placed in the root directory of the account. Even with invisible files displayed, it doesn't show up there or in the Wordpress MU directory.

    I deleted the new database created by the upgrade script, then restored the old database. Then I uploaded the old wordpress MU files. Now my blog's front pages show up, with most of their content, but none of the links work (except internal links while logged in, like the Dashboard, Site Admin, etc).

    I did a test post, and the post was created but I couldn't link to it from the Write page via the "View Site" link:

    http://destinymanifestation.com/wordpressmu/

    Got this error message:
    Not Found
    The requested URL /wordpressmu/2009/05/27/reinstall-trial-post/ was not found on this server.
    Apache/2.0.54 Server at destinymanifestation.com Port 80

    I reloaded the front page of the blog and it had shown up and been published.

    I suspect this all has something to do with the wp-config.php file or the htaccess file, but can't figure out the problem. (I simply re-installed the old wp-config.php file and didn't have the install script generate it.)
    ------------------
    wp-config.php excerpt:

    define('VHOST', 'yes');
    $base = '/wordpressmu/';

    // double check $base
    if( $base == 'BASE' )
    die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    define ('WPLANG', '');

    define( "WP_USE_MULTIPLE_DB", false );

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ------------------
    Any suggestions what I can do to fix this?

    Thanks!
    - Arthur

    Other information:
    The main WordPress MU Administrative blog is here:
    http://destinymanifestation.com/wordpressmu/

    These are some of the blogs created from it:
    http://arthur.destinymanifestation.com/wordpressmu/
    http://yogiblog.destinymanifestation.com/wordpressmu/
    http://bass.destinymanifestation.com/wordpressmu/
    http://dmdm.destinymanifestation.com/wordpressmu/

    Other similar problems:
    --------------------
    http://dmdm.destinymanifestation.com/wordpressmu/
    Tried to load a static page I originally created in the blog called "Links"

    http://dmdm.destinymanifestation.com/wordpressmu/links/
    Not Found
    The requested URL /wordpressmu/links/ was not found on this server.
    Apache/2.0.54 Server at dmdm.destinymanifestation.com Port 80
    --------------------
    Here's the same problem on one of the other blogs:
    http://bass.destinymanifestation.com/wordpressmu/

    Not Found
    The requested URL /wordpressmu/about/ was not found on this server.
    Apache/2.0.54 Server at bass.destinymanifestation.com Port 80
    --------------------

  2. Ovidiu
    Member
    Posted 13 years ago #

    did you restore your .htaccess file? if its missing it explains your problem.

    Ok, re-read your text. download wpmu, check the sample .htaccess file there, try and manually adapt it for your needs if you lost the old one.

  3. andrea_r
    Moderator
    Posted 13 years ago #

    "I tried to upgrade to 2.7 using the Automatic Upgrade button in the manage section."

    Well, I think I foudn your problem. This isn't built in to earlier verison, so you must have used a plugin, and got the single WP by mistake. Because the auto-upgrade plugin was for single WP.

    When you restored, you missed the htaccess file as noted above.

    When you get that working, please upgrade according this this:
    http://codex.wordpress.org/Upgrading_WPMU

    you'll probably be able to dump a few plugins along the way. especially the auto-upgrade one as you won;t need it.

  4. librlart
    Member
    Posted 13 years ago #

    Thanks folks. I deleted the db, re-installed from scratch, then replaced the db and did incremental upgrades through 2.7 and it seems to finally be working again. Although the upgrade instructions for the wp-config file on the codex are fairly convoluted and didn't work when adding the lines to the 2.6 wp-config. I just moved the 2.6 config over and added the lines that were requested after logging in. Now on to sort through the plugins...

About this Topic

  • Started 13 years ago by librlart
  • Latest reply from librlart