The MU forums have moved to WordPress.org

How do you make your main blog an RSS for the other blogs? (9 posts)

  1. spiffking03
    Member
    Posted 13 years ago #

    I'd like to have it post the most recent posts on the main blog, but I have yet to figure out a good way to pull this one off. I can get it as a widget, but I'd rather it be the main content. Ideas?

  2. spiffking03
    Member
    Posted 13 years ago #

    I should also include my most recent brilliant idea is to use a static front page but I still haven't cracked the RSS nut to put two and two together.

  3. dsader
    Member
    Posted 13 years ago #

    I, too, endorse Donncha's Sitewide Tags plugin.

    http://mu.wordpress.org/forums/topic/11262

    Have you given it a try? Every post in the site will be aggregated in the main blog content. The default RSS feed of the main blog then becomes the sitewide feed. The front page content loop becomes the sitewide content loop, etc, etc.

    Many of the usual Wordpress tricks can be used to show off sitewide content in your main blog: search, archive, author, category, tags.

    Sounds like what you are after.

    You will get help around here to set it up the plugin and keep it going, I'm certain. Many posts here likely solve any snafu you could encounter. Give it a whirl.

  4. spiffking03
    Member
    Posted 13 years ago #

    Thank you very much for the help and the idea. I've hit a 4 a.m. wall and am deciding to call it a night, but before I do I was wondering if there was anything special I had to do to make the plugin work since I installed it and it doesn't seem to be aggregating. I enabled it in the options section, checked the box for it to be use the main blog and I have nada. Ideas?

  5. Ovidiu
    Member
    Posted 13 years ago #

    Like it says in the readme, it only works for posts posted after the plugin was installed...

  6. andrea_r
    Moderator
    Posted 13 years ago #

    .. and the blogs have to be set to Public. :)

  7. spiffking03
    Member
    Posted 13 years ago #

    Forgot to add that I did make sample posts on other blogs after installing it and I just checked them and they are set to public. Now you see why this was driving me up the wall last night...

  8. spiffking03
    Member
    Posted 13 years ago #

    So after racking my brain for awhile I figured out a solution that made the damn thing work. I deactivated it site wide, then activated it within the admin panel, then in an individual blog. Success!

  9. Ovidiu
    Member
    Posted 13 years ago #

    I deactivated it site wide, then activated it within the admin panel, then in an individual blog.

    what do you mean you deactivated it sitewide? you're supposed to put it into the mu-plugins folder!!!

    the instructions say:

    Install
    
       1. Copy sitewide-tags.php into wp-content/mu-plugins/

About this Topic

  • Started 13 years ago by spiffking03
  • Latest reply from Ovidiu