The MU forums have moved to WordPress.org

Permalinks not working, images not showing up - .htaccess Problem (9 posts)

  1. gautammandewalker
    Member
    Posted 15 years ago #

    Hi,

    I moved 3 different wordpress installations to one single Wordpress MU.
    Every thing except Permalinks are not working and images are not loading on the webpages.

    Image URL style
    http://subdomain.domain.com/files/2009/05/image.gif
    Shows 404.
    but if change i change it to

    http://subdomain.domain.com/wp-content/blogs.dir/4/files/2009/05/image.gif

    It works perfectly fine.

    I tried everything found on this forum and other forums.
    My .htaccess file has following content

    RewriteEngine On
    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    My mod_rewrite is active.
    I am setting up this on an EC2 Instance.

  2. dlandgraf
    Member
    Posted 15 years ago #

    I'm having the exact same issue on a new install of wordpressmu? Do you have any suggestions on how to fix this?

  3. Jeremy32
    Member
    Posted 15 years ago #

    En mi caso sucede casi lo mismo pero con la forma http://dominio.com/usuario

    hace como 2 semanas que intento encontrar la solución =(

    ¿alguna sugerencia?

    Nota:
    La instalación es nueva

  4. oregondean
    Member
    Posted 14 years ago #

    I just fixed a similar problem ...

    AllowOverride needed to be set to All (I think caps are important) in the Apache *.conf file for the specific website.

    Apache2 ... Mac OSX Server 10.5.x Leopard

  5. enzo24
    Member
    Posted 14 years ago #

    Here's my workaround :

    I just put a soft link into the site using ssh (putty)

    ln -s /path_to_site/wp-content/blogs.dir/1/files/ /path_to_site/

    This creates a shortcut called files at the root of your site.
    Be sure to put the path to your website files (replace path_to_site). In my case it was /home/www/ (could be /var/www/ for you...)

    (This will work for a single WP setup... not so sure for WP_MU.. I'll check it out...on multiple users..)

  6. enzo24
    Member
    Posted 14 years ago #

    This doesn't work at all on WordPress MU :(

    However the answer above mine does work.

    I changed the AllowOverride from None to All in the Site setting for apache...

    Let me phrase it correctly :

    Look here :

    /etc/apache2/sites-available/default

    You set up variables for virtual sites and you have settings : It starts with :

    <Virtualhost *>
    .../...
    <Directory />
    ...
    AllowOverride None (CHANGE THIS TO 'All' - CASE SENSITIVE)
    ...
    </Virtualhost>

    After having done this change to file, type this command :

    /etc/init.d/apache2 restart

    This reloads Apache2 with the new settings & low & behold... url rewriting conditions in the .htaccess file of your WPMU setup is taken in account & everything works !

    Hope this does help.
    Regards & sorry for the mess above...

  7. ashaw
    Member
    Posted 14 years ago #

    enzo24, thanks for the post!!! I've been scratching my head for days looking for a solution and this did the trick. Beauty!

  8. randyftx
    Member
    Posted 14 years ago #

    Just a little more information on how this is done.

    In Linux - am using a Redhat variation - you go to /etc/httpd/conf
    You edit the httpd.conf file.
    Locate AllowOverride None - change it to All
    Save your file
    Restart Apache

    This worked for me.

  9. dwheeler
    Member
    Posted 14 years ago #

    I struggled with this issue for day's after I moved the site.

    Try to pull up an image then check your error logs, the answer may be in there.

    My issue was that the wp-content directory was group writeable.

    I chaanged the permissions to 755 and it worked perfectly after that.

About this Topic

  • Started 15 years ago by gautammandewalker
  • Latest reply from dwheeler