The MU forums have moved to

BUG: New user registration fails (10 posts)

  1. plug_n_author
    Posted 9 years ago #

    We are running WPMU 2.7.1 and the public side of user registration doesn't work at all. We fill in the registration information, click "Next", wait a while, and then it attempts to download 0 bytes on Firefox and IE says it fails to load the target page. We would like to turn registration on as our users are complaining.

  2. tdjcbe
    Posted 9 years ago #

    Have you checked the webserver's error logs?

    I can't try it because you;re using a captcha.

  3. plug_n_author
    Posted 9 years ago #

    RTM, huh? Well, let's see what I can do to satisfy your request:

    * Is VHOST true or false?


    define('VHOST', 'no');

    * Is the path to your WordPress? MU install "/" or some directory?

    "/" (root directory)

    * Anything in the error logs? If you didn't get a welcome email, check your mail logs.

    [Tue Jun 02 13:58:45 2009] [notice] child pid 13442 exit signal Bus error (10)

    * Did you receive any sort of error within your browser? If so, what was the specific error?

    Blank page/attempted download of 0 byte content/error page (depending on the browser).

    * Does the information in wp_blogs, wp_users and wp_site match your blog, user and site?

    It better. Brand new install as of yesterday. About the 10th time we've reinstalled this software. We've had this problem since the beginning of testing it.

    * Mention the version number, SVN check-in number or the date you downloaded the snapshot.

    WPMU 2.7.1

    * Plugins in place? Have you tried turning them off and seeing if that affects the issue?

    Yes. Have tried turning off all plugins (including the reCAPTCHA plugin) - still have the problem.

    * Server environment: Apache or IIS? What OS are you running? Any proxy or cache server in place?

    Apache (latest), PHP (latest), MySQL (not quite the latest but close enough), OSX Server (latest). Apache with mod_proxy as a reverse proxy for the old site content.

    * End user environment: Browser and version? (IE, Opera, Netscape, Safari?) OS? Security programs?

    Firefox, IE, Safari...doesn't matter. Windows/Mac/Linux - also doesn't matter. No security products active.

    * How to dupe the error. Please provide the specifics as to what you did to arrive at the error. Where within the site did the error appear? What is the specific error that you have received if you are getting one?

    Filled in the information at the aforementioned URL, clicked Next, get a blank/error page/attempted download (depending on the browser).

    * Give details. Please remember that you're the one seeing the error and many times, you're the only one seeing that error. Folks can't read minds or else they would be in Vegas playing cards instead of trying to help other folks on the Mu forums.

    See above.

  4. cafespain
    Posted 9 years ago #

    Firstly this isn't a bug so please stop marking you posts as such. It is a problem with your install. If it was an actual bug there would be a lot of shouting and entries in the trac as it is a basic requirement of the system.

  5. cafespain
    Posted 9 years ago #

    Now that is out of the way. Turn on debugging in your wp-config.php file and see what output is made then. It might help track things down a little bit more.

  6. plug_n_author
    Posted 9 years ago #

    Looking into a possible solution. Found something that sounds related to this issue on another forum.

  7. andrea_r
    Posted 9 years ago #

    '[Tue Jun 02 13:58:45 2009] [notice] child pid 13442 exit signal Bus error (10)"

    Well that would be the kicker there.

  8. plug_n_author
    Posted 9 years ago #

    Fixed: PHP 5.2.8 was the problem (it was crashing) and this was most likely the relevant bug:

    Upgraded (painful) to 5.2.9 and registration works fine now.

  9. roastlechon
    Posted 8 years ago #

    @plug_n_author, I have the exact same problem as you, except I am having trouble finding a solution. If you could help me out somehow by detailing how you upgraded to 5.2.9 on the Apple Xserve, that would be great!

  10. larsoncm
    Posted 8 years ago #

    Chances are, the function checkdnsrr is killing your OS X server. I've seen this function break user registration functionality on other products like phpBB and bbPress...

    You'll find checkdnsrr in two places on wordpressmu - In wpmu_functions.php (~line 862) look for
    function validate_email( $email, $check_domain = true) {
    and change it to:
    function validate_email( $email, $check_domain = false) {

    and in formatting.php (~lines 1423-1425) comment out these lines
    `if ( $check_dns && function_exists( 'checkdnsrr' ) && !( checkdnsrr( $domain . '.', 'MX' ) || checkdnsrr( $domain . '.', 'A' ) ) ) {
    return apply_filters( 'is_email', false, $email, 'dns_no_rr' );

    like so
    `/*if ( $check_dns && function_exists( 'checkdnsrr' ) && !( checkdnsrr( $domain . '.', 'MX' ) || checkdnsrr( $domain . '.', 'A' ) ) ) {
    return apply_filters( 'is_email', false, $email, 'dns_no_rr' );

    Of course, YMMV, and php experts may have a better solution. Another option is to recompile php on OS X, or use Mark Liyanage's ( php. The most recent updates to OS X 10.5.8 (including security patches) still don't fix Apple's php environment.

About this Topic

  • Started 9 years ago by plug_n_author
  • Latest reply from larsoncm