The MU forums have moved to WordPress.org

Installed WPMU 2.7.1 and home blog links go to a 404 error (9 posts)

  1. james@bluefishwireless.com
    Member
    Posted 13 years ago #

    I am looking to use WPMU and BuddyPress for a new site and have just finished installing WPMU. I am able to log in, create new users, go through the various dash board contents and create a test blog.

    The test blog has a link on the home page http://as7.bluefishwireless.com/wordpressmu/ but when I click the link I get
    The requested URL /wordpressmu/2009/06/07/jamess-first-blog/ was not found on this server.
    Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5 with Suhosin-Patch Server at as7.bluefishwireless.com Port 80

    I have tried to go through the various instructions to configure apache2 but am having no luck.

    In /var/www/wordpressmu I have htaccess.dist file with following contents;
    RewriteEngine On
    RewriteBase BASE/

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    In /etc/apache2 I have an empty htaccess.conf file and an apache2.conf file where I have changed the default directory lines to
    # Alias /error/ "/usr/share/apache2/error/"
    #
    <Directory "/usr/share/apache2/error">
    AllowOverride FileInfo Options
    Options IncludesNoExec
    AddOutputFilter Includes html
    AddHandler type-map var
    Order allow,deny
    Allow from all
    # LanguagePriority en cs de es fr it nl sv pt-br ro
    # ForceLanguagePriority Prefer Fallback
    </Directory>
    This is where I found the 'AllowOveride' and thought it must have been where I needed to make the changes.

    I am very new to configuring apache so any help to fix this problem would be very much appreciated.

  2. cafespain
    Member
    Posted 13 years ago #

    Yeah, the rewrite base on your htaccess is wrong. Did you let WPMU create it for you?

    UPDATE, sorry misread your post, what are the contents of your .htaccess file? The htaccess.dist file is just a sample file.

  3. andrea_r
    Moderator
    Posted 13 years ago #

    Either mod_rewrite is not enabled on your server, or Apache can't read the htaccess file.

  4. james@bluefishwireless.com
    Member
    Posted 13 years ago #

    I posted the htaccess.conf file contents above. Is this the wrong file? Where do I find the .htaccess file if this is a different one?

    How do I enable mod_rewrite? Is this in the apache2.conf file? The documentation talks about the httpd.conf file but this file is empty on my machine. It is in /etc/apache2

    Thanks for the fast responses! I am a total novice so likely am missing something very easy.

  5. Ovidiu
    Member
    Posted 13 years ago #

    you posted the content of the .htaccess.dist file which is the template wpmu uses to create the .htaccess file during isntallation.

    mod_rewrite is an apache2 module enabling depends on your OS, with debian its somethign like 'a2enmod mod_rewrite' but usually you can't just enable modules, your host has to do that for you or are you on a root or VPS server?

  6. james@bluefishwireless.com
    Member
    Posted 13 years ago #

    I have a server running in a colo built on Ubuntu 8.04. The machine is our companies. I can log in as root, but I have no experience with apache or enabling modules.

  7. cafespain
    Member
    Posted 13 years ago #

    can you connect to it with FTP and set your FTP client to display hidden files. At the root of your mu site /wordpressmu/ there should now be a .htaccess file, that's the one that's needed.

    If there isn't one then that is half of your problem.

  8. james@bluefishwireless.com
    Member
    Posted 13 years ago #

    ok thanks for that explanation. The .htaccess is in my /var/www/wordpressmu folder with the following contents

    RewriteEngine On
    RewriteBase /wordpressmu/

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Do I need to make changes to this?

  9. james@bluefishwireless.com
    Member
    Posted 13 years ago #

    Can anyone please assist me on this? I am stuck.

About this Topic

  • Started 13 years ago by james@bluefishwireless.com
  • Latest reply from james@bluefishwireless.com