The MU forums have moved to WordPress.org

Howto upgrade to the latest nightly (stress-free) (18 posts)

  1. amanzi
    Member
    Posted 16 years ago #

    Well it was stress-free for me at least, you may want to test this in your environment before following these steps - I use VMware for this.
    My blog is installed here: /var/www/virtual/blogtown.co.nz/htdocs

    Download the files:
    cd /var/www/virtual/blogtown.co.nz
    wget http://blogs.linux.ie/download/wpmu/wpmu-unstable.tar.gz
    tar -xzvf wpmu-unstable.tar.gz

    Fix the site upgrade problem:
    rm /var/www/virtual/blogtown.co.nz/wpmu-2006-06-19/wp-inst/wp-admin/wpmu-upgrade-site.php
    Copy and paste the text from this post (Thanks kahless) into a new file with the same name as the one you just deleted:
    vi /var/www/virtual/blogtown.co.nz/wpmu-2006-06-19/wp-inst/wp-admin/wpmu-upgrade-site.php

    Fix the 'Incoming Links' problem:
    Edit the following file with the fix from this post
    vi /var/www/virtual/blogtown.co.nz/wpmu-2006-06-19/wp-inst/wp-admin/index.php

    Fix the 'Languages' problem:
    Edit the following file and remove lines 25-32
    vi /var/www/virtual/blogtown.co.nz/htdocs/wp-inst/wp-admin/options-general.php
    Remove the following:
    25 <tr valign="top">
    26 <th scope="row"><?php _e('Language:') ?> </th>
    27 <td><select name="language"><?php language_dropdown( get_option('language') ); ?></select>
    28
    29 <?php _e('Language this blog is primarily written in.') ?>
    30 <?php _e('In the future, you will be able to modify the interface language in your profile.') ?>
    31 </td>
    32 </tr>

    Copy files to live site:
    Don't forget that if you have edited any of the core files, you will lose all your changes, so make sure you can reproduce what you've done. Your custom themes, htacccess files and your config file won't be touched.
    cp -R wpmu-2006-06-19/* htdocs/

    Upgrade main site:
    Go to your site here:
    http://example.com/wp-admin/upgrade.php

    I received the following error while upgrading but it didn't seem to have any other effects (so I ignored it!)
    WordPress database error: [Duplicate key name 'type_status_date']
    ALTER TABLE wp_1_posts ADD KEY type_status_date (post_type, post_status, post_date, ID)

    WordPress database error: [Duplicate key name 'domain']
    ALTER TABLE wp_blogs ADD KEY domain (domain(50),path(5))

    Upgrade all blogs:
    Go to your site here:
    http://example.com/wp-admin/wpmu-upgrade-site.php?action=upgrade
    Everything should upgrade OK.

    Hope this helps you all, and hopefully I've typed it all correctly. Remember, the best way to test is to run a mirror of your main site in a VMware machine.

  2. mypatricks
    Member
    Posted 16 years ago #

    A little bug for your site.
    1. Can not upload images
    2. Import wordpress error.
    It's seen directory not writable.

  3. amanzi
    Member
    Posted 16 years ago #

    Thanks for pointing that out. I also need to install the GD libraries for the thumbnail resizing process.

  4. samchng
    Member
    Posted 16 years ago #

    So is the procedure valid since there are little bugs?

    amanzi, what's GD library?

  5. amanzi
    Member
    Posted 16 years ago #

    The directory permissions problem was my fault, and shouldn't affect other installs.

    The GD library is required to create the thumbnails when you upload images. Most web servers have them installed, but my server was a fresh build.

    There is quite a lot of progress happening now (thanks to donncha) so these instructions will become redundant soon.

  6. samchng
    Member
    Posted 16 years ago #

    I tried upgrading, but I get this error upon running the upgrade script.

    Fatal error: Call to a member function on a non-object in /home/bizblogo/public_html/test/wp-inst/wpmu-settings.php on line 16

    The new wpmu_setting file is totally different from the old one. Any ideas? Thanks.

  7. amanzi
    Member
    Posted 16 years ago #

    I think the problem is with the wp-config.php file. I didn't experience this problem but somebody else did and posted here in the forums too.

  8. samchng
    Member
    Posted 16 years ago #

    I had to edit a core file, wp-config.php as the unstable .tarz did not come with a wp-config.php but wp-configsample.php.

    So my old wp-config.php was not overwritten when I copied the new files over and the difference? The end of the new wp-config.php points to wp-setting.php instead of wpmu-setting.php before. Damn...

    It runs ok now, as least it loads up, but I get 404 error upon running wp-signup.php. wp-login.php works fine. Any ideas??

  9. samchng
    Member
    Posted 16 years ago #

    I understand why wp-signup.php doesn't work now. .htaccess has rewrites that point to wp-newblog.php which doesn't exist. I do not know why the upgrade script didn't change the wp-config and .htaccess file.

  10. donncha
    Key Master
    Posted 16 years ago #

    Unfortunately the upgrade script only updates the database at the moment.
    Keep an eye on the changelog for changes to the htaccess.dist and use diff or vimdiff to find any extra lines.

  11. samchng
    Member
    Posted 16 years ago #

    "use diff or vimdiff to find any extra lines."

    How do we use diff or vimdiff?

    In addition, may I know what other files like .htaccess and wp-config that would not be upgraded automactically. This way as admin we can keep track of what to manually edit to make the upgrade successfull. Thanks donncha and I would like to personally welcome you back since your blissful wedding. :)

  12. tubbs
    Member
    Posted 16 years ago #

    I tried your instructions, but something odd happened, no blogs are visible, but all users are still there...

  13. samchng
    Member
    Posted 16 years ago #

    tubbs, you need to run the upgrade script in your Dashboard.

  14. donncha
    Key Master
    Posted 16 years ago #

    samchung - I think .htaccess and wp-config.php are the main culprits.
    To use diff:
    cd into the directory of the new wpmu snapshot
    Use this command:
    diff --brief -rb . /path/to/your/wpmu/website/htdocs/

    The files that are different will be highlighted. If you haven't modified them, simply copy those that are different. If you have, then load both in an editor and compare differences. Vimdiff makes that very easy but has a steep learning curve.

  15. Yoshi_S
    Member
    Posted 16 years ago #

    After the Update I cannot read blogentrys by clicking an category an 404 error appears.
    Only the first blog where the users can register (bloggg.eu) is working fine and I can choose an category.
    Can anybody help me, I think the database Upgrade isn't right.
    I've upgraded through upgrade.php and through my admin panel.
    Sorry for my bad english but I hope for an answer :)

  16. itdamager
    Member
    Posted 16 years ago #

    I reported in another thread that the upgrade feature is broken in the latest builds and how to work around it temporarily to upgrade your site.

    Everyone using these instructions should take note they were written *before* the major update from last week.

  17. donncha
    Key Master
    Posted 16 years ago #

    I fixed that problem on Sunday morning with the blog_id by moving about the WP_INSTALL check. Running upgrade.php worked on my test install and I'll be interested if it works ok for everyone else!

  18. Yoshi_S
    Member
    Posted 16 years ago #

    The problem with the categorys is fixed now, thanks to itdamager!
    When I run upgrade.php nothing happens and I get an blank site with wordpress logo.
    I chose this http://trac.mu.wordpress.org/browser/trunk/wp-admin/upgrade.php?rev=598
    to test the function.

About this Topic