The MU forums have moved to WordPress.org

Installed - can't login (28 posts)

  1. kyleconkright
    Member
    Posted 13 years ago #

    I installed wordpress mu on my server in a sub directory. when i try to login with admin and the password, it just takes me back to the login screen as if i never entered anything in. same if i try forgot password. what can i do? thanks.

  2. joshthomas80
    Member
    Posted 13 years ago #

    Hi Kyle,
    I have this same problem. Installation was done correctly following all directions and verified with my hosting support staff, who are experienced with WPMU. They are confused as to why this is happening.

    Anyone out there have a fix?

  3. joshthomas80
    Member
    Posted 13 years ago #

    UPDATE:

    By some miracle of code-land, I was able to get to the wp-admin screen!

    However, when I visit my site, I still get the WPMU installation screen.

    What gives?

  4. andrea_r
    Moderator
    Posted 13 years ago #

    Where are you hosted?

  5. joshthomas80
    Member
    Posted 13 years ago #

    I use hostgator and was fortunate to get a support tech who was very familiar with WPMU. We went through the install process together and he was baffled by the fact that my site kept showing the installation page.

    Again, I was able to access wp-admin and create a test post. But upon visiting the site, I only see the installation screen.

    What do you think? I've been looking for an answer to this issue and can't seem to find one.

  6. rohan_kapoor
    Member
    Posted 13 years ago #

    It sounds like you may either have a server issue with apache or a problem with your .htaccess.

  7. joshthomas80
    Member
    Posted 13 years ago #

    well, turns out I had modified the files from a previous install where I had an instance of WP already running. Per the instructions for that scenario, I "commented out" some lines which created the endless installation loop.

    So, I deleted everything, including the files on my computer, re-downloaded from WPMU and Voila! I'm now free to discover all the little compatibility issues between WPMU and WP themes. Yay. :)

  8. andrea_r
    Moderator
    Posted 13 years ago #

    I'm now free to discover all the little compatibility issues between WPMU and WP themes.

    Noting, really. There's no WPMU-specific template tags.

    there *is*, however, things to look out for:

    - thumbnail issues
    - hardcoded elements

    and I did a couple guidelines here -
    http://wpmututorials.com/themes/theme-designers-what-you-need-to-know-about-wordpressmu/

  9. joshthomas80
    Member
    Posted 13 years ago #

    Sorry for the sarcasm. The new version, WPMU 2.8.1, solved most of my problems.

    Andrea, your site is one of the primary resources I have used thus far. Thanks for your help.

  10. andrea_r
    Moderator
    Posted 13 years ago #

    Oh, good then. :)

  11. Farms
    Member
    Posted 13 years ago #

    We posted some guidelines for WordPress MU themes and a tutorial regarding editing your MU themes (using a text editor) too recently.

    Hope they help.

  12. lam
    Member
    Posted 13 years ago #

    I have the same problem, installation was successful, database is filled, default page is appearing, but I can't login to admin. I tried several times, clean install every time. Copy pasted the password, typed it with my hands, etc., nothing. It just redirects me to the login page, no error message.

  13. jcalabro
    Member
    Posted 13 years ago #

    I'm having the same problem as well. Anyone find a fix for this login issue?

  14. blistermania
    Member
    Posted 13 years ago #

    Same problem here. I've installed WP numerous times, but this is my first Mu install.

    Currently, I'm using WAMP for development. Also, I've installed MU into a subdirectory... ex. http://computername/mu-installation. Here is the address resulting from a login attempt:

    http://test-comp/blog/wp-login.php?redirect_to=http%3A%2F%2Ftest-comp%2Fblog%2Fwp-admin%2F

    I hope someone can help us out. Was wanting to play with the idea of setting up internal blogs for work. :D

  15. andrea_r
    Moderator
    Posted 13 years ago #

    On a local box, WPMU gets cranky if the hostname is not something.something.

    Can you make it test-comp.local ?

  16. KevBurnsJr
    Member
    Posted 13 years ago #

    adding a .tld (.com) to the end of the local host name seems to have fixed this issue for me.

    fwiw, that's a pretty silly glitch.

    also: it is not possible to create wildcard subdomains in hosts files in Windows.

    </rant>

  17. whobutsb
    Member
    Posted 13 years ago #

    I'm running in to the same issue as well. I have a intranet that i'm trying to setup WP Mu on and the computer name is one word. In the wp-config file I changed DOMAIN_CURRENT_SITE to icarus.local with no luck, icarus.com (which I knew wouldn't work), and to the LAN IP address.

    Doe anyone have any other solutions so that I can log on to my admin page?

  18. andrea_r
    Moderator
    Posted 13 years ago #

    You have to make sure those domain exist in the hosts file on your computer.

    And you have to put whichever one in when you run the install. don't edit the config file. If it comes up and says to edit the config file, that's a separate issue.

  19. whobutsb
    Member
    Posted 13 years ago #

    Thanks andrea_r, could you clarify a bit on what you mean by make sure the domain exists in the hosts file on your computer?

    I'm not quite sure what that means.

  20. andrea_r
    Moderator
    Posted 13 years ago #

    Well, if the computer name is one word, that is stored on the computer in a file called "hosts". You have to edit that file.

    (I'm not much a Windows person anymore tho)

  21. ericthered
    Member
    Posted 12 years ago #

    Hello. I am having this problem and I can't seem to fix it. I read the posts here and still can't figure it out. As previously stated above by other people, I installed MU on hostgator which we have our own server with host gator.

    I created a subdomain which I installed MU in (I am going to need to do this several more times with different subdomains). Install goes great but I am stuck with a login screen that won't take my login info Wordpress MU gave me. Also there is a red area above the login saying "Please log in again" before I have even try to login the very FIRST time.

    I looked at the error.log in the subdoman directory and it has this code over and over again about 20 times:

    [27-Mar-2010 01:03:25] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-zts-20060613/ixed.5.2ts.lin' - /usr/local/lib/php/extensions/no-debug-zts-20060613/ixed.5.2ts.lin: undefined symbol:

    I installed MU 2.9.2

    Any help would be much appreciated. Thank you.

  22. lchinbaatar
    Member
    Posted 12 years ago #

    I am having a same problem as above. Any help would be appreciated. Thanks,

  23. ericthered
    Member
    Posted 12 years ago #

    So does anybody know or am I up sh--s creek without a paddle? Any response would be good.

  24. andrea_r
    Moderator
    Posted 12 years ago #

    Have you asked Hostgator support? Because those errors are server ones.

  25. ericthered
    Member
    Posted 12 years ago #

    Hi Andrea,

    Thanks for the reply. I have contacted them and I am waiting on a reply. As soon as I hear back and figure this out I will post the info here.

    Thank you.

  26. ericthered
    Member
    Posted 12 years ago #

    Ok. So I just worked it out with hostgator.

    Looks like google chrome was cached and I couldn't login although I cleared that for chrome and firefox.

    So I took a better look at things and found out the Wordpress was redirecting me to the admin after install but in a different way.

    bad login string:
    http://mysubdomain.maindomain.net/wp-login.php?redirect_to=http://mysubdomain.maindomain.net/wp-admin/

    Good login string:
    http://mysubdomain.maindomain.net/wp-login.php?redirect_to=http%3A%2F%2Fmysubdomain.maindomain.net%2Fwp-admin%2F

    You can see the redirect in the url is different.

    As long as you use: http://mysubdomain.maindomain.net/wp-admin/ you should be good to go.

    One last note. I also went here to see how to manually change the password for Wordpress MU: http://support.hostgator.com/articles/getting-started/general-help/wordpress-and-other-script-admin-login

  27. marcus_nz
    Member
    Posted 12 years ago #

    Env: WPMU latest install on Vista laptop running WAMP for local access only.

    I was having the same issue where log in attempts took me back to the login page (no error message shown).

    My virtual domain was setup as WP. I changed this to WP.LOCAL (in hosts and apache) and reinstalled WPMU.

    Now I can log in and everything look fine.

    Hope this helps someone else with the same problem.

  28. noabsolute
    Member
    Posted 12 years ago #

    I am having the same problem as everyone else and none of the above fixes seem to work.

    I changed over to MU from a normal wordpress install on terencenance.com using these instructions.

    http://wparena.com/how-to/how-to-convert-a-wordpress-blog-into-wordpress-mu/

    everything went well, but now when I try and login, I get redirected to the login page with no errors.

    pretty please help! my database host name has a .com at the end but that seemed to only be a problem with local installs, please help!

About this Topic

  • Started 13 years ago by kyleconkright
  • Latest reply from noabsolute