The MU forums have moved to WordPress.org

WordPress MU 2.8.1 error? (26 posts)

  1. Sushubh
    Member
    Posted 10 years ago #

    Alright. I tried upgrading my installation to 2.8.1...

    Did it from the backend. Showed that the upgrade was successful. But the message 'WordPress MU 2.8.1 is available! Please update.' continued to remain in the backend.

    I also uploaded manually by uploading all files manually.

    Still I get the message in the backend:

    'WordPress MU 2.8.1 is available! Please update.'

    the footer shows:

    Thank you for creating with WordPress MU 2.8.1

    but it also shows:

    Get Version 2.8.1

    What am I doing wrong?

    The code of the blog pages also show:

    <meta name="generator" content="WordPress 2.8.1" /> <!-- leave this for stats -->

  2. jorbin
    Member
    Posted 10 years ago #

    http://trac.mu.wordpress.org/ticket/1037

    You're not the only one.

  3. Sushubh
    Member
    Posted 10 years ago #

    ah ok.

    the upgrade has also disabled some functionality on simple tags plugin. clicking on suggested tags does not work anymore. that is painful. this feature also does not work on wordpress 2.8.x releases.

  4. andrea_r
    Moderator
    Posted 10 years ago #

    So... did anyone report that back to the simple tags plugin author?

  5. cafespain
    Member
    Posted 10 years ago #

    I've updated the remove remotes plugin to get rid of this nag message for the time being (I also get it, and I updated via SVN, so not sure of the issue, but I'd rather not see it):

    http://snipt.net/cafespain/remove-remotes-plus-nag

  6. NetizenRon
    Member
    Posted 10 years ago #

    I'm also getting nags for plugins I just upgraded.

  7. ebiladdress
    Member
    Posted 10 years ago #

    I'm not having issues with plugins, just the core wanting to update as mentioned.

    - Just made fresh install of wpmu with ver2.7. I updated via interface, got the exact result of the version upgrade available message.
    - Repeated in /wpmutest2, same results.
    - All setup process is exactly like my 5 2.7 websites that are prod.

    I've not run into plugins needing updates over and over, so I installed two or three randomly from my local/dir. Other than one having an incorrect header, everything worked fine.

    Won't scrub these if anyone wants a look or wants me to try something else. ebiladdress at yahoo.com.

    - Eric

  8. ebiladdress
    Member
    Posted 10 years ago #

    Also found that Kimili Flash Embed will drop your wp-admin to a blank screen with this update. del the plugin dir and it reappears as expected.

    I have notified the author and offered to beta.

    E

  9. sdsenthil
    Member
    Posted 10 years ago #

    me also have same problem, better wait for next update.

    1. Even after says "Upgrade to 2.8.1" while saying You are using 2.8.1.

    2. In the dashboard, I can't select another blog, even I can't see the blogs other than the primary blog.

    So I degraded to old one 2.7.1.

    Regards,
    Senthil.

  10. islandcastaway
    Member
    Posted 10 years ago #

    I am getting this error when editing a page:

    Warning: implode() [function.implode]: Invalid arguments passed in /blah/wp-includes/post.php on line 1762

  11. ebiladdress
    Member
    Posted 10 years ago #

    I can not replicate that issue.

    Please disable all plugins and retry.

    E

  12. ZKWC
    Member
    Posted 10 years ago #

    I have the same error... 2.8.1 is available even though I've already updated.

    my "wp-ban" plug-in no longer works too. at least the "block you" plug-in does.

    how does one downgrade to 2.7.1?

  13. Ophidian
    Member
    Posted 10 years ago #

    ZKWC,

    You should probably report that wp-ban issue to the author as well. They would probably like to know so the features will work with the newest versions. I don't know as far as downgrading.

    Oph

  14. donncha
    Key Master
    Posted 10 years ago #

    Grab wp-includes/wpmu-functions.php and wp-includes/functions,php from http://trac.mu.wordpress.org/browser/branches/2.8 and overwrite the files in your current install. That should fix upgrade notice problems.

  15. buddha trance
    Member
    Posted 10 years ago #

    Overwriting the two files with the ones donncha mentions fixed the upgrade notice issue.

  16. Ipstenu
    Member
    Posted 10 years ago #

    @donncha and @buddha trance, I did that yesterday and it didn't work. Did it today and now it's working. o.O and yes, I'm sure I did it right.

  17. Driftless1
    Member
    Posted 10 years ago #

    Pardon my ignorance, but how does one grab the files at trac.mu.wordpress.org? I naively did I "save link as" and suddenly my dashboard was replaced with the trac.mu page!

    Maybe I should go to bed before I really screw something up.

  18. parkstreet
    Member
    Posted 10 years ago #

    At the bottom of the trac page of the file you want to download, you should see "Download in other formats:".

  19. Driftless1
    Member
    Posted 10 years ago #

    At the bottom!?! Thats soo... far... down... there it is.

    Yippeee! That does the trick for me.

    Thanks Donncha (and co)

    G'night.

  20. mercime
    Member
    Posted 10 years ago #

    @cafespain: Thank you very much for the updated remove-remote-plus-nag
    @donncha: Thank you for the new wpmu-functions.php and functions.php
    Cheers.

  21. SupersonicSquirrel
    Member
    Posted 9 years ago #

    This worked like a charm, thank you. :)

  22. SCadente
    Member
    Posted 9 years ago #

    Since I'm using 2.8.1, I cannot connect to my blogs via XMLRPC.
    According to ecto, "No valid XML data in response". Scribefire says that ID/Password is not valid.
    They were working fine in mu 2.7.1 (and normal WP 2.8.1).
    This issue happens to both clean install of 2.8.1 and updated blogs from 2.7.1.

  23. fredbiggar
    Member
    Posted 9 years ago #

    A little behind the curve here, I am trying to upgrade to 2.9.2. We currently have 2.8.1 installed, but we have the above detailed problem with the admin panel still saying 2.8.1 is available. I attempted the fix by overwriting the two files, but this didn't solve the problem.

    I'd be grateful fr any suggestions.

  24. andrea_r
    Moderator
    Posted 9 years ago #

    Upgrade manually?

  25. AvatarRocks
    Member
    Posted 9 years ago #

    Mates, I'm just catching up with this post.

    This may be a basic question, but...

    Will the fix mentioned above mess with
    the database and plug-ins we already have on the site.

    I mean will it wipe out and require a re-install
    of plug-ins, content, users, etc.

    Please let me know.
    We have some avid users and I'd hate to see
    profiles, content, and plug-ins disappear.

    Thanks very much for your good assistance.

    - Jeff -

    .

  26. andrea_r
    Moderator
    Posted 9 years ago #

    Backup first so you can restore if anything borks.

    Manually upgrades simply replace the core WordPress files. Your users & content live in the database. So above, where it is suggested you swap in two new files, doesn't touch your db or your plugins.

About this Topic

  • Started 10 years ago by Sushubh
  • Latest reply from andrea_r