The MU forums have moved to WordPress.org

New Install Problems (5 posts)

  1. ssb
    Member
    Posted 14 years ago #

    New to all this stuff.

    • Have loaded WP-MU on a RHEL 5 box.
    • Have the MySQL database server ( v 5.1.31sp1 enterprise ) working on a separate RHEL 5 box.
    • Have root access to both servers.
    • Connectivity between the 2 RHEL boxes is OK. Am able to login with the MySQL Administrator tool from the WP-MU box.
    • Have created a database on the MySQL server and have given it full access to the MySQL user that I've been using for the WP-MU setup.
    • Have found that I needed php-mysql so have loaded that.
    • Have launched the index.php file from my web browser and entered my parameters. After clicking the submit button I get the Error establishing a database connection message.
    • Have checked the parameters in the wp-config.php file for any typos .... there doesn't seem to be any. Tried replacing the DB_HOST directive with the IP address of the server .... didn't help. (Yes, restarted httpd each time.)
    • Have looked at http://wpmututorials.com/files/2008/12/installing-wpmu.pdf and do not see anything different between my install configuration and the MySQL and WP-MU settings there.
    • Have looked at Figaro's video at http://educhalk.org/blog/?p=148.

    Any pointers in the right direction would be much appreciated. Thanks for the forum's time.

  2. parkstreet
    Member
    Posted 14 years ago #

    Does your error logs tell you anything?

  3. andrea_r
    Moderator
    Posted 14 years ago #

    Did it create an htaccess file?

  4. ssb
    Member
    Posted 14 years ago #

    My error logs don't mention anything except that it can't find a file called favicon.ico. The only file on my server with this name is in the CUPS documentation so I have know idea where it's pulling this from.

    Re the .htaccess file, this in not being created.

  5. ssb
    Member
    Posted 14 years ago #

    Solution found.

    Worked on this for some time and discerned that the problem was really a PHP problem. It wasn't connecting to the database. PHP connectivity problems mean HTTPd problems. After a lot of digging into PHP, which I know nothing about, the problem pointed back to the SELinux tool. It was stopping the web server from communicating with the database server. The solution was to issue the following command at the Linux command prompt:

    [root@foo ~] setsebool –P httpd_can_network_connect=1
    [root@foo ~]

    After this the standard installation worked fine.

    Thanks for everyone's time.

About this Topic