The MU forums have moved to WordPress.org

Subdirectories 404 error and no access to admin :( (7 posts)

  1. tomdebruin
    Member
    Posted 14 years ago #

    I have a WPMU install set up at http://www.myexample.com
    It is using subdirectories. I then remove the /blog/ part with a rewrite_rules_array function.
    When I create a new blog (e.g. http://www.myexample.com/staffblog) it is created correctly but if I try to access that blog I get a 404 error (the 404.php from the main site theme). Additionally, if I try to access the the admin area for my new blog I just end up back in the admin area for my main blog (www.myexample.com/wp-admin instead of http://www.myexample.com/staffblog/wp-admin).

    The very bizarre thing is that I have an exact replica of the entire setup on a subdomain (sandbox.myexample.com) which works correctly. All the setting are the same except for one thing I noticed. The sandbox.myexample.com/staffblog contains a "Transient Random Seed".

    Could this have something to do with it? Or could it be related to the "www" on the URL? If I go to myexample.com/staffblog it sends me to http://www.myexample.com.

    Any ideas appreciated. It is difficult to test things on the main site due to its constant use, hence the sandbox but if they are behaving differently it makes things rather difficult.

  2. tomdebruin
    Member
    Posted 14 years ago #

    anyone? the answer hasn't miraculously presented itself to me yet ...

  3. tomdebruin
    Member
    Posted 14 years ago #

    fixed it. For anyone wondering, in my wp_blogs database table the domain was listed as http://www.myexample.com, dropping the www fixed it.

  4. r-a-y
    Member
    Posted 14 years ago #

    This post saved me!
    Thank you so much!

  5. zenjiweb
    Member
    Posted 14 years ago #

    I just found this doing a google search. Had the same problem (migrating from subdirectory install to live env) then found the answers.

    By default, WPMU hates "www." for some reason. If you configure the site to use www it trips it up, since its set to redirect all www requests. So it tries to force your entire site into "http://mydomain.com".

    There is a hack to allow for www outlined here for anybody needs it: http://manojkumar.org/install-wordpress-mu-with-www/

    I started down the path of the hack and then realized it wasn't worth it in the long run and reverted to the no-www default..

  6. andrea_r
    Moderator
    Posted 14 years ago #

    Yes, it was coded to strip that out.

    in wp 3.0 it's fixed.

  7. josemariamv
    Member
    Posted 14 years ago #

    Hi everyone. Hi have a wordpress mu instance with 2.7x version and when I try to upgrade to 2.9.1 version I have this problem. Mi domain begin whith www. ┬┐Any workaround for this?

    Thanks in advance and sorry for my bad english

About this Topic

  • Started 14 years ago by tomdebruin
  • Latest reply from josemariamv