The MU forums have moved to

Domain Mapping won't work for newest blog (10 posts)

  1. cscholberg
    Posted 8 years ago #

    I have domain mapping on, and I've used it successfully with many blogs on WPMU. For some reason, though, with this last blog I made, it won't work. I have the IP address in the correct spot, as always, but when I enter the domain and click "Add" it just refreshes the page, and the domain does not show up under the active domains section. I've tried everything I can think of, and I have no idea why it's not working.
    Can anyone help?

  2. cscholberg
    Posted 8 years ago #


  3. andrea_r
    Posted 8 years ago #

    Anything in your error logs?

  4. cscholberg
    Posted 8 years ago #

    nothing. when you map a domain with the plugin, where does it write this data to? I may have already mapped it to a blog that I deleted on accident, but I'm not sure. If it IS already mapped, how do I go about "unmapping" it?

  5. cscholberg
    Posted 8 years ago #

    UPDATE: I tried to do it via cpanel by parking my domain, but it comes up with "Error from park wrapper: the site is already configured"

    I guess I did already mess with it - how do I undo the damage?

  6. cscholberg
    Posted 8 years ago #

    So, I've asked hostgator support for help. Apparently I was mistaken. Parking domains is NOT the same thing as what this domain mapping plugin is.

    Basically, I need to go to, but to appear as

    I've done this several times with several blogs, but the usual process is not working - when i go to tools->domain mapping and click "add",nothing happens. no error, no nothing.

    Note: I may have already "added" it to another blog which I deleted, but now I can't go back to that blog and delete it from the active domain list, since the blog has been deleted. Unfortunately I don't remember if I did add it or not, but that would be the only thing I can think of that explains why it's not working this time. My thoughts were to go to wherever it writes the info down that is linked to and delete that, so it frees up and i can re-link it to the correct blog. Am I mistaken? If not, where is this?

    Thanks everyone for putting up with my lack of knowing what's going on, still brand new at this.

  7. andrea_r
    Posted 8 years ago #

    Apparently I was mistaken. Parking domains is NOT the same thing as what this domain mapping plugin is.

    It depends on what they call it in the backend. At another host I know of, they call it mapping.

    Whatever they call it, you need to make sure the new domain is on top of the main WPMU domain. Not the subdomain. WPMU will pick up the sub part and remap it correctly.

    To get rid of the old one, you'll have to delete the record in the database. There will be a domain mapping table in there, browse the info and find the old one.

  8. cscholberg
    Posted 8 years ago #

    This is exactly the answer I was looking for.
    I don't know who you are Andrea but I've seen your answers on lots of other posts and you seem like the answer to any wordpress problem. Thank you.

    For the benefit of anyone else who might run into a similar problem, I'm going to explain, in detail, what my problem was and how I fixed it, exactly.

    I use Wordpress MU and have a baby gator account with hostgator. I have a and several add-on/subdomains. I create a new blog with the URL, and I use the Domain Mapping Plugin to change the address to, since my maindomain website has nothing to do with my newblog website.

    So, I created, let's say,, and I assigned to it using the Domain Mapping Plugin. I thought I had made a mistake with something, so I deleted newblog4 from WPMU and I deleted the add-on domain (which removes the subdomain as well). Later on, I created newblog5, and tried to assign the old to using the Domain Mapping Plugin. It wouldn't add it! Then, I realized, that I forgot to remove the domain mapping from newblog4 before I deleted it.

    So, somewhere, something remembers that is already assigned. I guess you can't assign it twice. What it was assigned to is gone, and I need to assign it to my new blog, newblog5.

    I contacted hostgator live chat support twice, and both times they assured me the problem was not on their servers and that I had to contact the software developers. I also could not find anything on the internet. Thanks to Andrea, I found the solution.

    When you use the domain mapping plugin, it "remembers" what you assign in your database. Go to myPHPadmin, go to the database you are using, and look for "wp_domain_mapping" - When you click on it, click "Browse," and you should see a list come up. This is what it remembers. Here, I saw my Select what you want to remove, and delete it.

    This is what I did, and now is working properly with my WPMU install.

    Of course, always make a backup before you mess with anything.

    I hope that any of this comes in handy to at least one person - I'm not the only rookie out there.

  9. andrea_r
    Posted 8 years ago #

    Glad you got it sorted out. :)

  10. RobLincolne
    Posted 8 years ago #

    hey guys I've been having some problems getting multi domains working with my WPMU installation.. aside from some parking problems (which I *think* I'm getting to the bottom of), I just went to have a look at my 'wp_domain_mapping' table.

    It's empty!

    I've added the IP and tried to add new domains under the 'Tools -> Domain Mapping' interface. But the page kinda just refreshes and now I see the 'wp_domain_mapping' doesn't show anything.

    Any ideas?

About this Topic

  • Started 8 years ago by cscholberg
  • Latest reply from RobLincolne