The MU forums have moved to

404 Error on wp-admin, etc. after install (10 posts)

  1. ebellempire
    Posted 14 years ago #


    I noticed some others were having this issue but didn't find an answer that worked and/or applied to my situation (i.e. unlike some others, nothing else is installed on my server, I'm running in the root directory, etc.)


    So yeah, I'm getting these 404s on pages in the wp-admin directory.

    One guess would be .htaccess. The install failed to create a new one.

    This could be a result of my inability to 777 the root directory, for lack of access via FTP.

    Also, as far as I can tell (by speaking with GoDaddy support), I do have the * subdomain setup, even though I was given a warning after installation.

    Any help would be greatly appreciated.

    Cheers -- Erin

  2. andrea_r
    Posted 14 years ago #

    If it installed fine otherwise (as in the config file and db tables are there) you can create the htaccess by taking htaccess.dist and use that. Make a copy called .htaccess, and CHANGE the line that says

    Rewritebase BASE


    RewriteBase /

  3. ebellempire
    Posted 14 years ago #

    Hi Andrea,

    I'm still getting a 404 after logging in with wp-login. Below is my .htaccess file, modified as instructed above. The rep at GoDaddy mentioned that I might need to make some changes to the WPmu .htaccess file to make it work on their servers, though he did not indicate what those changes might entail. Any guess?


    RewriteEngine On
    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off

  4. andrea_r
    Posted 14 years ago #

    "The rep at GoDaddy mentioned... "

    Did he mention that they disable WPMU on their cheaper shared accounts?
    What account type do you have there?

    Also, they have a ton of caching going on, so it may take 30 mintues (yes, really) for it to "notice" the htaccess file. If you're on the right account to begin with.

  5. GDHosting
    Posted 14 years ago #

    To install WordPress MU on Go Daddy hosting, you'll need to be on a deluxe account or higher. You also need to have a Dedicated IP address. You can see more details about this here:

    I also want to mention that .htaccess files are picked up immediately

  6. ebellempire
    Posted 14 years ago #

    My hosting plan with GoDaddy:

    Linux Web Hosting - Unlimited
    Standard (Turbo) SSL

    The rep said that the SSL add-on includes a Dedicated IP so that is not the issue. I looked at the guide from @GDHosting and I have done all of those steps (minus the dedicated IP step, which is, as I said, already covered by the SSL... unless the rep was wrong).

    Any other guesses?

  7. GDHosting
    Posted 14 years ago #

    The SSL cert does include a Dedicated IP, but you still need to follow the step to add the Dedicated IP.

  8. ebellempire
    Posted 14 years ago #

    I'm pretty sure I did that, and since the following line appears in my Hosting Account Details, and I used the IP to create an A Record, I think the Dedicated IP is already set...

    Dedicated Hosting IP :

    I misspoke when I said I skipped that step. I only meant I completed it in an alternative fashion. Sorry.

    Thanks for your help so far. Any other advice you have would be greatly appreciated.

  9. ebellempire
    Posted 14 years ago #

    okay. here is where i sheepishly admit that the problem had to do with permissions. but before you get all upset and call me a dumbass, know this, my friends: i had to 777 the entire wp-admin directory to get this site working. that does NOT seem like an intuitive or wise choice, so i'm not too upset with myself for having not tried it until now.

    anyway, can anyone tell me any specific files i need to reduce permissions on to make this site secure?

  10. parkstreet
    Posted 14 years ago #

    I usually set the files in the root to 444 and sometimes I will set the files in the wp-admin to 444 as well. To my knowledge, none of these files need to be written to when templates and plugins are added. However, I don't know how this affects automatic upgrades, but I don't use the automatic upgrade. I usually set the files to 644, upgrade Wordpress, and then set them back to 444 when I am done.

About this Topic

  • Started 14 years ago by ebellempire
  • Latest reply from parkstreet