The MU forums have moved to WordPress.org

CformsII with Domain Mapping - Not working well (7 posts)

  1. kidino
    Member
    Posted 13 years ago #

    I have domain mapping and cformsII installed on my WPMU.

    It seems that cformsII is working fine on the sub-domain blogs, but it's not very much on the mapped domains. At the visual editor of a mapped domain blog, when I click on the cformsII icon, I only get a blank small pop-up.

    This does not happen when I am at a sub-domain blog. I can see all of the forms and I created. And I can select one, and it'll get into the page/post.

    Is this a known thing? Know what's causing it? How to fix it? Or do you use any other alternatives instead? Share your experience please.

  2. gw468
    Member
    Posted 13 years ago #

    I have the same problem. Worse though, in the cformsII form settings, when trying to install a form preset, I get the spinning loading graphic and it never goes away.

    I saw some other tinymce issues when I tried the advanced tinymce plugin. A lot of the buttons would only give the blank box in the pop up. For instance, if advanced html and advanced images was checked, I got the blank box. When I unchecked them, it worked properly. There were others, but I don't remember them right now.

    As for an alternative, you can switch to the html editor and code your cformsII like <!--cforms name="XX"-->. Replace XX with the form name.

  3. honewatson
    Member
    Posted 12 years ago #

    There may be an issue with the cform javascript.

    Issues with javascript can occur when you have cross domain referenced javascript. This is what happens with some javascripts when you have domain mapping. MU Wordpress will print the URL of the original sub domain of the blog before you domain mapped it to the c-named domain.

  4. miklb
    Member
    Posted 12 years ago #

    For others who find this thread with a similar issue, I found the problem is that when you first active the plugin it hardcodes the path to the plugin in /wp-content/plugins/cforms/js/cforms.js to a subdomain. If you have domain mapping on, that path may no longer work. Try hardcoding the path to the plugin to the top level domain instead of a subdomain. Worked for me, mileage may vary.

  5. miklb
    Member
    Posted 12 years ago #

    As a follow up, I'm finding that didn't work on a second installation, I had to disable AJAX for it to work, still trying to find the sweet spot on this one.

  6. geckofrog
    Member
    Posted 12 years ago #

    Any update? I'm interested in this also...

  7. miklb
    Member
    Posted 12 years ago #

    What I found was that you need to make sure that in cforms.js you need to make sure the path is var sajax_uri = '/wp-content/plugins/cforms/lib_ajax.php';

    At least that seemed to do the trick for meā€¦this time;

About this Topic