The MU forums have moved to WordPress.org

Upgraded site successfully! (10 posts)

  1. amanzi
    Member
    Posted 16 years ago #

    I just upgraded to the latest nightly build with the new file structure successfully. This is how I did it:

    • Downloaded the latest nightly and unzipped it at the same level as the current root directory of the site
    • Edited the htaccess.dist file - changed BASE/ on line 2 to: RewriteBase / because I'm not installing WPMU in a subdirectory.
    • Renamed htaccess.dist to .htaccess
    • Edited the wp-config-sample.php file with the details of my database. Changed the VHOST entry on line 7 to: define('VHOST', 'yes'); because I'm using VHOSTS and not subdirectories for users. Also changed the BASE setting on line 8 to $base = '/';.
    • Renamed wp-config-sample.php to wp-config.php
    • Edited the following two files just so that they integrate with my theme a bit better: wp-signup.php wp-activate.php
    • Copied all of the themes and plugins from the current site to the new installation.
    • Change Apache to point to the new installation - you can do this by either reconfiguring the Apache config to point to the new directory, or just rename the directories so that the new installation becomes the default.
    • Reloaded Apache so the new site becomes active
    • Upgraded all blogs using the site upgrade script, and then test by creating and deleting blogs, posts, users, etc...

    Hope this helps others.

  2. donncha
    Key Master
    Posted 16 years ago #

    Excellent, glad you made the jump!

  3. bsdguru
    Member
    Posted 16 years ago #

    Busy preparing to take the jump.

  4. Epsilon
    Member
    Posted 16 years ago #

    Thanks a bunch, it worked like a charm. ^_^

  5. samchng
    Member
    Posted 16 years ago #

    Yeah!!!! Nice one amanzi... Just that I do not have access to Apache need my host to do it. ;)

  6. zeug
    Member
    Posted 16 years ago #

    Yeh, worked fine for me too. Did the rc1 (r616) upgrade from my recently upgraded r585, first backed up all files and db then deleted everything except wp-config and wp-content, uploaded rc1 with new file structure, edited the new htaccess, diffed wp-config, uploaded new wp-content files, ran upgrade.php then upgrade site from admin and all is go, no probs at all.

  7. amanzi
    Member
    Posted 16 years ago #

    One important part which I left out above is that you also need to copy the blogs.dir directory to the new installation - otherwise all the files that your users have uploaded will appear to have dissappeared!

  8. samchng
    Member
    Posted 16 years ago #

    Instruction "# Change Apache to point to the new installation - you can do this by either reconfiguring the Apache config to point to the new directory, or just rename the directories so that the new installation becomes the default.
    # Reloaded Apache so the new site becomes active"

    I went ahead and upgrade an Apr build following your steps which doesnt go through an install. Everything seems fine, but this test blog is from a subdirectory /wpmu with old wp-inst with VHost.

    Accessing domain.com/wpmu I would arrive at my main home page where logina nd sign up are. domain.com would also arrive at my main home page.

    I have changed all database urls to exclude /wpmu but it doesn't seem to work. Is it something to do with Apache above?

    Oh yes, one more note, my "View Site" on admin blog is with /wpmu and also after I ran upgrade.php the "Have Fun" link is also directed at /wpmu.

  9. samchng
    Member
    Posted 16 years ago #

    I deleted the .htaccess and wp-config files and did installation again. That doesn't help too. I think I have to do a fresh install. :)

  10. amanzi
    Member
    Posted 16 years ago #

    OK - I haven't used the subdirectory option, so I can't help here.

About this Topic