The MU forums have moved to WordPress.org

Unable to create directory - Is its parent directory writable by the server? (3 posts)

  1. owencutajar
    Member
    Posted 9 years ago #

    I'm sorry to raise this again, from the forum I can tell it's been done to death, but I honestly can't find a solution to the issue.

    As previously stated, it looks like the problem is one of folder ownership and permissions. WordPress seems to be creating a folder under blogs.dir owned by "apache" and then is unable to write into it. If I change the ownership of the folder manually it can then create folders under it, but again creates them with the wrong owner. I *could* fix them manually but I'd have the problem every time someone creates a new blog.

    Has anyone ever come up with a real solution for this problem?

    I'm also interested who you're hosting your Mu installation with if your "upload images" function works out of the box.

    Thanks for the input

    Owen

  2. andrea_r
    Moderator
    Posted 9 years ago #

    Yep, it's worked for me out of the box on a few different servers.

    Have you tried just changing the permissions of blogs.dir to 777?

  3. owencutajar
    Member
    Posted 9 years ago #

    PROBLEM RESOLVED!

    Scratch that. I’ve managed to resolve the problem!

    I’ve noticed that on Mu installation it gives you the option to CHMOD your folders to 777 for installation or CHOWN them by Apache .. I had orignally done the former.

    After reading this blog post ( http://bui4ever.com/2009/07/wordpress-mu-file-upload-permission-issues ), I CHOWNed the whole of httpdocs folder to apache and it seems to have resolved all the issues I had!

    Hope this helps others with the same problem.

About this Topic

  • Started 9 years ago by owencutajar
  • Latest reply from owencutajar