The MU forums have moved to WordPress.org

Concerns with doing 2.8.3 my 1st one (4 posts)

  1. dpd1998
    Member
    Posted 13 years ago #

    As you read in the title I'm having to do my first upgrade.

    I'm have 2.8.1 installed and missed the 2.8.2 upgrade. Auto install link doesn't show up on wp-admin/tools on wp dashboard. I've already added the "-mu" on wp-admin/includes/class-wp-upgrader.php as Donncha had directed in his post about 2.8.3 Security Upgrade. The auto install link still doesn't show up.

    As Donncha said in his post if it doesn't to manually upgrade. This will be my first upgrade.

    I understand to upgrade from 2.8.1 to 2.8.3 I need to backup database files. I've also read I have to deactivate all my plugins. I have Simple:Press Forum 4.04 installed on my site as a plug-in.

    My concern is when I deactivate the Simple:Press Forum will I lose some of the work I've put into it? Logic tells me no it won't because everything is in the database and as long as the database stays intact I won't lose any of it or my blogs.

    I'll post my site in the the forum and strut my stuff if there's any thing left after I run this update. LOL Any help as far as what files I need to update would be really appreciated.

    I'll be joining WPMU Dev premium when I make some extra money. I'm a single parent of 3 that went out of work a year ago on sick leave and after 6 months when I returned to work only to be laid off.

    Thanks in advance any help I can get!

    David

  2. andrewbillits
    Member
    Posted 13 years ago #

    Hi David,

    I understand to upgrade from 2.8.1 to 2.8.3 I need to backup database files.

    There aren't any major changes going from 2.8.1 to 2.8.3 but a backup is always a good idea. Make a DB backup as well as a backup of your WPMU install (just copy all of the files minus things like themes to your local machine).

    I've also read I have to deactivate all my plugins.

    As mentioned above this is a mild upgrade. I would just temporarily rename your /plugins/ and /mu-plugins/ directories just to make sure a plugin doesn't toss an error during the upgrade. You really should be just fine though.

    Any help as far as what files I need to update would be really appreciated.

    Just overwrite all of the WPMU files with the new files from the 2.8.3 zip.

    Thanks,
    Andrew

  3. dpd1998
    Member
    Posted 13 years ago #

    Thank you Andrew, I'm going to go do it now.

    David

  4. dpd1998
    Member
    Posted 13 years ago #

    I have it upgrade, Thank You!

    Just a few bumps while doing the upgrade. Had interuptions from my 30 and 20 year old daughters right in the middle and overwrited my themes and plugins. Only took a few minutes to get it fixed. I worked after midnight to avoid the interuptions. LOL

    I'm going to post my site in "Your WordPress MU"

    David

About this Topic