The MU forums have moved to WordPress.org

No WPMU site defined on this host. (53 posts)

  1. lajevardi
    Member
    Posted 12 years ago #

    Hey guys,
    i have wpmu on my server uploaded, mod_rewrite is enabled.
    but when i enter database details in "index-install.php" page, the following message will appear:

    No WPMU site defined on this host.

    what should i do to install wpmu?
    in addition, i've create a .htaccess file that turn register_globals and display_errors off as the README file says.

  2. lajevardi
    Member
    Posted 12 years ago #

    There's also instructions in .htaccess to do more configuration:

    <Directory>
    Options FollowSymLinks
    AllowOverride FileInfo Options
    </Directory>

    Sorry about double posts.

  3. ColdCN
    Member
    Posted 12 years ago #

    make sure NO config.php in your dirtionary and drop the table. restart install.

  4. webmaster4india
    Member
    Posted 12 years ago #

    Yes same problem. Even its not coming for me. I tried all

  5. donncha
    Key Master
    Posted 12 years ago #

    From the README:
    Please read http://trac.mu.wordpress.org/wiki/DebuggingWpmu before
    asking any questions. Without all the information required there
    we'll just ask for it anyway or worse, your request will be ignored.

  6. anderong
    Member
    Posted 12 years ago #

    i have samn problem, and nobody here answer, quite strange...donncha, don't say read something. if we can solve the problem, why we always post the problems here.

    just consider the people who is not so familiar with the script or something.

  7. donncha
    Key Master
    Posted 12 years ago #

    anderong - unfortunately you haven't given me enough information for me to answer your question. If you read through the document linked above you may find that it's a simple problem to fix.

    I do consider those not familiar with the script, that's why I wrote the debug document! :)

  8. chooch
    Member
    Posted 12 years ago #

    Figured out a fix for this this problem, it perplexed me for the better part of today. Luckily it's a real easy fix - make sure that there is NO wp-config.php file in the root of your installation, if there is delete it and refresh the screen.. This is the only thing that worked for me.

    If you are getting this error I suggest you delete all the install files from your server, untar (or unzip) a fresh set of files and upload them. Do Not enter any Db information into any files (wp-config-sample.php for example) and make sure there are no tables in the Db itself.

    P.S. - this is what ColdCN was trying to say a few posts above me, just a bit truncated is all ;)

  9. lajevardi
    Member
    Posted 12 years ago #

    Huh!? no wp-config.php? I'm goin' to try!
    thank you all guys;

    @Donncha:
    Dear donncha i read the following doc. but i couldn't do anything, anyway i'm sorry about that :)

  10. zota
    Member
    Posted 12 years ago #

    Whew! After only a six hours, I finally got to the install screen.

    Could the message "DO NOT CONFIGURE WP-CONFIG" maybe go in the readme? I don't remember seeing anything about this on the debug page either. I've been installing WordPress for years, and this really screwed me up.

    Also, for me install.php would not run if index.php is group-writable (664). Making it 644 seems to have done the trick.

  11. Farkel
    Member
    Posted 12 years ago #

    Sweet I've been waiting a while for a solution to this, gonna try this now :)

  12. Farkel
    Member
    Posted 12 years ago #

    I got past the install part and then it created some thing like http://www.domain.com/cgi-system but when I go to it it doesn't work, it's just a directory with php.cgi and php5.cgi

  13. lajevardi
    Member
    Posted 12 years ago #

    Bingo!
    i've upload a new wp-config-sample.php without any manipulation and everything looks great.(temporary, i think)
    Thank you all guys ;)

  14. lajevardi
    Member
    Posted 12 years ago #

    The file wp-config.php will generate automatically with the given information in index-install.php.

    There's no need for you to upload it manually. But an unedited wp-config-sample.php needed to be upload before installation.

    Notice: i have delete my .htaccess file with the content in the above post.

  15. matt28
    Member
    Posted 12 years ago #

    also having the same problem..

    could it be something related to vitrual host etc ?

  16. drmike
    Member
    Posted 12 years ago #

    Might help if you folks read Donncha's link so we can try to help you. :)

    Donncha, you might want to add in there a sort of "Please explain what specifically you did to generate the error. Please include file names as well." type statement.

  17. matt28
    Member
    Posted 12 years ago #

    i read the link. details of specific problem. using 06/26/2006 release and it has worked before, (had to delete and then reinstall, but now its not installing).
    when i click to install, nothing happens, i click again and then the message 'no wpmu site define' appears.
    i check mysql and there are no database tables at all.

  18. myatthu
    Member
    Posted 12 years ago #

    Check with PHP4.3 onward.
    In minimum requirement at wordpress is PHP4.2.
    For wordpressmu, you should try with php 4.3

  19. Toucouleur
    Member
    Posted 12 years ago #

    I get the same trouble

    Finally I juste added define( "WP_INSTALLING", true ); in the wp-config.php and it rocks ;)

  20. ishikawa
    Member
    Posted 12 years ago #

    I got the same problem(No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance.)

    Toucouleur's tips didn't work very well.
    There is error that is "WordPress database error: [Table 'wp_myblog.wp_1_posts' doesn't exist]
    SELECT wp_1_posts.* FROM wp_1_posts WHERE 1=1 AND (post_type = 'post' AND (post_status = 'publish')) ORDER BY post_date DESC "
    It seems wpmu hasn't created any tables on the db.

    When I installed wpmu on the same server for a testing I succeed an installation.
    I have no idea for differences between them.

  21. ishikawa
    Member
    Posted 12 years ago #

    Sorry, I misrememberd.
    I don't need to edit wp-config-sample.php myself but I did that before runnig wpmu.

  22. conpeo
    Member
    Posted 11 years ago #

    i try to figure out wpmu-setting.php whats go wrong.
    print error to find out my $blogname is 'Object'.
    so what problem i get?

  23. conpeo
    Member
    Posted 11 years ago #

    thanksss!

    I have solve my problem. = try to delete these two file (htaccess.dist & wp-config-sample or wp-config)

    retransfer upload two files again. then refresh the page is ok.
    but! must make sure mod_rewrite is enable. make folder 777 mod.

    good luck next newcomer.

  24. skcsknathan001
    Member
    Posted 11 years ago #

    my piece of advice BEFORE installing

    Give the "wp-content" directory the permission 777
    Give ".htaccess" file permission 666

  25. wccw75
    Member
    Posted 11 years ago #

    i messed up the whole thing too. now i'm trying dump everything to the root directory instead of a folder and run from there. too much headache.

  26. wccw75
    Member
    Posted 11 years ago #

    right now i have install it to my root directory.
    i'm trying to copy over some files like the photos files that i uploaded from previous month to the new blogs.dir but it gives me an error
    "550 Can't create directory: Permission denied"

    So i try to CHMOD it to 777 and it gives me
    "550 Could not change perms on 2006: Bad file descriptor"

    Why is this folder so special? tried to search in d forum but found no answer.

    So what i did try again was to rename the blogs.dir which it allows me to do and recreate another blogs.dir. Then i try to do an upload and i get the error below.
    *************************
    Unable to create directory /home/anakdatu/public_html/wp-content/blogs.dir/1/files//2006/10. Is its parent directory writable by the server?
    'Back to Image Uploading
    *************************
    the parent directory wp-content is already chmod 777

  27. andrea_r
    Moderator
    Posted 11 years ago #

    Sounds like a problem with your server settings. Ask your host.

  28. lsabug
    Member
    Posted 11 years ago #

    Yup, I had the same error because I customized the wp-config file. When i removed it and left the sample file there WP loaded and let me start the install.
    lsabug

  29. shacker
    Member
    Posted 11 years ago #

    Echo'ing what others have said: PLEASE add a line like the following to the README and to the installation debug page - a little documentation could save many people many hours of installation frustration:

    "If you're accustomed to installing WordPress by hand, note that you should NOT attempt to create the wp-config.php file for WPMU in advance of installation. WPMU installation *will fail* if wp-config.php is present."

    I'd also suggest that the README should include information on permissions.

    Finally, a recommendation for the installer screen, once you do get it up. The field asking for the "shortest possible blog URL" doesn't say what to do if WPMU is installed in a subdirectory. Does that field want just the domain name, as the example shows, or the domain name plus path? If path, should it include trailing slash? Now that I've got basic install done, I'm getting infinite redirect errors and am not sure what's causing it, but suspect it has to do with the presence or lack of a trailing slash on that field.

  30. RavanH
    Member
    Posted 10 years ago #

    Adding the lines

    <Directory>
    Options FollowSymLinks
    AllowOverride FileInfo Options
    </Directory>

    to the htaccess.dist file (and removing the wp-config.php file before reïnstalling) did the trick for me...

    Strange: instructions about that addition are not in the README anymore?

About this Topic

  • Started 12 years ago by lajevardi
  • Latest reply from andrea_r