The MU forums have moved to WordPress.org

No WPMU site defined on this host. (53 posts)

  1. RavanH
    Member
    Posted 16 years ago #

    ... Even stranger:

    I have to remove that same addition to the .htaccess immediately after installing, because it causes an internal server error when trying to log into the new WPmu installation!

    Weird?

  2. theapparatus
    Member
    Posted 16 years ago #

    It's in there.

    Line 25

    The order of the readme file got moved around a bit recently.

  3. RavanH
    Member
    Posted 16 years ago #

    It's not clear at all (to me, sorry) that that applies to the htaccess.dist file and not some other PHP or Apache config file that I have no rights to - being on a shared host...

    And the fact that I have to remove the lines again from the resulting .htaccess to get rid of the server error? Does that imply trouble ahead?

  4. lunabyte
    Member
    Posted 16 years ago #

    It could very well imply trouble.

    Shared hosting + MU = Bad Idea

    - MU "usually" violates a shared hosts TOS in one of several ways.

    - If not, it will eat up enough resources to get you kicked off without warning (if you're using MU much at all, although for a personal CMS without handing out accounts and blogs it "might" be OK.)

    MU is server level software, and the very beginning of the readme file isn't joking. You know, the part about handling a complex webserver and database environment? Not knocking ya, but it really is true.

    Also, nowhere in the readme file does it say to edit htaccess.dist (or wp-config-sample.php for that matter). The install handles it all.

    It reads from those files, to create the files it needs. Nothing more. Tinkering with those, or making your own wp-config (like many people try to do) isn't a step in the process, nor does it say to do so. Unfortunately, many people think they know WP, and buzz right through it without reading the file and understanding it.

    That being said, you mentioned it's not clear to you (the readme file). If that really is true, maybe some additional skills development in the area of apache, mysql, and PHP would be a good starting point? You'll need them.

    As for the changes that must be made to server level files, at the very least you would have to ask your host if they are willing to make those changes to their apache configuration file. Some will, and some won't for a variety of reasons. Some just aren't willing to step outside of their normal configuration which is handled by whatever system they have in place. Some don't mind, but don't want MU on their system and their "polite" way of saying it is that they don't support making those types of changes.

    I could go on and on, but a certain "knowledgeable regular" around here found out the downside of shared hosting the hard way.

  5. RavanH
    Member
    Posted 16 years ago #

    Need to learn more about LAMP, yes SIR! ;)

    Seriously, I got your point... I will ask my provider if they object to WPmu on their server and if they are willing to make the changes described in the README. I know for a fact that my provider doesn;t allow automatic symlink creation (tested with ExponentCMS multi-site setup) but is that necessary for WPmu?

    My current test setup seems to work but only if I choose the option to have blogs like http://mydomain.ext/blogname during the install process.

    I tried with http://blogname.mydomain.ext/ together with a new DNS A record entry with *.mydomain.ext. But somehow that leads to 404 and Plesk 'domain not configured' pages...

    Anyway, thanks for the advice :)

  6. basszje
    Member
    Posted 16 years ago #

    Since this is the top page in google when you search for this error another suggestion: check your database settings. I usually don't allow 'webaccounts' to drop tables and such. This might trigger a failed installation. You can try the fill-out the root sql account. Don't forget to edit wp-config.php afterwards with the correct one.

  7. vforty
    Member
    Posted 16 years ago #

    I just completed a mu install on a cpanel box.

    Received this error message after the install page:

    "No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance."

    I decided to redo the install from scratch, and discovered that Cpanel might indeed be a part of the problem. My first reinstall failed again, giving me the same error message.

    So I tried again, being careful to make sure that cpanel didn't recreate an empty .htaccess file.

    The second reinstall worked perfectly, and the only change was that I LOGGED OUT OF CPANEL COMPLETELY before deleting the empty .htaccess file, then re-doing the install.

    So, if you're on a cpanel box and you get the error message above, I suggest trying a reinstall as follows:

    1. Delete the database created in your prior install (if it was). Recreate it and add the user to it. OK to do this in cpanel.
    2. LOG OUT OF CPANEL COMPLETELY. Make sure it's not open in any window/tab in your browser.
    3. Delete all WPMU files using an ftp client.
    4. Delete the .htaccess file.
    5. Upload the WPMU files again using an ftp client.
    6. Browse to the wpmu install directory and run the install script as before.

    Good luck.

  8. andrea_r
    Moderator
    Posted 16 years ago #

    Re: steps 3,4 & 5: you really only need to delete the htaccess file.

  9. theapparatus
    Member
    Posted 16 years ago #

    Actually I just got this on a cpanel install I was doing as well. I got an error concerning a 'touch' command not working correctly during the install which causes the install to bail half way through and the database not being populated.

    As to what vforty mentions, that's what the install instructions tell the person doing the install to do to work around the error. The instructions link to this thread:

    http://mu.wordpress.org/forums/topic.php?id=99

    (OK, actually the link is broken but the thread number does work if you plug it in.)

    As noted before, reading the errors one receives is always a plus. No offense directed to vforty. I just hope they discovered the solution before spending too much time on the issue.

    edit: There's a trac ticket on the broken link.

  10. shmooth
    Member
    Posted 16 years ago #

    I got this same error, but I have no idea how that wp-config.php file got there. I guess it must have been created when I almost installed wpmu in one directory, then moved it to another.

    So, I deleted wp-config.php, and all was fine.

  11. Arlo Gilbert
    Member
    Posted 16 years ago #

    All I did was re-installed it

  12. amnesiak
    Member
    Posted 16 years ago #

    guys what if you upgraded?

    I got the No WPMU site defined on this host. after I upgraded.

    Basically the site can be found here

    http://www.iktib.com

    It works fine and NEW blogs work fine too, however older blogs don't work. Clicking on any of the links results in No WPMU site defined on this host.

    Here's the deets.

    Went from 1.3.1 to 1.3.3
    Didn't change the htaccess file
    Didn't change the wp-config

    I did run 'upgrade'.

  13. amnesiak
    Member
    Posted 16 years ago #

    any suggestions guys?

  14. amnesiak
    Member
    Posted 16 years ago #

    no genious out there that can show me a fix (which will most likely be so simple that I deserve to be slapped with a fish)?

    Just noticed something.

    New blogs now sign up as

    iktib.com/BLOG

    rather than BLOG.iktib.com

    I'm sure that's where the problem is, and don't know what I should do to fix that.

    edit: I shoul also mention that the old blogs 'blog name' in the admin panel just shows up as / and nothing more.

  15. andrea_r
    Moderator
    Posted 16 years ago #

    Somehow the VHOSt setting got turned around.

  16. technodes
    Member
    Posted 15 years ago #

    No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance. is what i get after i install and my site iws http://www.technodes.net can anyone help me

  17. svsdnb
    Member
    Posted 15 years ago #

    "Figured out a fix for this this problem, it perplexed me for the better part of today. Luckily it's a real easy fix - make sure that there is NO wp-config.php file in the root of your installation, if there is delete it and refresh the screen.. This is the only thing that worked for me.

    If you are getting this error I suggest you delete all the install files from your server, untar (or unzip) a fresh set of files and upload them. Do Not enter any Db information into any files (wp-config-sample.php for example) and make sure there are no tables in the Db itself.

    P.S. - this is what ColdCN was trying to say a few posts above me, just a bit truncated is all ;) "

    You'd think they would add REMOVE WP-CONFIG.PHP FROM ROOT TO MAKE OUR PROGRAM WORK somewhere in the Install Doc.

    ... you'd think...

    Thank you... finally got this thing to work!!!

  18. tdjcbe
    Member
    Posted 15 years ago #

    Because if you remove the wp-config.php file that's created by the install, the program doesn't work.

    Also at no point in the install, are you instructed to enter information into any file. It's all done during the install by the program.

  19. andrea_r
    Moderator
    Posted 15 years ago #

    The instructions above that say to remove the wp-config.php file are *only* if you are trying to RE-install.

  20. rbronosky
    Member
    Posted 15 years ago #

    I can consistently reproduce the "No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance." problem. Here is a transcript:
    /var/www/html/wpmu_svn$ uname -a
    Linux 2.6.18-92.1.22.el5 #1 SMP Fri Dec 5 09:29:46 EST 2008 i686 i686 i386 GNU/Linux
    /var/www/html/wpmu_svn$ apachectl -v
    Server version: Apache/2.2.3
    Server built: Oct 28 2008 07:22:40
    /var/www/html/wpmu_svn$ php --version
    PHP 5.1.6 (cli) (built: Jun 12 2008 05:02:35)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
    /var/www/html/wpmu_svn$ rm -rf 2.6.3; svn co http://svn.automattic.com/wordpress-mu/tags/2.6.3 2.6.3; chmod -R o+rw 2.6.3

  21. SteveAtty
    Member
    Posted 15 years ago #

    That tells us nothing about your installation such as domain wildcard settings, webserver settings and so on. As WPMU is running in countless sites without problems the cause of your problems is going to be something do with with your server configuration rather than WPMU itself.

  22. lunabyte
    Member
    Posted 15 years ago #

    "No WPMU site defined on this host" means:

    HTTP_HOST was not a returned value from a query to the (prefix)_site table.

    In turn, that means the site table:
    a) doesn't exist
    b) is empty

    common cause: Bad DB info (user/pass/host), or user permissions on said DB.

  23. andrea_r
    Moderator
    Posted 15 years ago #

    ...or what else is on the server or if you've followed the instructions properly...

About this Topic

  • Started 17 years ago by lajevardi
  • Latest reply from andrea_r