The MU forums have moved to WordPress.org

Import only imports 100 posts?? (4 posts)

  1. delayedinsanity
    Member
    Posted 13 years ago #

    (The versions list still doesn't list 2.8.x! C'mon people, donncha (get it?) know how hard it is to have to type out my version everytime?) (sorry, probably the energy drinks talking)

    My apologies for cross posting this, as I know a lot of you follow both forums, but I'm desperate for some help and I can't track any information down on this;

    Is there a problem with the import function, or am I missing a setting I've never seen before somewhere?

    I'm trying to wrap up a project for a client today, which should've been finalized by importing their Wordprss.com blog entries into their brand new standalone installation of Wordpress.org - however I've tried running the import three times now, and everytime out of 183 posts, it stops importing at 100 (even though it claims it's imported all 183).

    Has anybody run into this? I've tried running a few searches, but can't seem to find anybody with a similar problem.

  2. andrea_r
    Moderator
    Posted 13 years ago #

    Cut the file in half to get the remaining entries. Just grab all the funny looking stuff form the top, and remove the first 100 entries.

  3. delayedinsanity
    Member
    Posted 13 years ago #

    Thankfully I understand XML or that file would've probably driven me crazy. I cut it into two halves and imported both with no problems... this seems like an odd limitation for the import though? I would suspect it just choked on the file size if it wasn't for the round number of 100 entries before it stopped, even though it claims to have imported all of them.

    Either way, it's fixed, thank you for the quick response Andrea.

  4. andrea_r
    Moderator
    Posted 13 years ago #

    Could be anything, really. I've seen it choke all kinds of frustrating ways. :D

    Oooo, I have to tell you about Ron's plugin for selective imports:
    http://wordpress.org/extend/plugins/advanced-export-for-wp-wpmu/

About this Topic

  • Started 13 years ago by delayedinsanity
  • Latest reply from andrea_r