The MU forums have moved to WordPress.org

wpmu categories not working! how to fix :( ? (8 posts)

  1. jorrie
    Member
    Posted 14 years ago #

    I really need some advice to debug a problem I have..

    http://mysite.com/category/news gives a not found page (not my 404 but i guess a wordpress generated not found page )

    http://mysite.com/category/news/item-1 works

    I copyed a theme from a friend that worked for him he could see all posts from hissite.com/category/news

    I tryed everything
    - Permalinks are on default setting
    - No category base is set
    - Settings, reading has default settings ( first page = show posts )

    I cannot get this to work.. how can i fix this?!
    I just want to be able to list all my posts from a certain category when I do http://mysite.com/category/mycategory

    I also removed all my posts ( its a new blog )
    and recreated them assigning them to the correct category

    my news category has 2 blog posts now
    If I do edit posts then click view it shows the url as

    mysite.com/2009/08/firstnewsitem

    it also show "news" as the category on this page
    but when clicked on this link I also get the not found page

    My category link seems to work okay

    Archives in the sidebar goes to
    http://mysite.com//2009/08/

    Listing everything from this month ( 1 post )

    In my sidebar there is
    Categories
    news (1)

    But when clicked on i get

    Not Found
    Sorry, but you are looking for something that isn't here.

    Based on this code

    <div id="content" class="narrowcolumn">
    <h2 class="center">Not Found</h2>
    <p class="center">Sorry, but you are looking for something that isn't here.</p>
    <form method="get" id="searchform" action="http://demo.wielercontent.nl/">
    <label class="hidden" for="s">Search for:</label>
    <div><input type="text" value="" name="s" id="s" />
    <input type="submit" id="searchsubmit" value="Search" />
    </div>
    </form>

    Which is *not* in my template directory

    Anyone knows what is happening here?

    Even If I set permalinks to default ?cat=x I get the not found message

    Help! please

  2. jorrie
    Member
    Posted 14 years ago #

    Nobody?!

    Please help me out on this else i have to drop WPMU :(

  3. andrea_r
    Moderator
    Posted 14 years ago #

    "Archives in the sidebar goes to
    http://mysite.com//2009/08/"

    Note the extra slash. When you installed, did you stick an extra slash in there?

    Can you go to mysite.com/about/ and see the page?

  4. jorrie
    Member
    Posted 14 years ago #

    mysite.com/about/ goes okay andrea
    thx any suggestions on how to fix this?

  5. andrea_r
    Moderator
    Posted 14 years ago #

    Turn off all plugins, set the blog back to the default theme, check if you get the same issues. And try resaving the options on the permalinks page.

  6. aurepa
    Member
    Posted 14 years ago #

    Thanks Andrea! I was having this issue as well and resaving the permalinks options fixed it. Is there any way to fix this bug permanently?

    I noticed it happened when I added a user to a blog.

  7. andrea_r
    Moderator
    Posted 14 years ago #

    The devs are looking at it. hard to fix becasue we don't know what's causing it.

  8. stopha
    Member
    Posted 13 years ago #

    I'm having this problem as well

    http://buylocalbuildafuture.com/blog/category/teaching-resources/

    I have a parent category with a child category that each is set to. If you click on the post for each, it just rounds back to the full listing. I tried resetting the permalinks with no luck.

    Any suggestions? Thanks!

About this Topic