The MU forums have moved to WordPress.org

Big problem - all blogs link to main site (9 posts)

  1. amanzi
    Member
    Posted 16 years ago #

    I've just noticed a major issue on my site. All new blogs are pointing to the home page for their links. Have I done something wrong? Has anyone else seen this? For example, all links on stuart.blogtown.co.nz point to blogtown.co.nz

    Help!

  2. amanzi
    Member
    Posted 16 years ago #

    OK - I sort of fixed the problem but haven't solved it yet. This may be a bug.

    I noticed that the new blogs weren't showing up in the wp_blog_versions table. So I ran the upgrade site script, and the new blogs showed up in this table, and the links all started working again.

  3. amanzi
    Member
    Posted 16 years ago #

    I just created a new blog under my admin account and received the following errors:
    WordPress database error: [Table 'mu-wordpress.wp_48_options' doesn't exist]
    SELECT option_value FROM wp_48_options WHERE option_name = 'blogname' LIMIT 1

    WordPress database error: [Table 'mu-wordpress.wp_48_options' doesn't exist]
    SELECT option_value FROM wp_48_options WHERE option_name = 'siteurl' LIMIT 1

    WordPress database error: [Table 'mu-wordpress.wp_48_options' doesn't exist]
    SELECT option_value FROM wp_48_options WHERE option_name = 'post_count' LIMIT 1

    Anyone else experiencing this?

  4. amanzi
    Member
    Posted 16 years ago #

    Ticket #59 logged.

  5. donncha
    Key Master
    Posted 16 years ago #

    Here's the url to further discussion on that ticket: http://trac.mu.wordpress.org/ticket/59

  6. amanzi
    Member
    Posted 16 years ago #

    So it looks like this was a problem with the memcached plugin - is anyone else running this on their site successfully?

  7. donncha
    Key Master
    Posted 16 years ago #

    Wordpress.com is using memcached in a big way, and yes, occasionally there are problems with cache poisoning. One way to solve problems like this is to restart memcached after major upgrades or when Apache or MySQL have been restarted.

  8. amanzi
    Member
    Posted 16 years ago #

    Thanks donncha. I tried restarting the memcached service but I still get the same problem when creating new blogs. I have to disable memcached completely or run the wpmu upgrade site script to fix the problem.

    What does the upgrade script do that would affect memcached? Is there a way that I can set this to happen when a new blog is created? I assume that it must be flushing the cache somehow, but I can't quite figure it out??

  9. donncha
    Key Master
    Posted 16 years ago #

    The upgrade script sets WP_INSTALLING which in effect disables memcached. The signup form doesn't have that, but wp-activate.php does.
    I'm not sure at all why it's not working for you.

About this Topic