The MU forums have moved to WordPress.org

Installing WPMU on GoDaddy Shared Hosting (37 posts)

  1. rvarum
    Member
    Posted 13 years ago #

    Hi Andrea,

    I solved the issue at last :)

    the problem was that I created an actual space for the website in the shared hosting account, like any regular website with files.
    I guess it was conflicting with WMPU and the virtual subdomain it creates.
    so I deleted the domain from the shared hosting account (coz anyway it was empty of files), and now everything is running as it should with the mapping.

    i can access the virtual WPMU subdomain either from direct subdomain url or the mapped external domain :)

    Thanks again for all the help.
    Roy.

  2. musiqcentral
    Member
    Posted 12 years ago #

    Ok, this may be a similar issue, but I got lost in the thread. I have recently set up wpmu on my godaddy host, I have an a record set to * pointing to the ip that wpmu is installed on. I can administer the site with the admin user that was created, but I created a testaccount with no blog and the "control dashboard (I called the user dash "control" gives me a 403. I also tried logging in to wpmu with the admin account and navigating to the control dash and it to gives me a 403. Any help? Do I have to make apache edits to httpd through goDaddy? or can I do this myself?

  3. andrea_r
    Moderator
    Posted 12 years ago #

    Have you asked support & told them you're installing MU?

  4. musiqcentral
    Member
    Posted 12 years ago #

    yes... they don't have any answered... I just paid for a dedicated IP hoping this would help me... but the last tech told me they don't use apache.... i think he was a moron... but...

  5. musiqcentral
    Member
    Posted 12 years ago #

    you can see my site http://twittrblog.com I don't know if you can glean anything from the site itself....

  6. suhaib.faizy
    Member
    Posted 12 years ago #

    i have installed wpmu on the root of my godaddy shared hosting(Windows). its working fine with dedicated ip and wildcard subdomain. my problem is that, i have a dotnet application installed on a subfolder with some URL rewriting which is not working fine after installing wpmu. if i delete the wpmu web.config then my dotnet application is working fine, but wpmu is not working. so there is some issue with wpmu web.config file and url rewriting. please reply asap.

    content of my web.config file.

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
    <system.webServer>
    <rewrite>
    <rules><rule name="wordpress - strip index.php" stopProcessing="false">
    <match url="^index.php/(.*)$"/>
    <action type="Rewrite" url="{R:1}"/>
    </rule>
    <rule name="wordpress - 1" stopProcessing="true">
    <match url="^(.*/)?files/$"/>
    <action type="Rewrite" url="index.php"/>
    </rule>
    <rule name="wordpress - 2" stopProcessing="true">
    <match url="^(.*/)?files/(.*)"/>
    <conditions>
    <add input="{REQUEST_URI}" negate="true" pattern=".*wp-content/plugins.*"/>
    </conditions>
    <action type="Rewrite" url="wp-content/blogs.php?file={R:2}" appendQueryString="false"/>
    </rule>
    <rule name="wordpress - 3" stopProcessing="true">
    <match url="^(.+)$"/>
    <conditions>
    <add input="{REQUEST_URI}" pattern="^.*/wp-admin$"/>
    </conditions>
    <action type="Redirect" url="{R:1}/" redirectType="Permanent"/>
    </rule>
    <rule name="wordpress - 4" stopProcessing="true">
    <match url="."/>
    <conditions logicalGrouping="MatchAny">
    <add input="{REQUEST_FILENAME}" matchType="IsFile" pattern=""/>
    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" pattern=""/>
    </conditions>
    <action type="None"/>
    </rule>
    <rule name="wordpress - 5" stopProcessing="true">
    <match url="^([_0-9a-zA-Z-]+/)?(wp-.*)"/>
    <action type="Rewrite" url="{R:2}"/>
    </rule>
    <rule name="wordpress - 6" stopProcessing="true">
    <match url="^([_0-9a-zA-Z-]+/)?(.*\.php)$"/>
    <action type="Rewrite" url="{R:2}"/>
    </rule>
    <rule name="wordpress - 7" stopProcessing="true">
    <match url="."/>
    <action type="Rewrite" url="index.php"/>
    </rule></rules>
    </rewrite>
    </system.webServer>
    </configuration>

  7. brian7997
    Member
    Posted 12 years ago #

    I just installed WPMU on an alias domain on my shared hosting plan at godaddy.com

    First you have to have a dedicated IP, after you purchase it you must apply your dedicated IP to the hosting (http://help.godaddy.com/topic/306/article/1057)

    Then if you are using an aliased domain you need to edit the .htaccess in the root. This is what I found that worked. I have a wordpress install in my root as well as the MU in a folder.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteCond %{HTTP_HOST} ^(www.)?([a-z0-9-]+).domain2.com [NC]
    RewriteCond %{SCRIPT_FILENAME} !^/domain2folder [NC]
    RewriteRule ^(.*)$ /zinegeist/$1 [L]
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    I was having a problem with the ssub.domain2.com going to sub.primarydomain.com and showing primarydomain.com

    If you are getting 403 errors it is probably caused by the dedicated ip no being fully propagated. Make sure it is applied to the account and give it 4-24 hours.

    Once it is set up it will show in your hosting control center summary

    Server IP Address: 72.167.131.XX
    Dedicated IP Address: 72.167.187.XX

    Hope this helps!

About this Topic

  • Started 13 years ago by rvarum
  • Latest reply from brian7997