The MU forums have moved to WordPress.org

Registration email not working (12 posts)

  1. zanfardinom
    Member
    Posted 13 years ago #

    Hi all,

    I have enabled everything in the options to allow users to register. When I run a test and register a user I get the confirmation message stating that I need to activate my account (will send via email in 30 minutes or less). I never receive that email. I have talked to our IT support and have all the variables.

    Here's my current setup. I have installed Apache, MySQL and PHP separately (no package like wamp). So, for Apache to work I had to disable IIS and in doing so I can't use the mail server. So, how do I get this to work. I am using a Windows 2003 server for hosting.

    thanks in advance.

    mz

  2. SteveAtty
    Member
    Posted 13 years ago #

    you can use external email services like google if you install the right plugin

  3. zanfardinom
    Member
    Posted 13 years ago #

    Thanks, SteveAtty for the quick response. But, I have to use our internal exchange server. Any ideas!

    mz

  4. alespinola
    Member
    Posted 13 years ago #

    I'm having a similar problem! Look: http://mu.wordpress.org/forums/topic/14107?replies=2
    Nobody has answered yet however... :S

  5. SteveAtty
    Member
    Posted 13 years ago #

    To be fair its more of a php email configuration issue rather than a WPMU problem.

  6. webhostuk
    Member
    Posted 13 years ago #

    Yaa I feel the same it can be php mail function issue.

  7. zanfardinom
    Member
    Posted 13 years ago #

    Thank you all for your answers and time. I am leaning towards a php mail function issue also. So, where should I enable this? The WPMU sits on one server and the exchange is on another. Should the IT department add/enable something to the exchange server and if so, what? Or, should I add/enable something to the WPMU server and if so, what?

    Thanks in advance.

    mz

  8. SteveAtty
    Member
    Posted 13 years ago #

    You can configure email settings in your php.ini file. Dont forget to restart Apache after you've made any changes.

  9. zanfardinom
    Member
    Posted 13 years ago #

    Hi SteveAtty,

    I have configured my email settings in php.ini file and still no go. Currently, our exchange server does not support PHP (I hope I'm saying this right) and the WPMU server has PHP. All I get, when registering, is this message:

    Congratulations! Your new blog, First Last's Podcast, is almost ready.

    But, before you can start using your blog, you must activate it.

    Check your inbox at lastf@domain.tld and click the link given. It should arrive within 30 minutes.

    If you do not activate your blog within two days, you will have to sign up again.
    Still waiting for your email?

    If you haven't received your email yet, there are a number of things you can do:

    * Wait a little longer. Sometimes delivery of email can be delayed by processes outside of our control.
    * Check the junk email or spam folder of your email client. Sometime emails wind up there by mistake.
    * Have you entered your email correctly? We think it's lastf@domain.tld but if you've entered it incorrectly, you won't receive it.

    Any ideas?

    mz

  10. SteveAtty
    Member
    Posted 13 years ago #

    So what have you put in the php.ini file for the mail configuration?

  11. zanfardinom
    Member
    Posted 13 years ago #

    I updated the [mail function] section.

    [mail function]
    ; For Win32 only.
    SMTP = subdomain.domain.tld
    smtp_port = 25

    ; For Win32 only.
    sendmail_from = me@domain.tld

    ; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
    ;sendmail_path =

    ; Force the addition of the specified parameters to be passed as extra parameters
    ; to the sendmail binary. These parameters will always replace the value of
    ; the 5th parameter to mail(), even in safe mode.
    ;mail.force_extra_parameters =

  12. alespinola
    Member
    Posted 13 years ago #

    That php.ini looks pretty like mine... the problem is not there I think...
    Here is mine (and it is working):

    [mail function]
    ; For Win32 only.
    ; http://php.net/smtp
    SMTP = smtpserver.mydomain.com
    ; http://php.net/smtp-port
    smtp_port = 25

    ; For Win32 only.
    ; http://php.net/sendmail-from
    sendmail_from = admin@mydomain.com

About this Topic

  • Started 13 years ago by zanfardinom
  • Latest reply from alespinola