The MU forums have moved to WordPress.org

Version 2.8.4a eats up too much memory (18 posts)

  1. kalihim88
    Member
    Posted 13 years ago #

    I have recently upgraded my wordpress mu installation from version 2.7.1 to 2.8.4a with the following plugins:
    Buddypress
    BP-FBconnect
    All in one SEO Pack
    Open Inviter
    and Welcome Pack for Buddypress.

    My site was running fine before upgrade. but immediately after I upgraded I was greeted by an Out of memory allocation error right from the dashboard. I cannot even write any posts anymore, because the php error was popping everywhere.

    My host's default php memory limit was 32MB and I raised it to the maximum allowed limit which was 64MB but still the error prevailed. I tried raising the memory in php.ini and wp-config to maximum allowed limit to no avail. I searched this forum for all the possible solutions but the error was still there. So I decided to revert back to my old version, hoping that in the future releases this memory problem will be solved. :(

  2. SteveAtty
    Member
    Posted 13 years ago #

    So what was causing the out of memory error? Was it one of the core WPMU files?

  3. henrikbox
    Member
    Posted 13 years ago #

    I have a similar problem. Updated to 2.8.4a from 2.7.1
    Everything went fine, updated all the plugins to the preffered version.

    After a while, my cpu and memoryusage whent through the roof. Restarded twice - but nothing helped. Reverted back to my 2.7.1 - kept the database though, and everything is fine again.

    Anybody else had the same problem?

  4. SteveAtty
    Member
    Posted 13 years ago #

    Which processes were eating memory and CPU?

    I've got a box with 1GB of RAM and mysql is using about 10% of it and when apache serves a page it takes a good chunk of CPU for a fraction of a second and then it all goes quiet.

    I'm on 2.8.4a

  5. henrikbox
    Member
    Posted 13 years ago #

    I couldn't see which process that were eating the cpu.
    It was eating all the time - no pauses or nothing.

  6. SteveAtty
    Member
    Posted 13 years ago #

    Then you need to find out what it was, and find out what was eating the memory too.

  7. henrikbox
    Member
    Posted 13 years ago #

    Is that possible to see in logs?

  8. SteveAtty
    Member
    Posted 13 years ago #

    no, you'd need to be running something like top and get the problem to catch it

  9. webhostuk
    Member
    Posted 13 years ago #

    If you have access to your server you can check access logs on the server for this domain to find out what was wrong.

  10. tim.moore
    Member
    Posted 13 years ago #

    You should also consider using WP Super Cache. If you have root access to your Web server, you should also look into optimizing Apache and installing a PHP opcode cacher (XCache for example).

  11. kalihim88
    Member
    Posted 13 years ago #

    So how do you check the logs for what was eating the most memory? Is there some kind of php file I have to insatll like phpinfo?

  12. SteveAtty
    Member
    Posted 13 years ago #

    You can only really reliably see memory/cpu load as it currently stands using something like top.

    The normal apache and php logs don't log that sort of information, but they will record out of memory errors when they occur.

    Also when the php out of memory error occurs it will tell you which php file is exhausting memory. I asked that right back at the top of the conversation. If we know which file is causing the problem then that could help us narrow down where the problem lies.

  13. viniciusandre
    Member
    Posted 12 years ago #

    I reproduced this problem.

    It was impossible to run Wordpress MU 2.8.4 and 2.8.5 due to memory usage. PHP keeps giving the "failed to allocate" error all the time and doesn't load any outsourced script (like plugins or custom functions), and halfly loaded some pages.

    Well, I had to downgrade to 2.7.1 quickly, the website couldn't be offline, and I'm sorry that I can't test it throught top or any other Unix command.

    The server had a 24MB memory limit on php.ini.

  14. tdjcbe
    Member
    Posted 12 years ago #

    The server had a 24MB memory limit on php.ini.

    Why not bump it up to a higher number, say 32megs?

    I'm sure you've thought of that and I'm not suggesting it to be rude but at the very least, it's a work around to get the site upgraded and running.

    And make sure that you have some form of caching in place.

  15. SteveAtty
    Member
    Posted 12 years ago #

    I've got my php memory set to something like 128MB and things run a lot faster.

    Also if you read the README:

    2. If your PHP is compiled with memory limit checks, the default is 8MB
    which is much too small. You should increase this to at least 32MB or 64MB
    to avoid PHP out of memory errors. Look for "memory_limit" in your php.ini
    file.

  16. viniciusandre
    Member
    Posted 12 years ago #

    tdjcbe, I'm not root of the server. I can't change php.ini or create a working .htaccess setting memory limit. I'm considering about using WP Supercache.

    SteveAtty, I'm sure that would "fix" the problem, but the difference from 2.7.1 to 2.8.4 looks quite big to me. I never had any problem with WPMU on about 2 years using 24MB on PHP memory options.

  17. SteveAtty
    Member
    Posted 12 years ago #

    I don't think that readme has changed for quite a while - so the fact that you've been getting away with only 24MB is probably down more to good luck rather than anything else.

    I reported performance problems with only 32MB of memory allocated about 2 years ago.

  18. tmoorewp
    Member
    Posted 12 years ago #

    viniciusandre: you can set the memory limit available for WordPress in the wp-config.php file. It'll override the PHP memory limit when running WordPress.

    Do this with:

    define('WP_MEMORY_LIMIT', '128M');

    This assumes that your server has 128MB of available memory.

About this Topic

  • Started 13 years ago by kalihim88
  • Latest reply from tmoorewp