The MU forums have moved to WordPress.org

MySQL 3.x Unsupported (22 posts)

  1. itdamager
    Member
    Posted 18 years ago #

    After racking my brain for a few days, I find out that mysql 3.x support no longer works because a couple of queries in upgrade-schema silently fail to create the required tables.

    Some timestamp fields were added that breaks compatability yet I can find nothing in the code that verifies which mysql version you have, only that the php module exists, nor can I find minimum requirements anywhere.

    Any way we can get it working for 3.x again?

  2. andrewbillits
    Member
    Posted 18 years ago #

    Is there any certain reason why you are still running MySQL 3.x? Why not upgrade to atleast 4.x?

    Just curious.

  3. vaderag
    Member
    Posted 17 years ago #

    Just going to bump this, because i need to get it working with MySQL 3.x as my host wont update.
    Is there an older version i can use that will work (i cant find a release history for this like i could with WP)

  4. lunabyte
    Member
    Posted 17 years ago #

    MySQL 3.x is unsupported, and there is no magic cure.

    I'd recommend finding another host.

    Older versions would bring about security risks, etc.

  5. drmike
    Member
    Posted 17 years ago #

    I think it was mysql 4.x from the getgo.

  6. lunabyte
    Member
    Posted 17 years ago #

    And isn't/wasn't there discussion of dropping 4.0 support in the main WP trunk at some point in the not so distant future?

  7. andrewbillits
    Member
    Posted 17 years ago #

    4.0 or or 4.X?

  8. lunabyte
    Member
    Posted 17 years ago #

    4.0, and moving to 4.1 as the minimum.

    Which really, I can't see what there's 3.X out there still anyway.

  9. andrewbillits
    Member
    Posted 17 years ago #

    No one should still be using 3.X but 4.1 is still heavily used.

  10. lunabyte
    Member
    Posted 17 years ago #

    Yep. Which is why the call was to move forward with 4.1+ compatibility.

    For the life of me though, I can't remember where I read it. But, thinking back about it, it might have been on the w-hackers list. Which, because of it being infiltrated by less than on-topic discussion, I checked out of.

    What comes to mind was 4.1 support from 2.2 (or 3) moving forward. I don't know if it came to light completely, but it wouldn't surprise me.

  11. vaderag
    Member
    Posted 17 years ago #

    Ah, that's a pain... nevermind... guess i'll just have to stick with normal wordpress for now...

  12. lunabyte
    Member
    Posted 17 years ago #

    Um, that's where the database version compatibility is coming from.

    2.1 is OK, I think (don't hold me to it), but I don't know about 2.2.

    It might be, but then again it might not.

    WordPress Minimum Requirements

    PHP 4.2
    MySQL 4.0
    ...

  13. vaderag
    Member
    Posted 17 years ago #

    I can use an older version of wordpress tho, i cant find an older version of MU...

  14. drmike
    Member
    Posted 17 years ago #

    The point is even older versions of mu wouldn't work since it was 4.x+ only from the start.

    At least i think it was.

    See this thread on how to pull older versions. Just modify the changeset number within the url.

  15. lunabyte
    Member
    Posted 17 years ago #

    As a note: you're opening up I dunno how many holes as well.

    /me I'd be finding a better host.

  16. drmike
    Member
    Posted 17 years ago #

    I go ahead and throw this out.

    jumpline.com is giving away a free year's vps hosting.

    There's some question though about if they support wildcard dns or not. I had to resend in the question along with the link Matt's walkthru as the reply didn't make any sense. So I don't know if they'll support wpmu.

    my host synhosting.com will give you free 3 or six months hosting just for coming from a different host as well. And I know they support wpmu. :)

  17. drmike
    Member
    Posted 17 years ago #

    Just for reference, jumpline doesn't allow wildcard dns.

    So much for being flexable.

  18. lunabyte
    Member
    Posted 17 years ago #

    They're giving away a year free? Huh, ain't that something.

    I used to have several VDS accounts there. Granted, never tried MU on it.

    I told em to stick it close to 3 years ago when I was doing their tech supports job for them.

    I am surprised that their DNS tool doesn't do wildcards though. It used to, I think. Although I had my own name servers with them at the time.

  19. jaredbangs
    Member
    Posted 17 years ago #

    I believe there was a recent conversation on the wp-hackers list regarding when it would be appropriate to require version 5 of both PHP and MySQL.

    The general consensus (or at least from Matt, etc.) was that no such move would be made unless the current platform couldn't handle some future requirement (either that or major un-patched security problems, I suppose).

    But, yeah, I'd say if the host won't upgrade MySQL beyond version 3 it's time for a new host.

  20. vaderag
    Member
    Posted 17 years ago #

    I'd agree, but it isnt my call - i'm working on behalf of a client...

  21. lunabyte
    Member
    Posted 17 years ago #

    Time to make the recommendation to them then.

    Let them know that if this is the solution they want, that they need to have the support to run it.

    If it's their own equipment (as in, in-house), then "someone" there can force the issue.

    Moving to an earlier version won't work, as discussed, and wasn't even supported a year ago.

    Also, and earlier version would be a security nightmare waiting to happen.

  22. drmike
    Member
    Posted 17 years ago #

    Gotta amdit that I agree. I had a church choir group who wanted a 120+ meg audio clip on their home page and wanted it to load first before any of the rest of the page loaded.

    Told them no and tried to explain why. They didn't want to listen and went with another designer who went ahead and did it.

    Imagine trying to explain that when the pastor tried to load the page via AOL dialup. ;)

About this Topic

  • Started 18 years ago by itdamager
  • Latest reply from drmike