The MU forums have moved to

WPMu Not creating table wp_site (11 posts)

  1. rsgrone
    Posted 14 years ago #

    Well finally I have been able to recreate my problem on my own 2008 IIS 7 server here at home.

    Fatal Error
    If your blog does not display, please contact the owner of this site.

    If you are the owner of this site please check that MySQL is running properly and all tables are error free.

    Database Tables Missing.
    Database tables are missing. This means that MySQL is either not running, WPMU was not installed properly, or someone deleted wp_site. You really should look at your database now.

    What do I do now?
    Read the bug report page. Some of the guidelines there may help you figure out what went wrong.
    If you're still stuck with this message, then check that your database contains the following tables:
    If you suspect a problem please report it to the support forums but you must include the information asked for in the WPMU bug reporting guidelines!

    Anyone have any ideas as what fields I need to add to this table to get this to work? --- By the way this is day three

  2. rsgrone
    Posted 14 years ago #

    P.S. I just attempted to report "a bug" read throguh the entire documentation, search for "wp_site" found nothing however, exactly which of the plethora of links do you choose to report the "bug"


  3. andrea_r
    Posted 14 years ago #

    Before you file a trac ticket, does the database user have ALL permissions on the database?

  4. rsgrone
    Posted 14 years ago #

    I am the only user, creator, physical owner of this 2008 server (quad core, 16 gigs memory)

    I just tried on the web site and am getting the 404 error after the login screen -- It would appear to configure correctly, sends to the login screen (which appears unformatted -- no css styling --- shoved to the left of the screen) and then dies with the 404 error...

    I am looking at the .htaccess right now and the config.php to see if there is something that can be tweeked ---

    RewriteEngine On
    RewriteBase /blog/
    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off

    Any thoughts?

  5. andrea_r
    Posted 14 years ago #

    You had to create a database. And a database user. This user has a password. This user also needs permissions to work on the database. One of these options is set to ALL. That's what you need to check.

    You can't jigger the config or htaccess to get it to work. It must create the database tables itself, or you need a WPMU database to fudge it.

    Delete wp-config.php & .htaccess. If you're running IIS, you also need a paid add-on module for the mod-rewrite rules.

  6. rsgrone
    Posted 14 years ago #

    Yes andrea would you like to see a screenshot of the table?

    Unfortunately it will not allow me to place a a jpg here however, after tinkering around a bit, my "css" is still messed up AFTER the final install page that looks fine, and when I hint the link to the login page is where the formatting is lost. NOW however, if I put my username and password in I am getting the 404 page error

    (and of course ignoring the dns settings -- for I choose the default installation method for grins)

    Installation Finished!
    Your WordPress µ site has been configured.

    You can log in using the username "admin" and password a685b8d392c7

    Warning! Wildcard DNS may not be configured correctly!
    To use the subdomain feature of WordPress MU you must have a wildcard entry in your dns. The installer attempted to contact a random hostname ( on your domain but failed. It returned this error message:

    From the README.txt:

    If you want to host blogs of the form http://blog.domain.tld/ where domain.tld is the domain name of your machine then you must add a wildcard record to your DNS records.
    This usually means adding a '*' hostname record pointing at your webserver in your DNS configuration tool. Matt has a more detailed explanation on his blog. If you still have problems, these forum messages may help.

    You can still use your site but any subdomain you create may not be accessible. This check is not foolproof so ignore if you know your dns is correct.

    Directory Permissions
    Please remember to reset the permissions on the following directories:


    You can probably use the following command to fix the permissions but check with your host if it doubt:
    chmod 755 D:\blog D:\blog/wp-content/

    Further reading

    If you run into problems, please search the WordPress µ Forums where you will most likely find a solution. Please don't post there before searching. It's not polite.
    There is also the WordPress µ Trac. That's our bug tracker.

    Thanks for installing WordPress µ!

    wpmu version: 2.8.4a

    WordPress µ | Support Forums

    Screen Two:



    Remember Me

    Lost your password?

    ← Back to

    And trust me minus the form fields in that cut paste, that is exactly what it looks like, a nasty looking first timer html web page...

    Then, I get the 404 page error

  7. rsgrone
    Posted 14 years ago #

    AFTER THOUGHT --- I am using ZEND Server PHP with there Java Bridge -- ever hear of any "issues" usinf ZEND? Although, the previous rev of Mu I was using worked fine -- where can I get a copy?

  8. rsgrone
    Posted 14 years ago #

    And one last note:

    <?xml version="1.0"?>
          <rules><rule name="wordpress - strip index.php" stopProcessing="false">
                        <match url="^index.php/(.*)$"/>
                        <action type="Rewrite" url="{R:1}"/>
                    <rule name="wordpress - 1" stopProcessing="true">
                        <match url="^(.*/)?files/$"/>
                        <action type="Rewrite" url="index.php"/>
                    <rule name="wordpress - 2" stopProcessing="true">
                        <match url="^(.*/)?files/(.*)"/>
                            <add input="{REQUEST_URI}" negate="true" pattern=".*wp-content/plugins.*"/>
                        <action type="Rewrite" url="wp-content/blogs.php?file={R:2}" appendQueryString="false"/>
                    <rule name="wordpress - 3" stopProcessing="true">
                        <match url="^(.+)$"/>
                            <add input="{REQUEST_URI}" pattern="^.*/wp-admin$"/>
                        <action type="Redirect" url="{R:1}/" redirectType="Permanent"/>
                    <rule name="wordpress - 4" stopProcessing="true">
                        <match url="."/>
                        <conditions logicalGrouping="MatchAny">
                            <add input="{REQUEST_FILENAME}" matchType="IsFile" pattern=""/>
                            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" pattern=""/>
                        <action type="None"/>
                    <rule name="wordpress - 5" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?(wp-.*)"/>
                        <action type="Rewrite" url="{R:2}"/>
                    <rule name="wordpress - 6" stopProcessing="true">
                        <match url="^([_0-9a-zA-Z-]+/)?(.*\.php)$"/>
                        <action type="Rewrite" url="{R:2}"/>
                    <rule name="wordpress - 7" stopProcessing="true">
                        <match url="."/>
                        <action type="Rewrite" url="index.php"/>
  9. andrea_r
    Posted 14 years ago #

    AHA! :D Here's your issue:


    WPMU won't work very well with a single-word domain. If it had been just localhost it would have shown a warning. in your your hosts file make one called or something and try that.

  10. rsgrone
    Posted 14 years ago #

    Problem solved (kind of read on) and it had nothing to do with the D:\blog thing, mysterious creeping files looking for dupe config.php or anything (not to sound coarse just really frustrated is all)....

    When I went to incorporate bbpress with Mu the other day for some reason the DNS configuration in my c:\......\applicationhost.conf file got screwed up....

    That is why during the setup screen it was throwing in Blogs

    I cannot believe this after all these hours wasted I simply had to drop the binding to the IP address and the damn thing worked (almost)... It is installed but I ran into the same issue as before except, my css was perfect... Once I logged in, I go the blank page so, I went into the IIS manager and browsed the editcomments.php page and got to the admin dashboard. From there I adjusted my permalinks and budda bing, the thing is up and running WITH another copy of Wordpress (which I had to do the same thing with by the way (and that happened after that auto update routine and hasn't worked correctly since)) in the parent directory of the web root hence, my index.html home page is in the same directory as the standard wordpress where as, my wordpressmu is in the d:\blog directory right next to my d:\website directory (which neither are in the "inetpub" folder....

    I cannot believe this, that is why I could get it running on my server here at the house (which is how I troubleshot it)....

    However, there is still that issue with the permalinks... Now I will need to go into the url re-write feature of the IIS 7 web server and delete all the rules that were just written....

    So this is a resolved with an error.... but as you folks say, you aren't Microsoft people you are the open source group.... There still within lies buggy code for IIS servers....

    So the morale to the story is that the bbPress feature that allows itself to be tied into the Mu on an IIS Server is not a harden, tested procedure.... Users BEWARE!!!!!!

    Thanks for the help....

  11. rsgrone
    Posted 14 years ago #

    PS How do I change the status of this thing from open to kind of resolved/closed....

    And why it failed to write the complete tables is beyond me.. I am looking at them also to see what happened but I believe it is bad indexing tied to the thing... MySQL being alive and well on my server must have said "you don't have permissions from, to write that type of data here" and dropped the sit_meta table

    A nightmare with one fix and one work around....

    PSS and not to mention the bbPress conversion tore the living crap out of my java bridge... I had to reinstall from the ground-up even with the the two fixes above, I wouldn't have been able to recover everything once the melt down began...

About this Topic