The MU forums have moved to

Creating a new blog shows blank page, no errors? (22 posts)

  1. mralexweber
    Posted 14 years ago #

    Hey guys...
    long time lurker, first time poster (be gentle!)

    The Situation
    So I've set up our site, and it works! So far, so good.

    I've created a second blog ("douche", don't ask) that lives at . I intend to move it to its own domain later, but for now, I just want to get it working.

    The Problem
    If you visit , there's nothing there. Just a blank page.
    I've been checking out as much documentation, forum posts, etc. as I can but haven't found anything on problems with creating second blogs.

    We've done a bit of troubleshooting. One is enabling PHP error logging, which isn't giving me anything. We tried enabling in-place PHP errors, but didn't see anything on the page.
    When I visit , I can log in and such, but see all the posts/comments/content from our main blog.

    Is VHOST true or false?
    -I believe it's true.

    Is the path to your WordPress MU install "/" or some directory?
    -it's installed at []/blog/

    Anything in the error logs? If you didn't get a welcome email, check your mail logs.
    -Can't find anything specific to this site in the logs. Did receive email notification that we'd created the new blog, new user, etc. Also, I did add users specifically as blog admins (my own account, for instance)

    Did you receive any sort of error within your browser? If so, what was the specific error?
    -No errors in the browser, even with PHP errors enabled.

    Does the information in wp_blogs, wp_users and wp_site match your blog, user and site?
    -in wp_blogs, the only difference is that "public" is set to "1" while its set to "0" on my main blog (/blog/)
    -wp_users has a bunch of users in it already, but it looks fine. anything i should look for here?
    -wp_site only has one entry, for /blog/. Here's what it looks like:
    id domain path
    1 /blog/

    Mention the version number, SVN check-in number or the date you downloaded the snapshot.
    -using 2.8.1, we upgraded right when it came out. However, my dashboard still thinks I need to upgrade (separate issue, i believe)

    Plugins in place? Have you tried turning them off and seeing if that affects the issue?
    -tried disabling all plugins, no change.

    Server environment: Apache or IIS? What OS are you running? Any proxy or cache server in place?
    -Apache on Windows Server 2008 Standard. I'm thinking that the permissions might be a problem because of this...

    End user environment: Browser and version? (IE, Opera, Netscape, Safari?) OS? Security programs?
    -using Chrome on Windows XP Home SP2. BitDefender is my security suite, firewall and antivirus.

    How to dupe the error.
    -visit , the page is blank. if you visit , you'll see our main blog.

    Thanks for any help you can provide, further troubleshooting instructions, or just well-wishes!


  2. andrea_r
    Posted 14 years ago #

    Big blank screen = errors. Always.

    So, you can get in the backend, that's good. This says the blogs are working, but the white screen says that the theme you've selected or the plugins that are on (or OFF) are the problem.

  3. mralexweber
    Posted 13 years ago #

    Big blank screen = errors. Always.


    Well, since I've tested with the plugins disabled, that shouldn't be the problem. I'll bet it's the themes. How can I force-enable them?


  4. tim.moore
    Posted 13 years ago #

    Don't just disable the plugins, remove them entirely. You can do this by temporarily renaming your plugins and mu-plugins folders.

    Also, for security, you should look into upgrading to 2.8.4a, the latest version of WordPress.

  5. andrea_r
    Posted 13 years ago #

    Go to site admin menu -> Blogs. Find the blog with the WSOD and clcik the Edit link the shows up when you hover over the blog name.

    Now, at this menu, find way down where it says theme template and theme stylesheet. Set them both to default.

    Now check the blog. Should be good if it was the theme.

  6. mralexweber
    Posted 13 years ago #

    tim.moore, When I disabled the plugins, I did it in this way--moved them to another folder called 'disabled-plugins'

    andrea_r, my "theme template" and "theme stylesheet" are both already set to default :-/. I've also futzed with the themes enabled site-wide and everything seems kosher there.

    I've noticed that when i visit , there is no page title, either.

    thanks again, guys.

  7. SteveAtty
    Posted 13 years ago #

    So what is in your php error logs?

  8. andrea_r
    Posted 13 years ago #

    And do you have anything in the mu-plugins folder? (That counts too)

  9. mralexweber
    Posted 13 years ago #

    SteveAtty, unfortunately there is nothing related to my wpmu site in the error logs. Is there somewhere in wordpress configs that I need to enable error logging? I followed what was suggested in the readme...

    andrea_r, i have the mu-multi-site plugin, but disabled the entire folder (by renaming it to /no-mu-plugins/) and still experienced the blank page of doom.

    Danke Schoen :)

  10. tim.moore
    Posted 13 years ago #

    Are you still experiencing issues? I notice that you get a blank page at /blog/douche right now, but also that the /blog/douche/wp-admin goes to an internal server error problem.

    Do you have mod_rewrite enabled on your Apache server?

  11. andrea_r
    Posted 13 years ago #

    "Is there somewhere in wordpress configs that I need to enable error logging?"

    No, error logging is a server function.

    Is it even creating the tables in the db for the new blogs?

  12. mralexweber
    Posted 13 years ago #

    tim, mod_rewrite is enabled. I can log in to , but the admin-panel looks identical to that at same posts, comments, etc. I expect that it would look different if it were accessing a different blog.

    andrea, gotcha. I did enable error logging on the server, just wanted to make sure I wasn't missing anything because there was NOTHING from wordpress at all.

    as per the DB, i have tables like wp_2_posts, wp_2_comments, etc. wp_blogs also has entries for each of the new ones i've created.

    Again, thanks for your help. Muchas gracias ;-)

  13. tim.moore
    Posted 13 years ago #

    What's the fist number that is created? Meaning, do you have tables like wp_1_posts or does it start at wp_2_posts?

    Also, when you first set up WPMU, did you give the URL for the site as or

  14. mralexweber
    Posted 13 years ago #


    I have wp_1_posts, which contains the blog at

    When I create a new blog, it starts at wp_2_posts, and continues from there.

    We set up WPMU with, using sub-directories (not subdomains)


  15. tim.moore
    Posted 13 years ago #

    You should try installing again and give the site URL as Remove the www.. That is likely causing some issues.

  16. mralexweber
    Posted 13 years ago #

    yikes! my site is live (in production) so I very much want to avoid taking it down.

    If anyone else has alternate suggestions, I'd much appreciate them.

    That said, Tim, do you have any resources on how to back up WPMU for a quick restore?


  17. tmoorewp
    Posted 13 years ago #

    There are a few places that you can edit the database, since it is live. I think they are wp_X_options, wp_site, and wp_blogs. Just edit the URL and take out the www.

  18. mralexweber
    Posted 13 years ago #


    first one (wp_1_options) didn't break anything. second one (wp_site) also didn't break anything.

    changing the entry in wp_blogs threw an error:
    "Could Not Find Blog!
    Searched for in wpmu::wp_blogs table. Is that right?"

    I'm going to contact our previous server admin to see if we've got any mod_rewrites going on, but it looks like that's not it. :-(


  19. mralexweber
    Posted 13 years ago #

    Hm, I never knew about MU's problems with www.! has more info on the subject, and possibly how to avoid this problem.

    I'm trying the steps from to set up my separate domains now. Fingers crossed that I don't have to re-install!

  20. andrea_r
    Posted 13 years ago #

    I recently wrote how we did multiple domain setups here:

  21. jamesmehorter
    Posted 13 years ago #

    mralexweber: Hey I ran into this same problem when creating new blogs after changing to subdirectories instead of subdomains, it would show just a blank page with no errors in my php error log. Turns out the theme is not being set. You should still be able to get into wp-admin and set the theme and voila. If you put your new blog default theme into 'themes > default' it should set automatically. Hope that helps.

  22. thakursahib
    Posted 13 years ago #

    @mralexweber,@ALL, Were you able to solve your problem. I am also facing the same pro. i am using mu 2.9.1. on hostmonster/bluehost apache servers. i have sub directory option. I am able to create the blogs from admin panel, they also shows up on main admin panel, but when i log in for the new blog admin, it shows me my main blog admin panel with existing post and comments. Also when i view the new blog it shows me page not found error. I have chcked on database, it is creating the tables for new blog, and also creating a row in wp_blog table.
    help on this needed.

    Thanks a lot in advance.

About this Topic

  • Started 14 years ago by mralexweber
  • Latest reply from thakursahib