The MU forums have moved to WordPress.org

Server won't send emails (8 posts)

  1. TheCasanove
    Member
    Posted 11 years ago #

    I really really need help here.
    My server won't send a single email. From the email that I as an admin am supposed to get at installation to the email when new users register - the server just won't send anything.
    I have tried quite a bit now and as I am no expert on servers I could need a hand here.

    PHP mail() and SMTP configurations will both return

    Test Message Sent
    
    The result was:
    bool(true)
    
    The SMTP debugging output is shown below:

    This lets me suggest that something is working. Nevertheless no email will be sent out.
    I tried my own SMTP Server and also Gmail... My server doesn't support encryption so I just tried the basic options. With Gmail however I tried every single encryption and port that gmail is capable of.

    Does anyone have a clue what might be going on here?
    My webspace is hosted on 1and1 and it's only a webspace+mysql solution - no virtual or real server. But still - I am pretty sure this should work.
    So far phpBB and Wordpress are runnung on the server and they run fine. They send emails and everything.
    vBulletin is showing the same errors, though vbulletin gives me an errormessage when not sending the mail.

    I can provide you with a few server informations... I am not sure which ones are relevant.
    Oh and mail() is on...

    I really hope someone will answer.
    Make the world a bloggier place and help me! :D

  2. VentureMaker
    Member
    Posted 11 years ago #

    Hey there.

    OK, so emails aren't sent when users sign up?

  3. TheCasanove
    Member
    Posted 11 years ago #

    there too. But NO email ever is sent by wordpressmu on my server.
    Not when I installed it. (it should send out my admin password then)
    Not when users sign up for a blog or as readers
    not on new comments.

    The testmail is said to be sent (response like in the post above) but it actually never arrives.

  4. VentureMaker
    Member
    Posted 11 years ago #

    Anything in error log?
    phpinfo output can also help...
    Also, try creating a mailbox wordpress@yourdomain.tld and check if emails are being sent after that.

  5. TheCasanove
    Member
    Posted 11 years ago #

    I just checked the logfiles for mail() there is nothing in there from the wordpress mu.
    Just from my other wordpress installtion:

    2009-09-14 08:36:27 u****** 4A**9u-1M**Ap3Jn3-0002MZ |< REMOTE=85.141.***.** SCRIPT=/blog/wp-comments-post.php -- /usr/sbin/sendmail -t -i

    These are being sent.

    this should be from the vbulletin forum where emails are also not sent:

    2009-09-20 08:59:18 u****** 4A**9u-1M**Ap3Jn3-0002MZ |< REMOTE=77.190.18.170 SCRIPT=/forum/admincp/diagnostic.php -- /usr/sbin/sendmail -t -i
    2009-09-20 08:59:18 u****** 4A**9u-1M**Ap3Jn3-0002MZ <= S=webmaster@mydomain.de SZ=1536 D=0 SID=207758171
    2009-09-20 08:59:18 u****** 4A**9u-1M**Ap3Jn3-0002MZ => myothernickname@gmail.com msmtp.kundenserver.de[172.19.**.*] 250 Message 0MKuxg-1MpGOE0uk6-00019F accepted by mreu0.kundenserver.de

    From what I see it looks like those are being sent but they never are received.

    There are no logs concerning wordpress mu. Just plain nothing. No error, nothing.

  6. VentureMaker
    Member
    Posted 11 years ago #

    Did you try creating a mailbox as I suggested above?

  7. TheCasanove
    Member
    Posted 11 years ago #

    Yes I have an emailaccount with pop/smtp support with the same tld.
    Like: support@websiteadresswpmu.de

    won't work as well. repsonds fine with in the testmail option but doesn't deliver any mail.

    the emailaccount itself works fine. it receives and sends mails when used with other software

  8. VentureMaker
    Member
    Posted 11 years ago #

    Another thing then. To what email accounts are all those emails not delivered?
    Did you try to signup with 'local' email address (something@yourdomain.com)? Are emails delivered to it?

About this Topic

  • Started 11 years ago by TheCasanove
  • Latest reply from VentureMaker