The MU forums have moved to WordPress.org

Server is overloaded or there was an error in a CGI script (6 posts)

  1. emaya77
    Member
    Posted 14 years ago #

    Hi All,

    I succesfully installed wordpress-mu in my machine.After that when i clikced on login button, I'm getting this error:

    "Server error!

    The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

    If you think this is a server error, please contact the webmaster. "

    I am NEW to this, so any detailed help would be so appreciated!!
    Thanks!
    ;o)

  2. emaya77
    Member
    Posted 14 years ago #

    Btw...when on the previous page (the page where you install wordpress
    mu), this warning is listed in the instructions:

    "Warning! It looks like mod_rewrite is not installed.

    If the mod_rewrite module is disabled ask your administrator to enable that module, or look at the Apache documentation or elsewhere for help setting it up."

    Also, should i leave the database host as: localhost? Or should it be "localhost.localdomain" which is what is in the field by default for the Server Address.

    And for the database, I've aned it 'wpmu', the username is "root", and I've left the pw field blank.

  3. SteveAtty
    Member
    Posted 14 years ago #

    You'll need to turn mod_rewrite on in your apache config for WPMU to work properly.

    leave the db host as localhost.

    DONT use root/{null} as your logon credentials, create a specific user which only has the required rights on the wpmu database.

  4. emaya77
    Member
    Posted 14 years ago #

    Thanks, SteveAtty!
    I apologize for being so clueless here...but:

    Is there a certain place in the apache config file that I should add "RewriteEngine On"? And do I need "#" or anything before it?

    As far as the login credentials, should I just make up ANY UN and PW? Do I then need to add this info anywhere else?

    Thanks again!

  5. SteveAtty
    Member
    Posted 14 years ago #

    You can use any username and password, you need to create it in mysql and then grant it the necessary permission on the database.

    I cant remember where to edit the main apache config to enable mod_rewrite, on my server. I'm using apache2 and I use a2enmode, a2ensite, etc to change my configuration.

  6. tim.moore
    Member
    Posted 14 years ago #

    Emaya,

    Assuming you are running Linux, in your apache installation, you should have two folders: one labeled mods_available and the other mods_enabled. You need to create a symbolic link in the mods_enabled folder to the rewrite.conf file in mods_available.

    Restart Apache after you do this and mod_rewrite should be enabled.

About this Topic

  • Started 14 years ago by emaya77
  • Latest reply from tim.moore