The MU forums have moved to WordPress.org

404 on new blogs (14 posts)

  1. darshi
    Member
    Posted 14 years ago #

    I had some problems installing wpmu but got it up and running. At first I was getting a 404 on everything except the main blog and admin. After changing permalinks to default I can now view posts to main blog, but any new blogs are still returning a 404.

    I dont have access to my httpd.conf as I am on a shared host, though my host has suggested they may edit the file, they asked me:

    What modifications are needed to be made to the httpd.conf? anything that can't be done in a .htaccess generally can't be implemented on our systems.

    So can someone tell me what edits need to be made to httpd.conf?

    Also my host assures me that

    The rewrite module is enabled on all of our servers

    Any help much appreciated

  2. tim.moore
    Member
    Posted 14 years ago #

    Which install type did you choose (subdomain or subdirectory)?

    If you chose subdomain, you need to set up a wildcard DNS entry as discussed in the readme.txt file.

  3. robinwilson2
    Member
    Posted 14 years ago #

    I am having a similar problem. I selected the "subdirectory" install.

    I can get to the administration pages, and the main page shows up - but if I click on any posts (including the default "Hello World" post) or create a new blog, or even 'View' a post from the edit page - I get a 404.

    Any ideas?

    (Please be gentle. I'm not only new to WordPress, I'm new to blogging in general. Jargon and assumptions that I know something will be met with confused stares and a blank look.)

    FYI, I've installed wpmu 2.8.4a on a Linux server running RHEL 5. I'm using PHP 5, and MySQL 5, and Apache 2. My DB server and apache/WordPress server are different boxes, and I cannot go to 'localhost' for any of this (I'm on my workstation, and the servers are in a locked room and only have terminal access). The install seems to work fine, and the DB is created properly (so far as I can tell). I did have the problem with the 'timezone' complaint, but a note elsewhere suggeste that I add "date_default_timezone_set('UTC');" to the 'wp-includes/functions.php' file, and that worked to clear up the issue.

    Everything "seems" to work correctly - except that I can't actually get to any posts, or create any new blogs.

  4. tim.moore
    Member
    Posted 14 years ago #

    Ok, in your Apache2 install, did you enable the mod_rewrite module?

    You can usually check /etc/apache2/mods-enabled, though this may be different under Red Hat.

    <tim>

  5. robinwilson2
    Member
    Posted 14 years ago #

    I have this line in my httpd.conf:

    LoadModule rewrite_module modules/mod_rewrite.so

    Is there something else I needed to do?

  6. tim.moore
    Member
    Posted 14 years ago #

    Here's a guide. If you've set everything up according to that and it still doesn't work, let us know.

  7. robinwilson2
    Member
    Posted 14 years ago #

    OK, I figured it out (the guide started me on a path to looking at my httpd.conf file - even though the guide was for Apache 1.3, and I'm on Apache 2.2).

    In case you case, it was this:

    AllowOverride FileInfo Options

    This was not in the "<Directory ...>" for my document root, and that's why it wasn't working properly. (It wasn't picking up the .htaccess file in my WordPress install. (I had the AllowOverride - just not in the right place...) This just goes to show - read _all_ the words, not just the ones I think are important.)

    Thanks for the help - not sure if that solved "darshi's" issue as well - but it might.

  8. darshi
    Member
    Posted 14 years ago #

    Hi Tim

    I have installed using subdirectory as I dont have unlimited subdomains.

    My host assures me that

    The rewrite module is enabled on all of our servers

    at one point I sent a bit of code to my host that was suggested as an edit to the httpd.conf

    <Directory />
     Options FollowSymLinks
     AllowOverride None
    </Directory>
    
    change to
    
    <Directory />
     Options FollowSymLinks
     # AllowOverride None
     AllowOverride FileInfo Options
    </Directory>

    but they responded saying

    That modification would not be necessary on our servers as allowoverrides none is not enabled, all overrides should be enabled for you

    As I dont have access to the httpd.conf and my (shared) host tells me they regard supplying me the with the current contents to be a security risk i'm unsure what to do next....

  9. andrea_r
    Moderator
    Posted 14 years ago #

    "if I click on any posts (including the default "Hello World" post) or create a new blog, or even 'View' a post from the edit page - I get a 404."

    Check and see if a .htaccess file is created in the root of the WPMU site. that's what does the URL rewriting for the posts & subdir blogs to show up.

  10. wm_bray
    Member
    Posted 14 years ago #

    Fun-Fact for Fedora users:

    In httpd.conf, AllowOverride None appears again after the <Directory /> declaration.

    My problems with 404 went away after I fixed this.

    I hope this helps somebody!

  11. darshi
    Member
    Posted 14 years ago #

    Hi Andrea_r
    my .htaccess is in public_html which is where wpmu is installed and reads:

    RewriteEngine On
    RewriteBase /
    
    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    wm_bray

    I guess that not applicable as my hosts tells me that allowoverrides none is not enabled?

    Thanks to you both for your posts, any other ideas?

  12. ckelpin
    Member
    Posted 14 years ago #

    I also have the same problem. I installed mump, the install seems to work well. DB is working, I can create new users and new blogs, can log in as the user, but cannot see pages of the blogs. Mod_rewrite is installed. This is a copy of the directory section of the httpd, can someone tell if this is good? (the blog.domain.com is false for secure reasons, our real domain site name is there on the server).
    <Directory "/">
    Options FollowSymLinks
    AllowOverride FileInfo Options
    </Directory>

    <Directory "/var/www/html">
    Options Indexes Includes FollowSymLinks
    AllowOverride None
    Allow from all
    Order allow,deny
    </Directory>

    <Directory "/var/www/icons">
    Options Indexes MultiViews

    AllowOverride None
    Allow from all
    Order allow,deny
    </Directory>

    <Directory "/var/www/cgi-bin">
    Options ExecCGI
    AllowOverride None
    Allow from all
    Order allow,deny
    </Directory>

    <Directory "/var/www/html/blog.domain.com">
    Options ExecCGI
    AllowOverride None
    Allow from all
    Order allow,deny
    </Directory>

  13. ckelpin
    Member
    Posted 14 years ago #

    my post above, its not mump, but wpmu :). its been a long day.

  14. tim.moore
    Member
    Posted 14 years ago #

    I see two issues:

    <Directory "/var/www/html/blog.domain.com">
    Options ExecCGI
    AllowOverride None <-- Change to AllowOverride FileInfo Options
    Allow from all
    Order allow,deny
    </Directory>

    and

    <Directory "/var/www/html">
    Options Indexes Includes FollowSymLinks
    AllowOverride None <-- Change to AllowOverride FileInfo Options
    Allow from all
    Order allow,deny
    </Directory>

    Having the AllowOverride set to None doesn't allow the .htaccess file to actually do its rewriting magick.

About this Topic

  • Started 14 years ago by darshi
  • Latest reply from tim.moore