The MU forums have moved to WordPress.org

having problems with wpmu-settings.php on line 167 (19 posts)

  1. RichonWordpressMU
    Member
    Posted 13 years ago #

    Hello, I am new to wordpress mu and am trying to install it on godaddy.com.

    This keeps coming up:

    "Warning: Cannot modify header information - headers already sent by (output started at /home/content/g/e/n/generate1/html/pettelle/wp-includes/functions.php:3415) in /home/content/g/e/n/generate1/html/pettelle/wpmu-settings.php on line 167
    "
    I have searched the internet and tried everything. please help me.

    Thanks

  2. SteveAtty
    Member
    Posted 13 years ago #

    You have a blank line after the closing ?> at the bottom of one of those files somehow. Did you manually edit one of them?

  3. RichonWordpressMU
    Member
    Posted 13 years ago #

    no, I downloaded the wordpress mu, and then uploaded it using filezilla

  4. RichonWordpressMU
    Member
    Posted 13 years ago #

    I cannot figure out, how to solve "wp-includes/functions.php:3415)"

    Likewise, I added a ?> at the end of on line 167, and made sure there were no blank spaces...

    nothing happened. I still get the same message.

  5. SteveAtty
    Member
    Posted 13 years ago #

    Remove what you put on line 167.

    Its not blank spaces its blank lines, i.e if you can cursor beyond the closing ?> at the bottom of the file you've got a problem

  6. SteveAtty
    Member
    Posted 13 years ago #

    And quite why the header line is blowing up on you I do not know.

  7. RichonWordpressMU
    Member
    Posted 13 years ago #

    would it be possible for you to IM me on AIM? (or call me, on the phone?)

    I do not understand the problem because I downloaded the wordpress mu from this site!

  8. RichonWordpressMU
    Member
    Posted 13 years ago #

    it seems that one problem is solved, but now i get receive this:

    "?>?> ?>
    Parse error: syntax error, unexpected $end in /home/content/g/e/n/generate1/html/pettelle/wpmu-settings.php on line 247"

    thank you VERY much for your help!

  9. SteveAtty
    Member
    Posted 13 years ago #

    reload wpmu-settings.php from your download and check that all files have the right permissions.

  10. andrea_r
    Moderator
    Posted 13 years ago #

    And have you asked godaddy support for any help?

  11. RichonWordpressMU
    Member
    Posted 13 years ago #

    yes, they said that they do NOT help with installations. All they work with is the "hosting."

    I am setting up the wordpress mu to set up the buddypress...

  12. tim.moore
    Member
    Posted 13 years ago #

    You should check Filezilla. It may be inadvertently changing your line endings in files.

    You can either change Filezilla so that it always uploads/downloads in ASCII/Binary mode or use a different FTP program.

    <tim>

  13. RichonWordpressMU
    Member
    Posted 13 years ago #

    tim, how would I know?

    ~Rich

  14. tim.moore
    Member
    Posted 13 years ago #

    You'd need to start the install over. Delete the WordPress files from the server, delete the database. Make sure that Filezilla is set up as I mentioned above, reupload the files, then visit the URL you set to start the installation.

  15. RichonWordpressMU
    Member
    Posted 13 years ago #

    hey, I just checked the filezilla, it was on auto.

  16. RichonWordpressMU
    Member
    Posted 13 years ago #

    hey tim, I changed the auto to a ASCII. That helped! I was able to get to the wordpress mu screen :). However, I called godaddy.com to get my information about the database name, user name, password, and database.

    Now this comes up: "Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!"

    Suggestions? Anyone?

    ~Rich

  17. RichonWordpressMU
    Member
    Posted 13 years ago #

    I reinstalled config-sample, and it is back the wordpress mu form.

  18. RichonWordpressMU
    Member
    Posted 13 years ago #

    tim, is there anyway we could talk on IM, or you could call me? (or, i could call you) you helped me more than godaddy!

  19. RichonWordpressMU
    Member
    Posted 12 years ago #

    hey everyone, I got it to work (knock wood)! thanks to YOUR advice! I own a buddypress site, and I own an online website. If any of you would like some consulting work, please write back... if not, then MANY thanks!

    ~rich

About this Topic

  • Started 13 years ago by RichonWordpressMU
  • Latest reply from RichonWordpressMU