The MU forums have moved to WordPress.org

Auto Activate Theme on New Blog (8 posts)

  1. derekd
    Member
    Posted 14 years ago #

    How do I get WordPress MU to automatically activate theme on new blog? I want to use the same theme on all blogs. For some reason it is not activating it on new blogs though. So when you go to new blog there is just blank screen (it is the only theme I have enabled in Site Admin >>> Themes). I can log into /wp-admin section of new blog and go to Themes and activate it and it works fine.
    How do I get it to automaically activate? Any help would be great!

    Thanks!
    Derek

  2. andrea_r
    Moderator
    Posted 14 years ago #

    By default, it looks for the theme in the /default/ folder. Thus, the blank screen.

    To get it to do this (and more), use this plugin:
    http://wpmudevorg.wordpress.com/project/new-blog-defaults

  3. derekd
    Member
    Posted 14 years ago #

    Thank you Andrea!
    Two quick questions : )

    1. Where is the /default/ suppose to be located? I looked around and I am not seeing it. I am wondering I just add it with my theme within if it will fix this issue.

    2. I tried downloading the pluggin from
    http://wpmudevorg.wordpress.com/project/New-Blog-Defaults and I don't think I am getting a good download. It is just a single file with no extension. Is this correct?

    Thanks!

  4. derekd
    Member
    Posted 14 years ago #

    UPDATE: I actually got it : )

    I read your post at http://wpmututorials.com/hacks/changing-the-default-theme/

    I just changed theme name to "default" since the default folder was missing. This fixed it! Now new blogs automatically have this theme!

    I would still like to know more about the New Blog Defaults plugin if anyone has a link for a good download.

    Thanks!!

  5. andrea_r
    Moderator
    Posted 14 years ago #

    - that is the correct download, and yes, it's only one file. it goes in mu-plugins folder and the menu for it shows up under the Site Admin menu.

  6. DeannaS
    Member
    Posted 14 years ago #

    The download should be a zip file that contains a folder with 2 files - a readme.txt and the actual file that does the work (cets_blog_defaults.php). You just put the php file in your mu-plugins directory. I just tried the download and it worked for me....

  7. dalara
    Member
    Posted 14 years ago #

    THIS doesnt work, only download the .txt see it... really check this, some ppl need work with this...

  8. DeannaS
    Member
    Posted 14 years ago #

    Did you read the installation information?

    The code has been moved to wordpress.org.

    http://wordpress.org/extend/plugins/wpmu-new-blog-defaults/

About this Topic