The MU forums have moved to WordPress.org

user activation email (61 posts)

  1. EJBogusch
    Member
    Posted 16 years ago #

    Activebiz I see you got your email notification working for off server email addys. Since I have the exact problem as you stated could you share your solution? Thanks!

  2. Sy4
    Member
    Posted 16 years ago #

    EJ,

    Check that SENDMAIL is turned on in your server.
    Aslo, goto phpmyadmin and remove the mailserver information in wpoptions table.

    It stores url/user/pass

    worked for me...

  3. drnopl
    Member
    Posted 16 years ago #

    Ok, i also cant get any email from WPMU after installation with my pass and login, and no activation mail, cant get any mail ...
    I've modified via phpMyAdmin these settings, dosent work.
    Other scripts propertly sends mail (LifeType, CMS, Forums and others ..)

  4. Delbert
    Member
    Posted 16 years ago #

    I have this issue on occasion - new users don't get their email and it's a real PITA. Thankfully, it hasn't happened lately and it seems to me to be a mailserver (I use qmail) issue. Now, I'm no mailserver guru so not knowing how I fixed what suddenly starts working makes me cross.
    Things I check:
    mailserver queue. Sometimes this gets too long (WHY? God only knows) and needs clearing out. Things start working then. It might be caused by the following.
    The "domains you're allowed to send to" function in Plesk does my head in. OK, I realise it's to stop naughty people using me as a relay but I think it causes problems with qmail. This might be an issue with cpanel, I don't know. At the moment it seems to be behaving.

    Hoping that helps. If I find out a definitive answer to why my setup works when it feels like it I'll let you know.

  5. Pixelate01
    Member
    Posted 16 years ago #

    Just installed wordpress MU and having same problem. I'm unable to get registration confirmation emails.

    I noticed that when I was logged in as the Admin and registered a new blog the email was sent out.

    Wondering what the configuration is supposed to be for: "mailserver_url", "mailserver_login", "mailserver_pass", "mailserver_port" ??

  6. Farms2
    Member
    Posted 16 years ago #

    I have exactly the same problem with new installs of WPMU 1.0 regardless of whether they're upgrades or fresh installs.

    No email to admin when a new blog is created :(

  7. amoldalvi
    Member
    Posted 15 years ago #

    I have the same problem. I still don't know how to get that email; I am checking with host (bluehost.com) to see if they can give me error logs.

    In the meantime, I activated the blog by going to:
    http://<yourblogdomain>/wp-activate.php?key=<from db>

    You can find the key in this table: wp_signups

  8. amoldalvi
    Member
    Posted 15 years ago #

    Also, my understanding is that "mailserver_url", "mailserver_login", "mailserver_pass", "mailserver_port" settings are if you want to accept blog postings via email. It has nothing to do with sending out emails for newly created blogs.

  9. nims
    Member
    Posted 15 years ago #

    I installed WPMU few days back for the first time though I am using WP on my other websites hosted on the same server. I selected subdirectory structure.

    When I tested WPMU by trying to create a new blog even I didnt get any activation email. I tried several times with different emails but it does'nt work. Is there any solution to it ?

  10. nims
    Member
    Posted 15 years ago #

    Hey I figured out the problem and I think admin/moderators/developers of MU must look into this.

    While installation I used my gmail email id and whenever I tried to create a new blog to test MU I was using another email id on gmail itself so no email was triggered. So basically whosoever with gmail account wont get an email in this case.

    I went to admin >> site admin >> options and changed the Site Admin Email: from my gmail to support@mywebsite.com and Wooooooooo !!! everything is working fine now !!

    I hope it would be helpfull for others and developers/coders can rectify this issue ;-)

  11. nolageek
    Member
    Posted 15 years ago #

    I'm having this same problem. WPMU doesn't send any e-mails out to new users when they sign up. Doesn't send it to the new user if I create the blog in Site Admin. The only mail I seem to get is to a mail address that's local to the domain. (support@domainname.com)

    Any ideas?

  12. nims
    Member
    Posted 15 years ago #

    Go to admin >> site admin >> options and change the Site Admin Email: to support@yourdomain.com
    Change yourdomain.com to your actual domain name where the blog is running.

  13. drmike
    Member
    Posted 15 years ago #

    When you checked your email logs, what did you see in there?

  14. bethallen
    Member
    Posted 15 years ago #

    Hi, I know this is an old thread. But, I ran into this exact same problem with wordpress MU, an new installation on Hostmonster. When I inspected the error logs, after a few attempts at creating new users and new blogs, I found an error message indicating it was trying to send mail from the user "wordpress@mydomain.com" (replace mydomain.com with the actual domain). It said there was no user with that name.

    So, I created an email: wordpress@mydomain.com, and now my user notification emails are going out. Hope this helps some of you. I know I was pulling my hair out over it.

  15. wengkies
    Member
    Posted 14 years ago #

    so has anybody found the solution to this problem? Yester day i tried to install the wpmu, installation was fast no error at all but cannot create users or blog becuase the registration confirmation did not arrive at users mailbox..

    any solutions people? appreciate it...

  16. tdjcbe
    Member
    Posted 14 years ago #

    Copied from above:

    When you checked your email logs, what did you see in there?

    Also:

    http://codex.wordpress.org/Debugging_WPMU

  17. andrea_r
    Moderator
    Posted 14 years ago #

    "but cannot create users or blog becuase the registration confirmation did not arrive at users mailbox.."

    If you create a user/blog from the admin area, what happens? Should still be there even if they don't get the email (which usually winds up in the spam folder).

  18. wengkies
    Member
    Posted 14 years ago #

    hi andrea_r I did try to create from the admin area but same thing.. for some reason no email confirmation, I did check the spam folder and nada, but anyway i will try to test and reinstall until i figured out the problme..

    the gud news is if you fresh install the wpmu it will send you your admin login and password.. but if you try o create users and blogs no email confirmation.. but anyway we'll try to solve it...

  19. tdjcbe
    Member
    Posted 14 years ago #

    I did check the spam folder

    Why not check the mail logs to see what happened with the email...

  20. dgilmour
    Member
    Posted 14 years ago #

    @wengkies: You haven't answered andrea_r's question.

    If you create a user/blog from the admin area, what happens? Should still be there even if they don't get the email ...

    Was the blog created? You should be able to see it in Site Admin / Blogs list. If it's there, does it work? Can you use Backend, for example?

  21. wengkies
    Member
    Posted 14 years ago #

    hi dgilmour

    yes i can create blogs and users from admin area and I can see them but still theres no email confirmation so I can't login, i tried to view from the admin panel [backend] if the blog works but no luck

    I got this error logs

    <i>[10-Apr-2008 10:31:19] install_blog - ID: 1 URL: http://mytestsite.com/v1/ Title: My new WordPress MU Site
    [10-Apr-2008 10:31:20] WordPress database error: [Unknown column 'blog_public' in 'field list']
    UPDATE wp_blogs SET blog_public = '1', last_updated = NOW() WHERE blog_id = '1'</i>

  22. punterbrewer
    Member
    Posted 14 years ago #

    I too am having this issue. I am able to send mail from this same server outside of WordPress via a php optin script. When I register, the user is created as evident by phpmyadmin and WordPress->Users. I can change the password via WordPress and then log in so it looks like just the mail is not working. I also tried a smtp mail plugin for WordPress that did not help at all. What else can I try?

  23. jeffwong
    Member
    Posted 14 years ago #

    I got the same problem last time
    But I just use smtp mail plugin to escape it
    Now I can receive the notify email as well

    Do you make a test after activate smtp mail 'Send a Test Email'?

    I thought most of email server had a strong spam email filter
    If you just use php option script to send notify message, then spam filter will consider it as a spam, because it send from your server IP address.

    When you use smtp mail then all notify message will send by your email server.

    You may need to select 'Yes: Use SMTP authentication' in smtp mail setting

  24. punterbrewer
    Member
    Posted 14 years ago #

    I finally got it to work. Apparently my WordPress version was old or buggy. I upgraded to 2.5.1 and reinstalled the WP Mail SMTP plugin (which did not work previously) and now email works fine. Thanks for the suggestions.

  25. wengkies
    Member
    Posted 14 years ago #

    hi everyone.. I downloaded the 1.5rc1 and activation email works.. i don't know if this toturialwill help you... i got it from my free host and i don't know if this issue has something to do with email activation.. i will post it anyway hoping to help someone..

    We use virtual user home directory paths so you can get error when trying to setup search engine friendly URLs or trying to pass virtual directories it to php scripts.
    If can be fixed very easy. Edit your .htaccess file and add slash "/" before path to your index.php or any other file which rewrites virtual directory name into variable.
    For example if your rewrite rule looks like this:
    RewriteRule ^(.*)\.html$ index.php?page=$1
    modify it and add slash "/" symbol before "index.php" so it looks like:
    RewriteRule ^(.*)\.html$ /index.php?page=$1

    my 3 questions are how come i can't edit the .htaccess file in 1.5rc1? access denied all the time i tried to edit the file...

    is this part of the security for wpmu 1.5?

    and if part of security issue how to disable it so that i can have access and edit the .htaccess file?

  26. andrea_r
    Moderator
    Posted 14 years ago #

    Uh, no. Being able to edit a file on your server has nothing to do with MU and everything to do with your host.

  27. m1gu3
    Member
    Posted 14 years ago #

    I have the same problem, looks like when I create a sample user thru the admin they do receive the mail but when the user registers by it self it doesn't work. Any suggestions? already changed the admin mail and restarted the qmail emailing service.

    Thnx in advance for the help.

  28. joshirules
    Member
    Posted 14 years ago #

    I just signed up the wordpress.com account

    my username is joshirules

    and that account exist with my email but didn't receive a activation site to my email and i can't go any further. please help

  29. andrea_r
    Moderator
    Posted 14 years ago #

    You are way in the wrong forum. See the address bar? It doesn't say wordpress.COM.

  30. thebushman
    Member
    Posted 13 years ago #

    Does anyone have an answer to the no receiving the activation e-mail. There really isn't a solid answer here.

About this Topic

  • Started 16 years ago by activebiz
  • Latest reply from andrea_r