The MU forums have moved to

Wrong URL of my Media uploads. (41 posts)

  1. blogsterfiles
    Posted 13 years ago #

    Wordpress mu is great but I am abandoning it on the vps server listed above simply because there is no help available to support wpmu. It seems that it either works for you or it doesn't. I am going to move the domain to a shared server, and in the mean time, use my vps to educate myself, and let my IT guy use it for a sandbox to get himself up to speed... a trade off that benefits us both in exchange for getting his help and advice. Thanks to everyone for your patience and what help you were able to offer. If I solve this problem, I will report my findings back here. :)

  2. tmoorewp
    Posted 13 years ago #

    There's plenty of help available, not just these forums. The majority of us here are giving our time freely to try and help.

    You can look at various WordPress related job boards and (the company that puts out WordPress). They have paid support options that can help as well.

  3. blogsterfiles
    Posted 13 years ago #

    Thanks Tim... I'll check there. Your help is appreciated, and I realize the biggest part of the problem, at least in my case, is my own deficit in knowledge. Which is why I'm backing off on the vps install until I can get myself up to speed. It looks to me like the biggest problem here is the overwhelming success of wpmu. It has attracted a bunch of novices like me, who see the power and value in it, but don't have a clue how to deploy.

    Did you see the comment I left about commenting the line out in .htaccess? The files suddenly show up in the browser if you do that. This is part of the reason I'm moving my users off of that server, so if I trash it digging around, I'll just have to restore the server and won't have any customers mad at me. Also, I won't be under so much pressure to find answers.

  4. andrea_r
    Posted 13 years ago #

    "It has attracted a bunch of novices like me, who see the power and value in it, but don't have a clue how to deploy."

    Exactly. :) It's a lot to run, and more than "just" a stand-alone blog.

  5. gulflee
    Posted 13 years ago #

    now another problem comes,
    the upload works perfect, but when i try to create link at Facebook the thumbnail selection shows when attach is clicked, all images show for select but when its share is show no thumbnail ?? is that some thing to do with the redirection of htaccess ??

    thank you for the aid

  6. drogomoss
    Posted 13 years ago #

    My good ness... I have not solved it yet. Although I doubt if anybody is going to hack my WPMU, I still want it too work. I have now recreated the error in a separate Linux server and will be debugging it from there. I still think it is with the .htaccess

    I'll be moving the wp-content where it should be and hopefully it would work. This just means that I still do not understand the code for .htaccess.

    Still this issue should be solved. I already have a couple of people signing of for a blog and sending me an email why they can't see their uploaded pics. AHHH!!!

    @gulflee: 90% tells me your posts do not have any Meta Tags. Shares like this usually make use of meta tags. Install an SEO plugin e.g. "All In One SEO Pack". This should solve your problem without the hassle. :-)

  7. gazouteast
    Posted 13 years ago #

    Quote drogomoss earlier in the thread

    (x) =
    (y) = /home/kabaliw1/public_html/blogcamp/contented/wp-content/blogs.dir/2/files/2009/10/testimage_file.JPG
    (z) = (x) + (y) =

    I'm having a near identical problem but without your (z) issue

    Chasing down from a scattergun direction - I noticed in cPanel that image files with the "JPG" extension (i.e. capitalised) are returned as text files by cPanel's file manager, whereas "jpg" (lowercase) extensions are returned as image files.

    I doubt this has any effect on our shared issue, but just thought I'd toss it on the fire in case it does.


  8. webgdawg
    Posted 13 years ago #

    I had similar issues, file system path being inserted into the link path.

    I solved this by using a filter like so:

    add_filter('wp_get_attachment_url', 'nsir_wp_get_attachment_url');
    function nsir_wp_get_attachment_url($url) {
    	return preg_replace("/http:\/\/.*\.yourdomain\.com\/UPLOADBLOGSDIR\/(.*)?(\/files)/", "$2", $url, 1);

    While looking into this I discovered a couple of things:
    1 - If upload_path option is absolute it will not append ABSPATH
    2 - If you move/rename you WP-CONTENT dir you need to define UPLOADBLOGSDIR
    3 - blogs.php in your content directory is build to serve all uploaded files
    4 - For non-image uploads (ie pdfs) if http://... is in the href it will mark it with a rel="attachment wp-att-[id]" and replace it with a link to the attachment post instead of the file url.

    So in the above example it would not only remove the unwanted file path, but also the http://... making it a relative url.

  9. bartatwpmu
    Posted 13 years ago #

    Maybe these helps:
    I have had the same problem. Upgraded wordpress-mu and sudden all images (and blogs) are not visible anymore because ?wrong links? but still on the server. Search for days forums and internet, nothing!

    The thing i have noticed is that after wordpress-mu upgrade the .htaccess file in the wordpress directory whas gone. And the .htaccess file in the "root" (public_html) whas sudden empty!?

    bug or not ??? i don't know

    What i have done to fix these:
    1 copied a new "test" wordpress-mu in the same "root" (public_html)
    2 In the wp-config-sample.php file at the line $table_prefix = 'wp_';" i have changed 'wp_' in 'wp_test_' to not have problems with the tables already in the database from the original installation.
    3 then i have followed the normal wordpress-mu installation instructions at
    4 in ftp programme: show invisible files
    5 copied the .htaccess file from my "test" wordpress-mu directory in my "original" wordpress-mu directory
    6 opened these .htaccess from in my "original" directory in a texteditor and changed the line:
    RewriteBase /test/
    RewriteBase / (here name from the "original" directory) /
    7 And now everything is working nice and smooth :)

    ! make back-up of your "original" wordpress-mu and database !

    sorry for weird english

    hope these helps

  10. jittopjose
    Posted 13 years ago #

    Me too have the same problem.. The Image uploads well.. its in the directory.. but when i try to access it by giving its path, then its redirected to error page. Any body have a clear solution for this?.. I think all the requests except to wp-content is redirect to error page...
    Is there any way to change the default upload directory to wp-content direcory.. I am using buddypress also... so i need to be done in both places...
    I read all the posts in this thread.. many people have the same problem... but its still unanswered.... Please share if anybody have any idea about this problem...
    Jitto P.Jose

  11. omgitsrfb
    Posted 13 years ago #

    I followed @gulflee's suggestion and simply renamed .htaccess_dist to .htaccess and it works now!!!!

About this Topic

  • Started 13 years ago by drogomoss
  • Latest reply from omgitsrfb