The MU forums have moved to WordPress.org

404 error on blogs (12 posts)

  1. tavi_10
    Member
    Posted 14 years ago #

    Versions 2.8.4
    OS: CentaurOS 5
    Management: Plesk

    I just moved my site to a VPS with plesk on it from shared hosting and i am getting 404 error when accessing the blogs. Main blog posts and articles are showing up right but not the blogs.

    I edited the vhost.conf for the domain to

    <Directory>
    AllowOverride FileInfo Options
            </Directory>

    but no luck. Any ideeas please?

  2. tim.moore
    Member
    Posted 14 years ago #

    Did you do a fresh install or did you backup your database and transfer it?

  3. tavi_10
    Member
    Posted 14 years ago #

    Backup and transfer.

  4. tim.moore
    Member
    Posted 14 years ago #

    Ok, a few things to try:

    1. Is mod_rewrite active? You've set up the AllowOverride, but does Apache have mod_rewrite enabled?

    2. Is the domain name the same when you backed up and transferred? If not, you'll have to manually change this in the database.

    3. If you are using subdomains, did you set up wildcard DNS entries in your new VPS?

  5. tavi_10
    Member
    Posted 14 years ago #

    Thank you very much for your time.

    1) The main blog posts are with permalink and they work pretty ok (like http://astrologikon.com/blog/blog/2009/04/14/cum-se-scrie-un-articol-in-wordpress/ ).

    http://astrologikon.com/blog/ is the main blog page and you can see from there the problem.

    In the apache configuration file, the rewrite module is loaded (i checked for this)

    2) Yes, it's the same domain name as on the previous server.

    3) I am not using subdomains, but the funny thing is that the subdomains don't get redirected to the main page as they did on the previous server. On the other hand, as the main blog pages work, the .htaccess file must be operational.

  6. andrea_r
    Moderator
    Posted 14 years ago #

    make sure you copied over the .htaccess file from the old site to the new one. It's a hidden file and often gets missed.

    If you're sure it's there, read it. Compare it to the old site. make sure it's *all* there.

  7. tavi_10
    Member
    Posted 14 years ago #

    it seems to be all there...

    RewriteEngine On
    RewriteBase /blog/
    
    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Maybe something else?

  8. tavi_10
    Member
    Posted 14 years ago #

    I've managed to redirect all subdomains to the main site, it was a dns issue, the only thing left is the blog problem...

  9. andrea_r
    Moderator
    Posted 14 years ago #

    on subdomain installs, MU puts a /blog/ in the permalinks off the main blog. This is to avoid collisions, basically.

  10. tavi_10
    Member
    Posted 14 years ago #

    This is not a subdomain install...

  11. andrea_r
    Moderator
    Posted 14 years ago #

    Doh, mistyped. I meant subfolder installs.

  12. tavi_10
    Member
    Posted 14 years ago #

    Figured it out... Changed in the config the vhosts options and set it to yes... I realised this when i tried to create a new blog. Sorry for wasting your time for my mistake.

About this Topic