The MU forums have moved to WordPress.org

Blog page cannot be found (15 posts)

  1. Stef78
    Member
    Posted 14 years ago #

    Hi,

    The troubles aren't quite over.
    When I make a new post, I can't get to the page of that post.
    It gives a 404 error
    http://www.managementplatform.nl

    If I make the plugin Buddypress active.
    it gives this error.
    Fatal error: Call to undefined function bp_page_title() in /home/stefnitert/domains/managementplatform.nl/public_html/wp-content/themes/bp-sn-parent/header.php on line 9

    Somethings' gone quite wrong.. isn't it?

    thanks for helping.

  2. andrea_r
    Moderator
    Posted 14 years ago #

    Yes. :)

    Your server either does not have mod-rewrite enabled, or if it does, then Apache is not reading the htaccess file.

    you have to fix that before activating things like BP.

  3. Stef78
    Member
    Posted 14 years ago #

    I do have mod-rewrite enabled.. that shown in the .htaccess file.. right?

    This is the content of the .htaccess file

    RewriteEngine On
    RewriteBase /
    
    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    I'm pretty much out of options.
    Do you know some way out of this?

    Thank you.

  4. SteveAtty
    Member
    Posted 14 years ago #

    mod_rewrite has to be enabled in your apache configuration and then you've got to set the Options in the directives for your site to allow the .htaccess file to enable it

  5. Stef78
    Member
    Posted 14 years ago #

    From my hosting provider I got the following mail.

    ----
    mod_rewrite is standard enabled on our servers and .htaccess is also standard enabled.
    ----

    Are there some other suggestions?
    I really appreciate your help Steve and Andrea. Thanks already .

  6. tmoorewp
    Member
    Posted 14 years ago #

    Check the permissions on the .htaccess file. Usually should be 0755. It could be that everything is enabled for mod_rewrite, but Apache can't find the .htaccess because it isn't readable by the server.

  7. Stef78
    Member
    Posted 14 years ago #

    They stood on 644.. but changing it to 755 didn't help.
    I do have 2 htaccess files but deleting one of them doesn't help either.

    http://img.skitch.com/20091022-fts8qnnq4dd3jsmj5sf3e2xj7m.preview.jpg

    I did had a lot of trouble installing wordpress mu. Maybe something still isn't right. And I probably end up by doing a clean install again. I still hope there are some options left.

    Thanks for your reply though.

  8. tmoorewp
    Member
    Posted 14 years ago #

    .htaccess if the file WPMU creates...that is the one that should remain in the directory.

    I notice you have a "config.php" file. Is that something you created?

    Also, if you could post a screen cap of all the files in your root directory, that might help.

  9. Stef78
    Member
    Posted 14 years ago #

    the screenshot:
    http://img.skitch.com/20091022-mqy7anwq63b89ya786dh4gnspt.jpg

    about the config.php file.. I think I did not create that. But I'm not sure anymore. I had a lot of trouble installing MU.
    Here you can read the help I got on the forum.
    http://mu.wordpress.org/forums/topic/15035?replies=8

    I deleted an config.php file and that did the trick to install everything.
    But it apparently wasn't enough.

    Hope you have some good advice.

  10. tmoorewp
    Member
    Posted 14 years ago #

    Ok, it appears your problem is that you have /blog/ in the permalinks. Go to Settings -> Permalinks and select the Default option. Save it, then try your blog out.

  11. Stef78
    Member
    Posted 14 years ago #

    that's it!!

    Thank you!

  12. Stef78
    Member
    Posted 14 years ago #

    ..and I'm back again..
    Catchable fatal error: Object of class WP_Error could not be converted to string in /home/stefnitert/domains/managementplatform.nl/public_html/wp-includes/wpmu-functions.php on line 107

    I've uploaded a new theme.. and there it goes.
    Does anybody knows how to solve this?

  13. Stef78
    Member
    Posted 14 years ago #

    This is the line in wpmu-functions.php on line 107

    $blog_id = wp_cache_get( "get_id_from_blogname_" . $name, 'blog-details' );

    But I don't know what to do here.

  14. tmoorewp
    Member
    Posted 14 years ago #

    Could be a plugin issue. I'm seeing a lot of different support requests for this.

    Try disabling all of your plugins, then reenable them until the error occurs again.

    If that doesn't work, try switching themes. If that fixes it, there's something wrong with the theme.

  15. Stef78
    Member
    Posted 14 years ago #

    I got it working..
    http://mu.wordpress.org/forums/topic/13798?replies=4#post-86721

    I found this post and this solution worked for me. I had to rename something in the database.

    thanks for your time anyway. Much appreciated.

About this Topic