The MU forums have moved to WordPress.org

That blog does not exist. Please try... (14 posts)

  1. witakr
    Member
    Posted 20 years ago #

    Hey, I did as the readme.txt > installation section said and I even went through the installation steps but now after wpmu told me it was installed and i try to goto the blog to admin it gives me this error:

    " That blog does not exist. Please try *******.*****.***/******/wpmu/ "

    *replacing the asterisks with my actual web URL

    What should I do?

    A couple things to know:
    Its WordPress MU running on a linux/apache server with php 4.4.2 and mysql 4.1.19-standard

    thanks for you help

    -witakr

  2. witakr
    Member
    Posted 20 years ago #

    I am trying a reinstall to see if that changes anything.. I will reply with an undate in about 15 min

    -witakr

  3. witakr
    Member
    Posted 20 years ago #

    For the love of God I think I may have gotten it right... OK reinstalling it twice and creating the DBs prior to install fixed it.... :-/

    -witakr

  4. drmike
    Member
    Posted 20 years ago #

    Sound's also like you may not using the latest version because there's been a link in there for quite sometime to a report form for information that we need to help you. :)

    Double check to see if you're using the latest Nightly version.

    Right now it's r674 but it updates nearly every night.

  5. FelixDing
    Member
    Posted 20 years ago #

    I HAVE grabbed the lastest offical/nightly version and installed this shit twice, but still got this error. what the fuck!

  6. drmike
    Member
    Posted 20 years ago #

    But yet you don't follow the link that it gives you nor tell us anything about your setup as per the link asks you to.

    So how are we suppose to help you?

  7. donncha
    Key Master
    Posted 20 years ago #

    witakr - I see that you have installed WPMU in a sub directory of a directory. Unfortunately this hasn't been supported up to now. If you update from SVN, or just merge the changes from revision 709 it should work, with one cavaet. You can only have one wpmu site defined in wp_site. That's probably the case for 99% of people so we're saving a few cycles here!

    http://trac.mu.wordpress.org/changeset/709

  8. sivac
    Member
    Posted 20 years ago #

    hi i have installed multiuser wordpress blog in my server ,after installation i got message like this
    "That blog does not exist. Please try http://mysite.com/~test/blogs/" i had the latest version of the blog can u please help me to solve this problem

  9. drmike
    Member
    Posted 20 years ago #

    - Please don't double post.

    - Please read the thread you post in.

    Also the error you get says a lot more, including a suggestion of what to do with a link.

  10. sivac
    Member
    Posted 20 years ago #

    sorry for double the post ,

    in my server the folder of blog does exists ,i try the link "http://mysite.com/~test/blogs/" which comes with the message but no change

    i think there is no error database connection
    pls help as fast as you can

  11. sivac
    Member
    Posted 20 years ago #

    hi dr mike,

    i just solved the problem

    in the file wpmu-settings
    i comment the line "$path = substr( $_SERVER[ 'REQUEST_URI' ], 0, 1 + strpos( $_SERVER[ 'REQUEST_URI' ], '/', 1 ) );"

    because i think this condition is not valid corresponding to the url - "http://mysite.com/~test/blogs/"

    i am not aware anything more about it,so please inform if anything wrong by making it comment

  12. selven
    Member
    Posted 19 years ago #

    hmm the method sivac says doesn't work for me..
    Anywayz, i wish to describe more the problem.

    >My wpmu installation was around <=june
    had to lock it out sincei was away for quite some times.. i did used to upgrade before without problems.. but i guess there are lot of changes now.. (good job btw guys).

    >upgraded (did whatever was said in the README file which pointed me to http://trac.mu.wordpress.org/wiki/UpgradingWpmu
    andi followed instruction for upgrade of pre RC1)

    >Anywayz, everything went on fine, i used the upgrade script etc.. (site admin>upgrade)
    it showed all blogs of my users being updated.
    Everything went on fine.

    >I tried to do a list users and list blogs
    Nothing appeared.. i mean results was no users (except admin) and no blogs (except the admin blog)

    >I tried using the forget password option (just to see if it works), it does work.

    >Though when i try any link of my user's blog.. i get the error:

    That blog does not exist. Please try http://mysite.com/b4e/

    >more info
    I've installed wpmu on
    /htdocs/b4e/

    below is a copy of my /htdocs/b4e/.htaccess
    -----.htaccess-------------------------------
    RewriteEngine On
    RewriteBase /b4e/

    # Rewrite http://www.domain.com to domain.com
    #RewriteCond %{HTTP_HOST} ^www\.(.*)
    #RewriteRule ^(.*) http://%1/$1 [R,L]
    RewriteCond %{HTTP_http://www.mysite.com/b4e} ^www\.(.*)
    RewriteRule ^(.*) http://%1/$1 [R,L]

    #RewriteRule ^$ /b4e/index.php [L]
    ##############################

    #uploaded files
    RewriteRule ^(.*)?/?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    RewriteRule ^([_0-9a-zA-Z-]+)/ /b4e/index.php [L]
    -----------------------------------------------

    I tried searching for users in the users>Users & authors section of the admin panel, i got this error:

    Warning: Invalid argument supplied for foreach() in /htdocs/b4e/wp-admin/users.php on line 372

    +selven

  13. selven
    Member
    Posted 19 years ago #

    Ok i managed to bypass the error, i just made a clean install (on another database), I recreated the wp-config.php file and the .htaccess,

    Finally, (removed blogs.dir) & i copied from the old wpmu installation the
    old_wpmu/wp-content/blogs.dir
    to the
    new_wpmu/wp-content/blogs.dir

    finally, i just modified the wp-config.php for the settings of my REAL database of the old wpmu installation..
    and voila.. everything was back to normal .. it was soo simple yet i didn't think about it earlier.
    cheers

    +Selven

  14. selven
    Member
    Posted 19 years ago #

    btw.. well done wpmu team.

About this Topic