The MU forums have moved to

Automatic Upgrade bug? Install is looking for (4 posts)

  1. flicht
    Posted 14 years ago #

    Upgrade Automatically is failing because it can't copy files. But I think I spotted a bug?

    The message I get from Automatic Upgrade is:

    Could not copy file: /var/www/wpmu/wp-content/upgrade/wordpress-mu-

    Note that it's looking in .../wordpress-mu- However, if I watch the upgrade folder during install, the directory it creates is wordpress-mu- (there is no 1 at the end). does not exist so naturally it can't find it. Seems that this is bug, as it should be looking in Any suggestions on how to get past this problem?

    Sorry if I'm missing something obvious here. I'm a bit of newbie with WP, and this is my first attempt at an upgrade.

  2. flicht
    Posted 14 years ago #


    I just tried again and now it seems that automatic upgrade is now creating a wordpress-mu- directory in the ...upgrade/ directory.

    For some reason, this has changed from the wordpress-mu- directory it was creating a few hours ago. (I know I'm not crazy because I still have that output in putty session showing wordpress-mu-

    Unfortunately, I am still getting the exact same error: could not copy file .../older.js. Does anyone have any ideas why? What should I do next to get past this?

  3. tmoorewp
    Posted 14 years ago #

    You should download the zip file directly to your computer, unzip it and FTP it to your site, as you did when you first installed.

    The automatic upgrade is still quirky and is very dependent on your server being set up just right (which isn't the case most of the time).

    Try manually upgrading and see if that helps. Backup your files and database first (you should've done this anyway before an auto-upgrade).

  4. flicht
    Posted 14 years ago #

    OK. I'll try it manually.

    Thanks for the advice!

About this Topic