The MU forums have moved to WordPress.org

No Admin, Plugins options after WordPress 2.8.5.2 upgrade (11 posts)

  1. atgeist
    Member
    Posted 7 years ago #

    I did the automatic upgrade to 2.8.5.2 from 2.8.5 and now I can't see any admin functions on the backend. I see no "plugins" tab, no "site admin" tab. Any ideas???

  2. tmoorewp
    Member
    Posted 7 years ago #

    Check in your MySQL database for the table wp_sitemeta. In wp_sitemeta, search for the value "site_admins" in the "meta_key" column.

    What is the "meta_value" that goes along with the "site_admins"? Is your username that you are logging in with listed there?

  3. circuit
    Member
    Posted 7 years ago #

    did you drop the MU users table? you need the MU uber-admin account to see those options. the only way to recreate it is to reinstall MU.

  4. atgeist
    Member
    Posted 7 years ago #

    tmoorewp, yes, my username "admin" is there. and no, my MU users table has not been dropped. there had to be something in that upgrade that crapped something out, not sure what?

  5. atgeist
    Member
    Posted 7 years ago #

    it seems that the only things I can't see are the "plug-ins" and the "site admin" screen. It still shows me as the administrator and I can see all the other sub-blogs.

  6. atgeist
    Member
    Posted 7 years ago #

    I manually upgraded the site to 2.8.5.2 but I'm still not seeing an "upgrade" link nor my "plugins" and "Site Admin" dashboards. I think since I already did the "upgrade" link, it is not showing as an option.

  7. DeannaS
    Member
    Posted 7 years ago #

    Did you check in the database in the site options table to make sure that the meta_key site_admins looks like this:
    a:1:{i:0;s:5:"admin";}

    There was an issue with an earlier upgrade where the format of the site_admins meta key changed and it broke some of the permissions of site admins...

  8. atgeist
    Member
    Posted 7 years ago #

    Thanks DeannaS, that fixed it!

  9. corischlegel
    Member
    Posted 7 years ago #

    FWIW, if anyone else encounters this problem - the specific issue is that the old value "escaped" the double-quotes with a backslash:
    a:1:{i:0;s:5:\"admin\";}

  10. dains
    Member
    Posted 7 years ago #

    Encountered the exact same problem - thanks for working this out!

  11. dains
    Member
    Posted 7 years ago #

    Just for the record, my entry looked like this after the upgrade:

    a:1:{i:0;s:0:"";}

About this Topic