The MU forums have moved to WordPress.org

Domain url ends up with newblog.mydomain.com/wpmu/ (10 posts)

  1. mickemus
    Member
    Posted 16 years ago #

    Everything runs smoothly... I can create new blogs and update etc etc!

    The catch: All blogs end up with a /wpmu trailing the domain name. I have the DNS wildcard set so newblog.domain.com is resolved but it gives me a directory view (with all the directories under public_html). Clicking on the wpmu folder (or keying it straight in the url) brings me to the correct site.

    When I try to create a new blog already logged in as admin the signup page states the following:

    Here are the blogs you already have:
    * mydomain.com/wpmu/

    ...also with the trailing /wpmu/

    What am I doing wrong? I've searched high and low on these forums for hours now but cannot find any direct hit.

    My .htaccess

    RewriteEngine On
    RewriteBase /

    # Rewrite http://www.domain.com to domain.com
    RewriteCond %{HTTP_HOST} ^www\.(.*)
    RewriteRule ^(.*) http://%1/$1 [R,L]

    #uploaded files
    RewriteRule ^(.*)?/?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    If the answer is clearly out there... please point me in the right direction.

    Thanks!

  2. drmike
    Member
    Posted 16 years ago #

    You need to install it to your root directory, not a subdirectory.

    My guess is you uploaded the compressed file and unzipped it there. It's set up to unzip the files into a subdirectory.

    Changes are you're going to have to delete the install, reupload the files into the correct directory and then do a reinstall.

    Good luck,
    -drmike

  3. mickemus
    Member
    Posted 16 years ago #

    Ok... but... ;)
    Now I've installed it under the root of a subdomain (real subdomain), blog.mydomain.com but it still shows me a directory listing (ie cgi-bin, blog etc). That means that I'm forced to install wpmu in the real web root (public_html).

    I was hoping that I could use a different tool for my main site (standalone wordpress or CMS) and then have users blogs under myusersblog.mydomain.com. Now it seems that I'll be "forced" to use myusersblog.blog.mydomain.com and to use wpmu as my main mydomain.com tool.

    Is there a way around this?

    My worst case option (I won't die but I'm a fetish for the perfect world and I have a tendency to customise and tweak my own blogs so I don't want to 'kill' my users blogs due to my own stupidity) would be to have myusersblog.blog.mydomain.com for the user blogs. If I want to use a standalone wordpress/CMS for my webroot, could I achieve this by changing the domain wildcard from *.mydomain.com to *.blog.mydomain.com?

    Thanks!

  4. kahless
    Member
    Posted 16 years ago #

    mickemus,

    Yes!

    I have my install set like this. domain.com is it's own vhost with document root public_html. I have the blogs.domain.com set as a subdomain and wildcard entry on this subdomain. The vhost document root for blogs.domain.com is public_html/wpmu. I have this setup on two separate servers (one I administer as school and one hosted with DreamHost).

  5. mickemus
    Member
    Posted 16 years ago #

    okidokey!! I'll have to settle with the 'second best option' ;)

    Thanks a million kahless!!!

    WPMU Dev GURUS!! Suggested future feature... Can this be worked out??? I think most ppl would like to put the WPMU on a 'subdomain/vhost' and not put the users blog one level below?

    Thanks for a great effort on WordPress... since January 06 I've set up 6 blogs for friends and communities and they've all ended up with WP (I've used phpwebsite and other CMS previously but with all the great plugin support I can do 95% of the stuff on WP).

    Keep up the great job!!

  6. Nepherim
    Member
    Posted 16 years ago #

    "I think most ppl would like to put the WPMU on a 'subdomain/vhost' and not put the users blog one level below?"
    I'd like to second this. I've also installed into a sub-dir and am struggling with finding a .htaccess / WP setting to accomodate clean URL's. It can be done, as most other s/w takes this approach.

    In general, installing in the root is not something that's typically encouraged -- the preference being to ensure s/w separation and prevent potential conflicts.

  7. donncha
    Key Master
    Posted 16 years ago #

    If you don't want to install into the document root, the accepted way of getting around it is by pointing another vhost at that new directory, but then that's the root of that vhost so you're still stuck.
    You could also use a server alias and install it somewhere else. The packaged versions of PhpMyadmin do this. That requires access to your httpd.conf however.

    TBH, if you want something to appear like it's in the root of your domain, it'll be installed there too. That's the simplest way of doing it.

  8. Nepherim
    Member
    Posted 16 years ago #

    "That's the simplest way of doing it."
    Perhaps, but .htaccess can change how that looks to the browser user, making it appear that WP is installed in root. I just can't work out how to ensure WP generates clean URL's (without the "/wp"). Other s/w I use has this kind of setting for exactly this purpose.

  9. macosx
    Member
    Posted 16 years ago #

    Hi,

    We had the same problem.

    We were trying to inst mu.wp on an account of a user under confixx (a admin tool to manage virtusers by http://www.swsoft.com).

    The problem is, that even if we chmod the html directory 777 it is not seen writable by the wp's index resp. install php and we keep getting err:

    "Installing WPµ

    /home/www/web207/html : FAILED
    Quick Fix: chmod 777 /home/www/web207/html
    Warning!

    ..."

    We tried numerous variations of chmod, chown w. and w./o. -R and even if we move fast (confixx's CRON'ed script re-sets the permissions), we keep getting the same error.

    Installation works perfectly within a subdirectory, but we want http://blog.co.ro to be the entry-page and not like http://blog.co.ro/wp/ or anything similar

    Why isnt it enough for mu.wp to check on whether or not it is able to write INTO the html dir (the users root web-directory, public_html)? Why does the software need to check whether the directory ITSELF is writable? Or am I missing something here?

    We finally solved it by adding <DocumentRoot = /home/www/web207/html/wp/> to apache's conf but this an option most of the usual hosting clients wont be able to use, and I really do not see why it should be necessary, if you revise the rights check of wp's root directory executed upon installation.

    Thank you & keep on the good work,

    Mr. Mac

  10. donncha
    Key Master
    Posted 16 years ago #

    INTO a directory and a directory ITSELF is the same thing. Are you sure you don't have some sort of PHP safe mode enabled? What you did should have worked fine!

About this Topic

  • Started 16 years ago by mickemus
  • Latest reply from donncha