The MU forums have moved to

Yet Another Domain Mapping Probelm (5 posts)

  1. miklb
    Posted 14 years ago #

    Obviously there seems to be two camps on this issue, one who thinks the plugin works just hunky dory, and another that thinks it could stand better documentation and work. I'm leaning towards the later.

    I've read every thread/post/tutorial I can find on the subject, and am just not getting anywhere. I am able to map a subdomain with CNAME Records just fine. However, trying to map a domain using an A Record, something is amiss. won't load, and won't load. It just kinda loops, never getting to the site. _seems_ to redirect to, but doesn't quite get all the way.

    What confuses me is that the subdomain mapping works just fine. redirects to, so obviously the DNS and Apache VHost are configured properly.

    I've even upgraded to the latest dev version of the plugin to see if that might resolve my issue, but alas, no luck.

    If anyone has any clear up-to-date instructions for redirecting full domains using A Records, I'd love to read them.

    Might I add, this is just a plain ol' VPS, not a cPanel installation. I get very confused by the instructions that discuss parking/and add-on domains.

  2. miklb
    Posted 14 years ago #

    I've not figured this out for my plain ol' VPS, I even tried adding to the ServerAlias in the httpd.conf, but I did sort this out on a cPanel install I'm working on.

    Now, does anyone have any tips on how to force the WWW? It's beyond my control, I'm not a fan of the WWW, but I have some fringe cases where it's required.

  3. andrea_r
    Posted 14 years ago #

    "However, trying to map a domain using an A Record, something is amiss."

    Right, because the server needs to be setup for it. The plugin can't do that part. :)

    you're on a vps with no control panel?
    Is the MU install the default v-host?

  4. miklb
    Posted 14 years ago #

    Yes, and Yes. It seems my problem was with Godaddy and the particular domain I was trying to map to my installation. I tried a different domain and it worked like a charm.

    I do still have someone worried about not being able to use a WWW in their domain, but otherwise, I've finally gotten a grip on the plugin.

  5. andrea_r
    Posted 14 years ago #

    Good. :)

    It's usually the DNS part that trips people up.

About this Topic