The MU forums have moved to WordPress.org

Problem creating blogs (subdomain) (9 posts)

  1. thekruser
    Member
    Posted 13 years ago #

    Issue:
    When I create a new blog (subdomain), I get a 404-error.

    Limitations:
    -Cannot have access to httpd.conf
    -Hosting service (GoDaddy) will not enable wildcard DNS
    -No idea if mod_rewrite is enabled and they wont tell me (called multiple times...apparently it is a security risk according to their policies)

    Actions tried:
    -Followed steps at GoDaddy Help to no avail. Personally, I think that article is written for no other reason than to upsell you to static IP. It worked...I bought it. It didn't do anything, but they got my money!
    -Read readme.txt, no solution for my unique situation.
    -Read article referenced in readme.txt, not applicable.
    -Have created an A host redirect (* to domain ip), did nothing.
    -Created subdomain manually and pointed to WPMU installation directory. This works, but seems rather counterproductive given the goal of WPMU.

    Questions:
    -Is there a way to manipulate using .htaccess? If so, how?
    -Is my methodology flawed?
    -Have I done something incorrectly? I admittedly know very little about this type of problem.

  2. sbrajesh
    Member
    Posted 13 years ago #

    well,since your host does not allows wild card DNS and you don't have access to httpd.conf,my advise will be go for Sub directories style blog address.
    If yo have just installed wpmu,you can re install it with the sub directories style blog address and that will work.

    Given your situation,I don't see a good option for subdomain style blog address.
    Hope it helps.

  3. andrea_r
    Moderator
    Posted 13 years ago #

    "-Hosting service (GoDaddy) will not enable wildcard DNS"
    and
    "-Followed steps at GoDaddy Help to no avail. Personally, I think that article is written for no other reason than to upsell you to static IP. It worked...I bought it. It didn't do anything, but they got my money!"

    Both these things trouble me. Call up support. Tell them you're installing MU and you bought the static IP like they said. Get them to enable wildcard subdomains.

  4. GDHosting
    Member
    Posted 13 years ago #

    @thekruser
    It really has to do with the shared hosted environment and IP delegation. It's also not a matter of us enabling it, but that it will not allow for a shared IP address to be assigned to a Wildcard A-Record. Our support team can help you with this if you haven't contacted them already. That information is found here: http://www.godaddy.com/community/community.aspx?tab=support

  5. thekruser
    Member
    Posted 13 years ago #

    I have it working now...FINALLY. Thank you for your help, all.

    The solution was to get the static IP then create a wild card A record pointing to the static IP. It took a while to get it to go through, but it is working now.

    Again, thanks for the help.

  6. mybenson
    Member
    Posted 13 years ago #

    @thekruser, how long did it take for the sbudomains to work after you got the static IP? I created the wildcard before getting my static IP, and then after the static IP was created, the wildcards automatically switched to the new IP. That was about 10 hours ago, and subdomains still not working. Thanks :)

  7. andrea_r
    Moderator
    Posted 13 years ago #

    That's too long, should be instant.

  8. musiqcentral
    Member
    Posted 13 years ago #

    Wow.... GD says it can take 24 to 48 hrs. They claim they have to physically pick up the account and move it to another server.... The shared IP will stay the same, they give a secondary Dedicated IP.... it is this IP that will need to be used for the wildcard a record.

  9. musiqcentral
    Member
    Posted 13 years ago #

    ok... it was less than 24 hrs I guess... I got my dedi IP... I added the dedi IP to my a record for wildcard domains... and now I get a 500 error... not sure if it is still the propagation or it's another error...

About this Topic

  • Started 13 years ago by thekruser
  • Latest reply from musiqcentral