The MU forums have moved to WordPress.org

Problem uploading images / Unable to create directory (8 posts)

  1. EmmaDouble
    Member
    Posted 12 years ago #

    Hello to everyone,

    I had a little pb when i try to upload some picts on my Wordpress mu blogs.

    I have the following message:

    'Unable to create directory /var/www/vhosts/lerestedumonde.com/httpdocs/blogs/wp-content/blogs.dir/1/files. Is its parent directory writable by the server?'

    I try to allow the writable propriety in all the directory but it could not still work...

    Could any help me please?

    Emma.

  2. ancawonka
    Member
    Posted 12 years ago #

    Hi Emma,

    The last time I had this problem, it was because there was a typo in the upload directory specification inside the WordPress settings. Make sure that you actually have that specific directory on your filesystem

    How are you making the directories writeable? Are you using an FTP client, or going through the shell?

    You can try this:

    (from the command line/shell)

    chmod -R 777 /var/www/vhosts/lerestedumonde.com/httpdocs/blogs/wp-content/blogs.dir/1/

    Cheers,

    Anca.

  3. EmmaDouble
    Member
    Posted 12 years ago #

    Hello,

    Thanks for your answer.

    I use Filezilla FTP.

    I made the directories writable
    with the command line

    chmod -R 777 /var/www/vhosts/lerestedumonde.com/httpdocs/blogs/wp-content/blogs.dir/1/

    But now i have a new message:

    "The uploaded file could not be moved to the upload folder."

    Could anyone help me?

    Thx.

  4. ancawonka
    Member
    Posted 12 years ago #

    Here's a great list of things to try that might help solve your problem: http://wordpress.org/support/topic/164999?replies=1

  5. EmmaDouble
    Member
    Posted 12 years ago #

    Thx a lot.
    But i still can t fixe the problem.

    on wordpress MU, is there a way to choose in which subdirectories we want to upload images ? (like in wordpress classic, settings=>Miscelliscious..)

    THX.

  6. andrea_r
    Moderator
    Posted 12 years ago #

    Check the ownership of the folder. If it's owned by apache or root, that's the issue.

  7. paulholmes
    Member
    Posted 12 years ago #

    EmmaDouble - I had the exact same problem with mu2.8.6, just cleanly installed.

    I checked the ownership of the folder, and it actually did assign the wrong owner, so I logged in as "root" and reassigned the user and group to the same user and group as the rest of the folders (stay logged in after this).

    chown [user] blogs.dir
    chogrp [group] blogs.dir

    I then created a folder (in FileZilla, my FTP program) named "1", and changed it to "777"

    Then I tried uploading it again, and received the same message you received:
    "The uploaded file could not be moved to the upload folder."

    Within the "1" folder, it created a folder called "files".

    I went back to my "root" login and reassigned the user and group again.

    chown [user] files
    chogrp [group] files

    This fixed it.

    I just hope I don't have to do this for every MU blog added... we'll see.

  8. EmmaDouble
    Member
    Posted 12 years ago #

    Thanks a lot.
    I am on MAC OS.

    Could please tell me how you can enter all these commands in FTP Filezilla...? please

    THANKS.

About this Topic

  • Started 12 years ago by EmmaDouble
  • Latest reply from EmmaDouble