The MU forums have moved to WordPress.org

how to handle the .www is deprecated bit in MU? (3 posts)

  1. miwashi
    Member
    Posted 12 years ago #

    WP MU seems to use URLS without the www. in front as it's deprecated. However my host and setup cannot seem to function without the www. If I access the domain without the http://www., I get a server not found error.
    Can I know how I can set my website to respond to accesses through both http://www.mydomain.com and mydomain.com?

    The problem is manifested in the WP MU admin login screen. Accessing the login screen through a http://www.xxx.xxx/admin.php link is fine. But after keying in the credentials and submitting, WP MU redirects the browser to a xxx.xxx/xxx.php page, and the lack of a www. in front causes a server not found error.

  2. ancawonka
    Member
    Posted 12 years ago #

    Who's your host? If you have access to your DNS settings, you should make sure that there is a valid IP Address setting for *.yourdomain.com.

    Also, make sure that your Apache server responds to requests for yourdomain.com, rather than just "www.yourdomain.com". Depending on who your hosting provider is, there different ways to specify that.

  3. tmoorewp
    Member
    Posted 12 years ago #

    Also make sure that Apache mod_rewrite is activated and working properly. Page not found can sometimes be caused by the rewrite rules not being utilized.

About this Topic

  • Started 12 years ago by miwashi
  • Latest reply from tmoorewp