The MU forums have moved to WordPress.org

Installation #{$£ ! (25 posts)

  1. fredl
    Member
    Posted 17 years ago #

    Bonjour,

    First, wp is great and mu too ! I've installed mu localy, after installing apache 2, it was working correctly, i've decided to install on my production server. MU-WP has been so easy to install, so I've transfered to my linux production server. 5 minutes after, i was following the messages, and run the install...
    I'm still waiting the process to run correctly... non response...

    Do I forgot something ?

    Please help !

  2. lucid1
    Inactive
    Posted 17 years ago #

    the nightly build from last night seems to have an error....

  3. Farms
    Member
    Posted 17 years ago #

    Have you checked the .htaccess? Appartently there was something odd on mine...

  4. lucid1
    Inactive
    Posted 17 years ago #

    no I encountreed a parse error on index.php

  5. donncha
    Key Master
    Posted 17 years ago #

    Fixed it now. small typo on 2 lines. unstable release has been updated!

  6. lucid1
    Inactive
    Posted 17 years ago #

    close but....
    Parse error: parse error, unexpected ';' in /var/www/html/blah/blah/wp-inst/wp-admin/wpmu-upgrade.inc.php on line 5

  7. donncha
    Key Master
    Posted 17 years ago #

    Got it.. copy and paste error!

  8. lucid1
    Inactive
    Posted 17 years ago #

    Parse error: parse error, unexpected ';' in /var/www/html/blah/wp-inst/wp-admin/wpmu-upgrade.inc.php on line 28

    before you changed it I had fixed line 5 then 24 and 28, then got sql syntax errors....

  9. lucid1
    Inactive
    Posted 17 years ago #

    saw ya changed it again so I tried it....
    Warning: main(/var/www/html/blah/wp-inst/wpmu-settings.php): failed to open stream: No such file or directory in /var/www/html/blah/wp-inst/wp-config.php on line 86

    Fatal error: main(): Failed opening required '/var/www/html/blah/wp-inst/wpmu-settings.php' (include_path='.:/usr/local/lib/php') in /var/www/html/blah/wp-inst/wp-config.php on line 86

    so I looked and sure enough the file 'wpmu-settings.php' isnt there

  10. donncha
    Key Master
    Posted 17 years ago #

    Fix that last bug, I don't know why wpmu-settings.php wasn't created. Download the latest unstable release and run the installer again?

  11. Farms
    Member
    Posted 17 years ago #

    and has anyine seen my pome?

    http://mu.wordpress.org/forums/topic/151

  12. lucid1
    Inactive
    Posted 17 years ago #

    I got the same error as the ones I posted last time....
    I dont have a wpmu-settings.php.dist either.....

  13. donncha
    Key Master
    Posted 17 years ago #

    The file is definitely there.. Double check your install?

    $ tar ztvf wpmu-unstable.tar.gz |grep wpmu-setting
    -rw-r--r-- donncha/donncha 2068 2005-07-19 10:34:28 wpmu-2005-08-12/wp-inst/wpmu-settings.php.dist

  14. lucid1
    Inactive
    Posted 17 years ago #

    my mistake, wpmu-settings.php.dist is there... but I still get the same errors... and wpmu-settings.php was not made...

  15. lucid1
    Inactive
    Posted 17 years ago #

    ok I think I know what the deal is, I started again... this time I refreshed the main install page (was loading cached page I guess) and checked and it was made... I will continue install in a few minutes... thanks for help!

  16. lucid1
    Inactive
    Posted 17 years ago #

    ok... that done... continuing the instillation I got the following erros...

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1]
    INSERT INTO wp_sitemeta (meta_id, site_id, meta_key, meta_value) VALUES (NULL, 1, 'welcome_email', 'Dear User, Your new SITE_NAME blog has been successfully set up at: BLOG_URL You can log in to the administrator account with the following information: Username: USERNAME Password: PASSWORD Login Here: BLOG_URLwp-login.php We hope you enjoy your new weblog. Thanks! --The WordPress Team SITE_NAME'

    and

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1]
    INSERT INTO wp_sitemeta (meta_id, site_id, meta_key, meta_value) VALUES (NULL, 1, 'first_post', 'Welcome to SITE_NAME. This is your first post. Edit or delete it, then start blogging!'

  17. lucid1
    Inactive
    Posted 17 years ago #

    ok there are 2 ' ) ' missing in index.php and one in wpmu-upgrade.inc.php

  18. lucid1
    Inactive
    Posted 17 years ago #

    after fixing those 2 files in those 3 places, the install seemed to work fine, but the blog that was made had errors at the top because something was coming before the headers it was trying to put out....

    here are the errors....

    Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/lucid1/vnof/wp-inst/wp-content/themes/classic/header.php:5) in /var/www/html/lucid1/vnof/wp-inst/wp-includes/pluggable-functions.php on line 320

    and 3 more with different line numbers...

  19. donncha
    Key Master
    Posted 17 years ago #

    Fixed those errors!
    Update wp-include/wpmu-functions.php and wp-include/pluggable-functions.php from the unstable release.

  20. fredl
    Member
    Posted 17 years ago #

    hell,
    such a mess, i've tried to get the file wpmu-upgrade.inc.php nothing, something is going wrong with my version, i'll get the unstable one and i try again to install, be back in a minute.

  21. fredl
    Member
    Posted 17 years ago #

    I've install the unstable version, and now there's a 500 !
    How can I do !

  22. lucid1
    Inactive
    Posted 17 years ago #

    any 500 I have gotten has had to do with mod_rewrite

  23. lucid1
    Inactive
    Posted 17 years ago #

    sweet on the fixes, cant wait untill tomorrow's! :)

  24. fredl
    Member
    Posted 17 years ago #

    I've cumulated the problems, .htaccess and my server configuration, next step, full install of mu-wp !
    still fighting with the db scripts !!!
    Tomorrow's an other day...

  25. dronamraju
    Member
    Posted 17 years ago #

    Where exactly were the missing ")" in these files? Can you provide line numbers? My wpmu installation has parse errors with wpmu-functions.php (unexpected $ at line 640 when there were only 639 lines in the file). Help greatly appreciated

About this Topic

  • Started 17 years ago by fredl
  • Latest reply from dronamraju