The MU forums have moved to WordPress.org

Admin Panel Missing after Import from Standard WP (3 posts)

  1. awarner20
    Member
    Posted 12 years ago #

    I've been searching the forums and have seen some references to similar situations, but mine is a bit different.

    On an existing wpmu install I have an admin user named user1234. This was a fresh install with only the example posts.

    On a standard wp install, I exported 1300 posts, pages, etc. I then imported this into the wpmu install. During import I was prompted to "attach these posts to user1234?" which I did.

    Everything seems to be fine with the exception of the plugins and admin panel missing.

    After some searching/reading/looking through the db, I simply went into the db and changed the username back to admin instead of user1234. This brought back the site admin and plugins panels in the dashboard...but of course I don't want the username of admin for security.

    Does anyone have any idea on what might be the missing piece here? What did I miss?

  2. kgraeme
    Member
    Posted 12 years ago #

    In Site Admin > Options look for the setting for listing who the allowed Site Admins are. When you changed the admin account name in the database it no longer matched the list of names here.

    So just add the desired name here first, then go into the DB and change the account name.

  3. awarner20
    Member
    Posted 12 years ago #

    Thanks, kgraeme. When logged in as admin, I added the user1234 username to the allowed site admins. I then went into the db and changed "admin" to "user1234".

    Thanks!

About this Topic

  • Started 12 years ago by awarner20
  • Latest reply from awarner20