The MU forums have moved to WordPress.org

Install 08-13-2005 (21 posts)

  1. plainsman
    Member
    Posted 17 years ago #

    I've tried the install five times now. I have read everything I can find in the forums. Some have similar problems with other builds.

    This is not the same as "Installation #{$£ !" at http://mu.wordpress.org/forums/topic/157

    It is similar to some older posts about other builds. I receive this error:

    Fatal Error
    Could Not Find Blog!
    Searched for prtopics.com/wpmu/ in wpmudb::wpmu_blogs table. Is that right?
    Please check that your database contains the following tables:

    * wpmu_blogs
    * wpmu_users
    * wpmu_usermeta
    * wpmu_site
    * wpmu_sitemeta
    * wpmu_sitecategories

    It creates all of the tables each time I install.

    My server uses /htdocs/www structure.

    I've installed WPMU two ways.

    (1) in the /www by uploading the whole folder /wpmu/
    (2) even did it as a sub-domain in the /htdocs by uploading the /wpmu/

    Strange thing is, in the (2) option above, it actually worked for the initial blog. It gave me the signup page, too.
    http://wpmu.mydomain.com/wp-newblog.php

    However, filling that out did not return a proper URL to a new blog. It did send the email stating that my new blog was located here: http://rdf.wpmu.mydomain.com/wp-login.php

    And, the new blog I'd signed up for did not show up in the list of blogs installed in the WPMU blog's admin section.

    In the (1) option above, putting the /wpmu/ in the /www directory and running it seems to go well, but then the email announcing the initial installation says that I have a new blog at:
    http://mydomain.com/wpmu/wpmuwp-login.php

    When I visit that link, I receive the initial error I reported at the top. "Can't find blog" etc...

    Sorry if this is too much info, but I wanted to try and give as much as possible.

    Any ideas? Many thanks.

  2. lucid1
    Inactive
    Posted 17 years ago #

    I had that problem when I attempted to install in a directory other than the root of the domain....

  3. plainsman
    Member
    Posted 17 years ago #

    Well, I'll admit my noobness.

    Can you tell me how I would call /wpmu if I installed it in the "/" root? not /htdocs/www or /htdocs

    Is that what you're saying?

    Thanks.

  4. lucid1
    Inactive
    Posted 17 years ago #

    I am not that familier with that type of file system so this could be wrong, but I have my dns server accepting wildcard subdomains for the domain in question, and I replace the domain with the wpmu stuff... ie, my file system works like so, /var/www/html/username/domain/stuff

    so I untar it and rename the folder made to 'domain'.... I chmod the domain -R 777 and install works great.

    I doubt that this helped you.... good luck...

  5. plainsman
    Member
    Posted 17 years ago #

    lucid1, thank you for the replies.

    i am using shared hosting for my domains. this seems to be aimed at those with dedicated servers.

    however, my provider thinks it will work on my accounts. i guess I'm going to have to do more interaction with them.

    however, if someone has been using WPMU on shared hosting successfully, I'd like to hear about, too.

    searching for shared hosting in her doesn't turn up much.

    thanks.

  6. alexk
    Member
    Posted 17 years ago #

    Hello plainsman, I had a similar problem. I traced the problem down to the discrepancy of the blog (name/id) being stored in the database as "prtopics.com" whereas it is looking for some different name (possibly with a www. prefix or some other prefix). That setting is in the dashboard/admin section.

    However, I noted that once the database has registered the name as 'prtopics' there is no way for admin to correct the issue. I was able to use phpmyadmin to rename my blog manually in the database to correct the problem.

    Not sure if that'll help, but it may give you some clues.

  7. plainsman
    Member
    Posted 17 years ago #

    Thank you, alexk.

    In that instance, I'm guessing you're referring to the blog being in the /htdocs/www as being the place to put the /wpmu folder to set up the blog(s).

    And, that field for the site name/id is in what table? what field?

    looking around at the tables, I find wp_sitemeta which has a field for site_id ... is that it? or wp_site which has id and domain?

    and then, i'd have to find out how to change that. i do have phpmyadmin

    i'm looking through wordpress codex for tips on the tables / fields and not finding it ... also, i imagine those tables/fields might be different in WPMU?

    the noobness i'm experiencing and feeling is immense here. :o)

    thank you.

  8. plainsman
    Member
    Posted 17 years ago #

    OK, tried it for the umpteenth time now .... when I put the /wpmu/ folder in the /www root, these are the problems I encounter.

    Everything up to the screen saying, "Your blog has been created" works fine. But, the URL it provides for the blog is all wrong.

    For instance, in the last installation attempt this is the URL I received:

    http://mydomain.com/wpmu/wpmu

    and I get this in the email about the initial blog being set up:

    The requested URL /wpmu/wpmuwp-login.php was not found on this server.

    So, I am guessing that a combination of the install setting the URL of the site without the "www." and perhaps something in the .htaccess file is not doing what it should?

    The support people of my provider are looking into it, but they think it should work as is ... and, of course, it isn't.

    As another attempted installer said in another post, tomorrow is another day. :grin:

    Thanks.

  9. ark
    Inactive
    Posted 17 years ago #

    You might get rid of some funny paths by adding a slash to the path in the wp_blogs table, but that only solved some problems in my case.

  10. plainsman
    Member
    Posted 17 years ago #

    Thank you, ark. I'll try that, too.

  11. alexk
    Member
    Posted 17 years ago #

    plainsman, are you trying to install in the root directory of your server? I have found that to be the cleanest install. I have installed multiple builds on my multiple servers using CPanel, as well as Plesk but haven't run into a problem like yours. I am also using the VHOST configuration and it works fine.

    If you wish, send me an email and if I am provided with the needd info, I can try to install it for you. Frankly, a clean install of the software takes no more than a minute (minus the upload time for all the files onto the server).

    The WP teams seems to be working hard on the software as sometimes they come out with multiples builds of the software in one given day, some of which install cleanly and others don't. As a result I have saved a copy of the software which I found to install in a squeaky clean manner. This is an early morning version of the software that came out on 8-13-05 :)

    Let me know.

    Thanks

  12. plainsman
    Member
    Posted 17 years ago #

    Thank you, Alexk. I may take you up on your offer of help in the install.

    However, for now it has become a personal grudge to get it to work. :o) So, I'm going to keep working at it.

    I think I may have found part of the problem.

    On my provider's site, they do not have the VHOST option enabled and you have to do some tweaking. I don't think I'm doing it right. I'll keep working with the providers and see if I can get it going correctly.

    Thank you all for your help.

  13. plainsman
    Member
    Posted 17 years ago #

    By the way, is their a link where I might download that "8-13-05" nightly that works so well?

    Thanks.

  14. alexk
    Member
    Posted 17 years ago #

    As for the 8-13-05 version, it's my understanding that they keep replacing the download file under the 'downloads link' with a fresh/updated copy, so the version I am referring to is already replaced by a different copy.

    For Vhosts, I don't think there's anything your provider has to do in order to make it work for you. All you have do is ensure that mod_vhost and mod_rewrite is installed. After that you (the webmaster) have to set up the server to use a wildcard DNS, and configure apache to use the wildcard virtual host.

  15. CMerritt
    Member
    Posted 17 years ago #

    Exact same install problem here -- Could Not Find Blog -- tables are created -- no access to admin or wp-newblog.php. I originally tried installing last weekend with the 8-12-05 version I believe.

    So here's a question around the mod_vhost and mod_rewrite functions. How do I verify on my dedicated server that they're actually working? Silly question possibly I know... but here's what I know.

    1) In my phpinfo under "Loaded Modules," mod_rewrite is listed. I also don't get any install error about mod_rewrite when I install Mu.

    2) I've set up my VHosts in apache previously for a homepage community script that I use, as well as to set up one IP address on the server as a virtual domain. However, I'm not convinced that I have wildcards set up correctly. There was already a "VirtualHost" entry for my main domain, but I went in and added a wildcard entry via pico and restarted apache. However, I haven't done a clean reinstall since I updated the VHosts info.

    Is there anything else I'm missing before I do another install and see what I get?

    Thanks!

    -Chad

  16. CMerritt
    Member
    Posted 17 years ago #

    Updated VirtualHost entry, restarted apache, uploaded unstable version that I downloaded 08-16-05. Still getting:

    Could Not Find Blog!
    Searched for fwrestling.com/wpmu/ in wpmu::wp_blogs table. Is that right?
    Please check that your database contains the following tables:
    wp_blogs
    wp_users
    wp_usermeta
    wp_site
    wp_sitemeta
    wp_sitecategories

    In wp_blogs through phpmyadmin I see:

    blog_id | site_id | domain path | registered | last_updated | is_public
    1 | 1 | fwrestling.com | /wpmu | 2005-08-17 11:55:27 | 0000-00-00 00:00:00 | yes

    Any suggestions? At this point I'm stumped. I still don't know how to tell if mod_rewrite is doing what it is supposed to.

    -Chad

  17. NetAndif
    Inactive
    Posted 17 years ago #

    If you installed wpmu in a subdir of your webroot you will most likely have no luck.
    I were at the same point recently, and found out that in such case the blog path could not be retrieved correctly.
    I guess it wouldn't be that hard to fix, but you need the support for this from the developers...

  18. altoyes
    Member
    Posted 17 years ago #

    alexk:
    would you be able to assist me to install mpmu?
    i have looked at it 6 times over a year and a half and just cannot work out how to install. i do not understand the instructions.
    as 8.13.05 version works for you, could this be installed for me?

    alto

  19. altoyes
    Member
    Posted 17 years ago #

    to anyone:
    does anyone know what to do with the "RSS feed for this thread" link. i click on the link and all it says is .....

    "This XML file does not appear to have any style information associated with it. The document tree is shown below."

    alto

  20. Melodiefabrieknl
    Member
    Posted 15 years ago #

    I think it's a bug. I am not using subdomain for MU, only subdirectories. I am adding sites from Dashboard and everytime I create a new blog the Admin of the blog is send an URL without the subdirectory-blogname in the name. Not good: a bug!

  21. quenting
    Member
    Posted 15 years ago #

    thanks for reviving a 17 months old thread...

About this Topic

  • Started 17 years ago by plainsman
  • Latest reply from quenting