The MU forums have moved to WordPress.org

Category/Author/Tag pages come up 404? (6 posts)

  1. mybenson
    Member
    Posted 13 years ago #

    None of my category/author/tag pages are working. I have pretty permalinks setup, and the nav and post pages work, but not the rest.

    Not sure if this is yet another htaccess problem. I have the structure setup to /category/%category% and /author/%author%. I'm using the Advanced Permalinks plugin and those are the defaults.

    ---------------

    On a sort of separate note, when I create a page named Blog or Contact, and it automatically creates the URL to be mydomain.com/blog -or- mydomain.com.contact, those pages come up "Page not found". Not even my custom 404 page. But if I go in and manually change the URL to something like /contact-us, it works just fine.

    Any thoughts on either of those problems? Thanks.

  2. andrea_r
    Moderator
    Posted 13 years ago #

    I am really stumped that half your permalinks aren't working.

    Okay, just noticed this:
    "I'm using the Advanced Permalinks plugin and those are the defaults."

    Turn it off. Resave the permalinks on the settings page (which, you know, you can set up without a plugin) and try again.

  3. vested1
    Member
    Posted 13 years ago #

    This is strange -- because I am using the purchased plug-in as well however, my problem is not that obvious.

    Of the 40+ regular authors, 2 of them if, you click on their username in the article to filter out their posts, are missing posts from today back until mid December however, I also created categories for each author "whatever by john smith" and if you click on that category, all the posts appear...

    I did an advanced export and looked at the CDATA for one author and did not notice anything unusual, and also tried to do a restore hoping that the old data would be over written.... they both have great comments associated with their articles and would hate to delete them and then attempt to bring them back in with a restore....

    Anything I can do on the dbase end one might think of?

  4. mybenson
    Member
    Posted 13 years ago #

    Yeah, it didn't dawn on me that disabling the plugin and just using the standard permalinks would solve the problem but it did. I suppose with all my other issues, I think everything else is going to be just as complicated.

    Although I still have the /blog and /contact page problems...

    Thanks Andrea :)

  5. vested1
    Member
    Posted 13 years ago #

    Ok -- that's not the same problem I am having -- I will post my question out in the forum...

  6. takuya
    Member
    Posted 13 years ago #

    I was having the same category permalink problem, thanks to this post. Now that I have to look for advanced permalink alternative.

About this Topic