The MU forums have moved to WordPress.org

WILL NOT LET ME SAVE ANYTHING IN HOST FILE (13 posts)

  1. sam-111
    Member
    Posted 14 years ago #

    Hi guys..

    Only began using Wordpress a couple of months ago so not too experienced in all this. I already have Wordpress up and running as local host using Xampp.

    I now want to try Wordpressmu.. i've downloaded and unzipped into a sub-directory within Xampp. I've created the database.
    I have also realised that mu will not work without a proper url. I have followed various instructions in trying to create a new one by typing in: 127.0.0.1 localhost.localdomain in Hosts (notepad). When i click on save i get the following pop up box:

    Cannot create the C:\Windows\System32\drivers\etc\hosts file.

    Make sure that the path and file name are correct.

    I have run as administrator so i have no idea why it will not save.

    Can anybody help me get past this?

    Thanks in advance..

  2. SteveAtty
    Member
    Posted 14 years ago #

    have you checked the permissions on the hosts file?

  3. sam-111
    Member
    Posted 14 years ago #

    Hi.. no.. i'm a beginner at this.. sorry!

    How do i check the permissions?

  4. SteveAtty
    Member
    Posted 14 years ago #

    find the file, right click on it, select properties and make sure its not marked as read only

  5. sam-111
    Member
    Posted 14 years ago #

    It let's me type new text in the file so it cant be read only... i've just checked anyway and all looks fine in all the permissions.. all the boxes are ticked for full control on this file :-(

    Any other ideas?

  6. SteveAtty
    Member
    Posted 14 years ago #

    The fact that you can type into the file doesn't mean anything.

    Its not file ownership permissions - if you right click and select properties there should two check boxes at the bottom of the first tab in the dialogue box - one of which will labelled Read Only. Make sure that its is clear.

    As I don't have a windows box to hand I'm doing this from memory.

  7. sam-111
    Member
    Posted 14 years ago #

    Hi yes.. i did check these boxes.. both were as should be.

    I did change something in the advanced security permissions and it has let me save to the host file so thanks for pointing me in the right direction!!

    I've now hit another snag.. i've gone through the installation and have got the congratulations page, your wordpress mu site has been configured with a login link etc.

    I've clicked on login and now get the following page:

    Server error!
    The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

    If you think this is a server error, please contact the webmaster.

    Error 500
    localhost.localdomain
    21/01/2010 21:40:37
    Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0

    Do you know what i have done wrong now??

    Sorry to be a pain..

  8. SteveAtty
    Member
    Posted 14 years ago #

    Check your apache error log.

  9. sam-111
    Member
    Posted 14 years ago #

    The following is in my apache error log dated tday:

    [Thu Jan 21 20:42:36 2010] [error] [client 127.0.0.1] File does not exist: C:/Users/samantha/Desktop/sam1/xampp/htdocs/favicon.ico
    [Thu Jan 21 20:53:31 2010] [error] [client 127.0.0.1] WordPress database error Table 'wordpressmu.wp_blogs' doesn't exist for query SELECT * FROM wp_blogs WHERE domain = 'localhost.localdomain' AND path = '/xampp/sammu/' made by require, include, include_once, require_once, require_once, referer: http://localhost.localdomain/xampp/sammu/
    [Thu Jan 21 20:53:31 2010] [error] [client 127.0.0.1] WordPress database error Table 'wordpressmu.wp_sitemeta' doesn't exist for query SELECT meta_value FROM wp_sitemeta WHERE site_id = 1 AND meta_key = 'site_name' made by require, include, include_once, require_once, require_once, get_current_site_name, referer: http://localhost.localdomain/xampp/sammu/
    [Thu Jan 21 20:53:31 2010] [error] [client 127.0.0.1] WordPress database error Table 'wordpressmu.wp_blogs' doesn't exist for query SELECT blog_id FROM wp_blogs LIMIT 0,1 made by require, include, include_once, require_once, require_once, referer: http://localhost.localdomain/xampp/sammu/
    [Thu Jan 21 20:53:33 2010] [error] [client 127.0.0.1] WordPress database error Table 'wordpressmu.wp_sitemeta' doesn't exist for query SELECT meta_value FROM wp_sitemeta WHERE meta_key = 'wpmu_sitewide_plugins' AND site_id = 1 made by require, include, include_once, require_once, get_site_option, referer: http://localhost.localdomain/xampp/sammu/
    [Thu Jan 21 20:53:33 2010] [error] [client 127.0.0.1] WordPress database error Table 'wordpressmu.wp_sitemeta' doesn't exist for query SELECT meta_value FROM wp_sitemeta WHERE meta_key = 'active_sitewide_plugins' AND site_id = 1 made by require, include, include_once, require_once, apply_filters, call_user_func_array, mu_filter_plugins_list, get_site_option, referer: http://localhost.localdomain/xampp/sammu/
    [Thu Jan 21 20:56:01 2010] [alert] [client 127.0.0.1] C:/Users/samantha/Desktop/sam1/xampp/htdocs/xampp/sammu/.htaccess: RewriteEngine not allowed here
    [Thu Jan 21 20:59:43 2010] [alert] [client 127.0.0.1] C:/Users/samantha/Desktop/sam1/xampp/htdocs/xampp/sammu/.htaccess: RewriteEngine not allowed here, referer: http://localhost.localdomain/xampp/sammu/index.php
    [Thu Jan 21 21:00:12 2010] [alert] [client 127.0.0.1] C:/Users/samantha/Desktop/sam1/xampp/htdocs/xampp/sammu/.htaccess: RewriteEngine not allowed here, referer: http://localhost.localdomain/xampp/sammu/index.php
    [Thu Jan 21 21:01:35 2010] [alert] [client 127.0.0.1] C:/Users/samantha/Desktop/sam1/xampp/htdocs/xampp/sammu/.htaccess: RewriteEngine not allowed here, referer: http://localhost.localdomain/xampp/sammu/index.php
    [Thu Jan 21 21:01:42 2010] [alert] [client 127.0.0.1] C:/Users/samantha/Desktop/sam1/xampp/htdocs/xampp/sammu/.htaccess: RewriteEngine not allowed here, referer: http://localhost.localdomain/xampp/sammu/index.php
    [Thu Jan 21 21:05:03 2010] [alert] [client 127.0.0.1] C:/Users/samantha/Desktop/sam1/xampp/htdocs/xampp/sammu/.htaccess: RewriteEngine not allowed here, referer: http://localhost.localdomain/xampp/sammu/index.php
    [Thu Jan 21 21:11:15 2010] [alert] [client 127.0.0.1] C:/Users/samantha/Desktop/sam1/xampp/htdocs/xampp/sammu/.htaccess: RewriteEngine not allowed here, referer: http://localhost.localdomain/xampp/sammu/index.php
    [Thu Jan 21 21:40:37 2010] [alert] [client 127.0.0.1] C:/Users/samantha/Desktop/sam1/xampp/htdocs/xampp/sammu/.htaccess: RewriteEngine not allowed here, referer: http://localhost.localdomain/xampp/sammu/index.php

    The above means nothing to me i havnt a clue!

    My domain is localhost.localdomain
    My data base is: wordpressmu
    My wordpressmu files are saved as Sammu in htdocs/xampp

    I've checked in php and my database has the files attached to it....

  10. SteveAtty
    Member
    Posted 14 years ago #

    You've not got mod_rewrite enabled so fix that for a start

  11. sam-111
    Member
    Posted 14 years ago #

    Hi.. finally got a minute to look at how to enable the above... i've gone into the httpd file but the LoadModule rewrite line is already uncommented and according to articles i've read.. this is what i needed to do to enable it.

    Do i need to do anything else?

    Ps. i cant even open the mu installation finished page now either... but my other wordpress sites are still in tact so thats one good thing.

  12. SteveAtty
    Member
    Posted 14 years ago #

    Other WP sites? On the same server in the same directory structure?

  13. sam-111
    Member
    Posted 14 years ago #

    I have the std wordpress installed 3 times all on the same server but they all have their own files/names/databases etc and all run perfectly.

About this Topic