The MU forums have moved to WordPress.org

Image editing not working in one blog (14 posts)

  1. VFHwebdev
    Member
    Posted 14 years ago #

    Using WPMU 2.9.1.1

    In all my blogs but one, the new "edit image" feature works great. In this one particular blog, when I try to edit an image, the window where I'm supposed to see my changes to the image is just blank. I can see the crop, rotate, etc. tools, but not the window where I actually interact with the image.

    On all my other blogs this works fine. These are all part of the same WPMU installation.

    I tried disabling all the plugins for this particular blog and that didn't fix the problem.

    Any ideas what else this could be?

  2. andrea_r
    Moderator
    Posted 14 years ago #

    Did you check your error logs?

  3. ecenica
    Member
    Posted 14 years ago #

    We're seeing the same problem and can't find any solution.

    Server logs show nothing.

    Appears to be a javascript error?

  4. andrea_r
    Moderator
    Posted 14 years ago #

    Turn off all the plugins running on that blog and try again.

  5. ecenica
    Member
    Posted 14 years ago #

    After posting here I created a new test blog on our WordPress MU system, activated all the plugins and then removed them one by one.

    Until I found the culprit.

    The Edit Media feature is now working perfectly!

    My original suspicions of it being a cross-domain permission issue caused by the awesome Domain Mapping plugin were unfounded.

  6. SteveAtty
    Member
    Posted 14 years ago #

    So which plugin was causing the problem?

  7. VFHwebdev
    Member
    Posted 14 years ago #

    Yes, please tell us what the culprit was. I've tried disabling all plugins and am still having this problem.

    I only have it on one blog within my WPMU install. The others are all functioning normally.

  8. VFHwebdev
    Member
    Posted 14 years ago #

    My issue is still not resolved. It doesn't appear to be a plugin compatibility issue. I have the same problem even when all the plugins are disabled.

    Any one have any other suggestions?

  9. VFHwebdev
    Member
    Posted 14 years ago #

    It's my theme.

    I've been trying to figure out which plugin was causing this problem. Once I exhausted all those possibilities I set up a new blog and started testing one step at a time to see when the image editing feature broke.

    It happened when I activated my theme. If I switch back to the default theme the image editing capability comes back.

    This is a custom designed, custom built theme. Any ideas what in a theme could interfere with WP's image editing capabilities?

    How are the theme files even coming into play when I'm in the admin area?

  10. andrea_r
    Moderator
    Posted 14 years ago #

    Javascript.

    If the theme has it and it;s conflicting, that could do it, especially if it's running on every single page load (including the admin area).

    Talk to your theme dev.

  11. phofer
    Member
    Posted 14 years ago #

    My problem with image editing was that the thickbox appeared but there was no content, only a big blank area.

    I've spent some hours to track it down - maybe the solution is useful for somebody else:

    - Editing an image needs the file "editimage.html". (Folder: wp-includes/js/tinymce/plugins/wpeditimage/)
    - "editimage.html" requires "./js/editimage.js".
    - Due to an installation problem earlier, the folder "js" didn't have sufficient file permissions. So I've changed the rights of the folder to 775
    - "./js/editimage.js" is responsible for preparing the generic "editimage.html" and making it visible. Thus, it's working fine now.

    in retrospect, the error could easely be noted, as in the script part of the interpreted editimage.html, behind js/editimage.js, there was a "HTTP 403 Forbidden" error. (Such things can be inspected e.g. by Firebug.)

  12. VFHwebdev
    Member
    Posted 14 years ago #

    I've isolated my issue to be related to a short code I created using a tutorial I found online. Here's the function causing the problem.

    function sc_liste($atts, $content = null) {
            extract(shortcode_atts(array(
                    "num" => '5',
                    "cat" => ''
            ), $atts));
            global $post;
            $myposts = get_posts('numberposts='.$num.'&order=DESC&orderby=post_date&category='.$cat);
            $retour='<ul>';
            foreach($myposts as $post) :
                    setup_postdata($post);
                 $retour.='<li><a href="'.get_permalink().'">'.the_title("","",false).'</a></li>';
            endforeach;
            $retour.='</ul> ';
            return $retour;
    }
    add_shortcode("list", "sc_liste");

    I'm still trying to figure out exactly what part is the problem. I'm not a programmer so it's slow going. The tutorial for this is here: http://www.smashingmagazine.com/2009/02/02/mastering-wordpress-shortcodes/

  13. VFHwebdev
    Member
    Posted 14 years ago #

    Well, I think this was a really strange fluke. I don't think it had anything to do with that short code function after all.

    I was trying to work through the function one line at a time. I wasn't changing anything really, I just removed the line break before the beginning of the function and magically everything started working again.

    I "undid" the delete, posted functions.php and the problem comes back.

    Is it possible I picked up a random corrupt character or something in copying and pasting from that tutorial?

  14. andrea_r
    Moderator
    Posted 14 years ago #

    Yep, especially if you just scraped it from the front page.

About this Topic

  • Started 14 years ago by VFHwebdev
  • Latest reply from andrea_r